1. jxke's Avatar
    I cannot recall if my wifi here ever worked since my network carrier here has a promo wherein I pay 50php for 1 day of internet usage. But then, I realized that we had wifi here at home, well not always. But the main problem is, it doesnt work on my bb. It reads my wifi router(linksys) but the wifi icon doesnt turn white. it's always gray.

    That's odd because when i'm scanning for networks and i connect, it always says "wifi setup complete" But it doesnt show a check mark, it just shows a dash mark.

    I tried to look for a problem and when i go to services status, my Blackberry internet service is not connected. But I have an active profile of linksys
    09-18-10 06:08 PM
  2. Fubaz's Avatar
    It can take 2-5 minutes for your wifi icon turn white.

    I have no issues with my Linlsys router running WPA-2 security.

    Go into your wifi setting through your options menu and delete all the profiles and try setting it up again.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-18-10 06:33 PM
  3. jxke's Avatar
    It's already 5 minutes and I did what you told me to and still it's doesnt turn white but the wifi connection stated that it was successful
    09-18-10 07:06 PM
  4. Rootbrian's Avatar
    I cannot recall if my wifi here ever worked since my network carrier here has a promo wherein I pay 50php for 1 day of internet usage. But then, I realized that we had wifi here at home, well not always. But the main problem is, it doesnt work on my bb. It reads my wifi router(linksys) but the wifi icon doesnt turn white. it's always gray.

    That's odd because when i'm scanning for networks and i connect, it always says "wifi setup complete" But it doesnt show a check mark, it just shows a dash mark.

    I tried to look for a problem and when i go to services status, my Blackberry internet service is not connected. But I have an active profile of linksys
    Can you browse the web using your blackberry's browser while connected? I can, only if I use my old linksys-based router. It never works on my belkin, which i'm dreadfully selling.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-18-10 07:19 PM
  5. jxke's Avatar
    Oh gosh, I think I solved my problem. When I deactivate my mobile network, even though the wifi is gray, the internet is working. Only problem is, how can I now receive SMS messages while Wifi is on
    09-18-10 07:25 PM
  6. Fubaz's Avatar
    I cannot recall if my wifi here ever worked since my network carrier here has a promo wherein I pay 50php for 1 day of internet usage. But then, I realized that we had wifi here at home, well not always. But the main problem is, it doesnt work on my bb. It reads my wifi router(linksys) but the wifi icon doesnt turn white. it's always gray.

    That's odd because when i'm scanning for networks and i connect, it always says "wifi setup complete" But it doesnt show a check mark, it just shows a dash mark.

    I tried to look for a problem and when i go to services status, my Blackberry internet service is not connected. But I have an active profile of linksys

    something i missed.... back up where I underlined and bolded.... I assume it sounds like you are trying to get on someone elses wifi. and if you dont always have it... you are able to connect to it for networking but UNABLE to connect to it for internet.... If you have 1 or 0 greens bars when scanning for WiFi this would be the assumed issue.
    09-18-10 07:25 PM
  7. jxke's Avatar
    I swear that this is our router. I just dont know why we don't bother to tell the technician that the wifi has been on "on-off" mode. Our router is linksys and so is our wifi
    09-18-10 07:33 PM
  8. Rootbrian's Avatar
    I swear that this is our router. I just dont know why we don't bother to tell the technician that the wifi has been on "on-off" mode. Our router is linksys and so is our wifi
    Tried hitting the Reset button on the back of the router?

    Press it once, don't press and hold it.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-18-10 07:39 PM
  9. jxke's Avatar
    One more problem, earlier I mentioned that wifi is working when I deactivate my mobile network. I managed to download fb and twitter for bb and appworld. But when I click on them, they all stated something to do that i dont have internet connection But i tried browser, and still I have wifi
    09-18-10 07:55 PM
  10. Motorcycle Mama's Avatar
    You must have a BlackBerry Data Plan in order to use BlackBerry Data features (including Facebook, Twitter, and BlackBerry App World) even over WiFi.
    09-18-10 08:43 PM
  11. jxke's Avatar
    ^What's a data plan? Sorry for my ignorance
    Oh no, I think that "data plan" got erased when I reformatted my bb because of a JVM error
    09-18-10 08:58 PM
  12. Rootbrian's Avatar
    ^What's a data plan? Sorry for my ignorance
    Oh no, I think that "data plan" got erased when I reformatted my bb because of a JVM error
    The data plan is with your cellular carrier. It doesn't get deleted when you need to wipe & reload the OS your blackberry.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-18-10 09:00 PM
  13. jxke's Avatar
    ^Oh, so do they reinstall it on my phone? Or do I just have to call them?
    09-18-10 09:04 PM
  14. Rootbrian's Avatar
    ^Oh, so do they reinstall it on my phone? Or do I just have to call them?
    If you can use BBM, e-mail, the native browser and app world when wi-fi is not turned on, you have a data plan. It is a feature and it is included in your Carrier's plan. Your carrier can better explain what it is.

    Without a data plan, most of the features, internet wise, are useless on a blackberry.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-18-10 09:08 PM
  15. jxke's Avatar
    ^Ugh I can't use bbm and all you've mentioned without my wifi being turned on. I think I did something wrong when I reformatted my bb when it got a jvm error
    Before i got the jvm error, my bb worked so smoothly
    09-18-10 09:25 PM
  16. Rootbrian's Avatar
    ^Ugh I can't use bbm and all you've mentioned without my wifi being turned on. I think I did something wrong when I reformatted my bb when it got a jvm error
    Before i got the jvm error, my bb worked so smoothly
    You need to give your wireless carrier a phone call.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-18-10 09:26 PM
  17. queenkow's Avatar
    Oh gosh, I think I solved my problem. When I deactivate my mobile network, even though the wifi is gray, the internet is working. Only problem is, how can I now receive SMS messages while Wifi is on
    I get the same problem too.

    And then i subscribed to a daily plan!!

    When i switch it off, the plan i mean, i can't seem to use the browser anymore!!!

    HELP!!
    09-27-10 05:37 AM
  18. Rootbrian's Avatar
    I get the same problem too.

    And then i subscribed to a daily plan!!

    When i switch it off, the plan i mean, i can't seem to use the browser anymore!!!

    HELP!!
    Well then, TURN IT BACK ON! Then you'll be able to access the internet from your phone's browser.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-27-10 02:53 PM
LINK TO POST COPIED TO CLIPBOARD