1. Artemis22's Avatar
    So i have my brand new blackberry bold and i am trying to connect to my home wifi network but even though it says that it is connected in my manage connections tab there is a white dash showing that it isnt really connected and since i dont have a data plan i cant use any sort of data on my phone. My router has WPA-2 security, and it works fine on all the computers in my house and on my friends iphone. Any advice as to how i could get this to work would be highly appreciated.
    03-20-10 04:16 PM
  2. owlyn's Avatar
    It is a well-known problem with no known solution. After researching every thread here and Googling for the problem, I have concluded that the problem is rerstricted to routers that have security enabled, especially WPA-PSK, and that RIM has no clue how to fix it.
    03-20-10 04:56 PM
  3. mandony's Avatar
    I agree, this is a RIM problem.
    I did not have a problem connecting until I upgraded from 4.x.
    One conversation that I tried did not work ... perhaps it will work for you:

    03-20-10 07:22 PM
  4. Artemis22's Avatar
    Ya nothing seems to be working. This is a really stupid problem that could easily be fixed with a software update
    03-21-10 10:54 PM
  5. dp867's Avatar
    Sorry to hear, have you tried connecting to other wi-fi networks? (i.e. a friends' house) -- If that works than we may narrow down the problem (if it isn't rim)
    03-22-10 12:30 AM
  6. owlyn's Avatar
    The typical scenario is that it works fine at public WiFi spots (Starbuck's, Cosi, etc.), but not with a home router that has encryption turned on.
    03-22-10 08:07 PM
  7. alisan8's Avatar
    hi there, i have similar problem when i upgraded to os 5, however i can manage to surf the web using the browser, by going to browser >option> browser configuration > make sure u choose "hotspot browser" . that should do the trick.

    I however still unable to run my BBM with wifi, help anyone? its funny i used to be able to access BBM on my 4.6 version, but since upgrading to 5.0 seems unable to connect to bis.

    pls help

    03-23-10 10:44 AM
  8. owlyn's Avatar
    Hotspot browser does not solve the issue for everyone.
    03-24-10 05:41 AM
  9. ab.riyami's Avatar
    Hello ppl,

    I have a similar prob with my BB,, At some Wifi areas i can connect (security enabled) but at other places its impossible, I've searched for all different solutions but nothing worked, it seems the Bold has a mind of its own the same type of connection WPA-Psk in two different networks....one connects the other doesnt....

    what i have found out is....the BB actually manages to get a connection but what fails is the device trying to connect to "BlackBerry Infrastructure" ports....i thought maybe some routers restrict outbound connection attemts but couldnt find a solution.
    if ther is anyone who could help me please reply or msg me on Crackberry....cant post my email here ........... thanks ppl.
    04-05-10 01:35 AM