1. lindros2's Avatar
    Before people respond with "mine is great", hear me out.

    I've owned three GPS-enabled BlackBerry devices, and they've all been bad.

    My current Bold, which worked "okay", has become a nightmare (with OS It now takes 10-20 MINUTES to pick up a signal - especially when I'm out of town.

    Back to my first comment - it's worked okay for a short period of time - but that is like saying that you can play in the PGA because you made par on a hole...

    Posted from my CrackBerry at wapforums.crackberry.com
    02-08-11 10:41 AM
  2. i_hiker's Avatar
    I found the GPS in the 9650 to be more responsive than my 9630. I've found the 9650 OS6 GPS to be more responsive than OS5. I mostly use the GPS with my weather app and it seems to lock in fairly quickly....2-3 minutes at most. On OS5 I used .975. Sorry...really don't have any constructive suggestions other than to search the GPS and Mapping threads. Good luck!
    02-08-11 10:51 AM
  3. Culex316's Avatar
    Try upgrading to OS6, GPS response there is quick.

    Also are you getting network coverage? AGPS needs it to get a quicker lock, otherwise 10-20 minutes is the norm for an autonomous GPS unit
    02-08-11 12:26 PM
  4. lindros2's Avatar
    Thanks for the quick replies.

    I'm able to get to 1000-2000m pretty quickly. In the past (about a month and a half ago), that was goofed up (it had me 1000 miles away in the middle of the Gulf of Mexico).

    Now, I'm getting a pretty quick lock in my home area (8-10m). But once I travel, it's crap (back to the 1000-2000 for the first 20 minutes).

    For comparison, my wife's phone (Droid Incredible) gets an INSTANT lock (GPS and direction/compass).
    02-08-11 12:35 PM
  5. combroker's Avatar
    I use the VZ Navigator all of the time. Suddenly, I too had difficulty in getting connected, and all the Verizon Techs did was reinstall it, but that actually made things worse. I kept getting an error message that no one understood, and I also could not update the roaming capabilities. After three hours, I was put through to a "VZ Navigator Specialist", who told me there was definitely a problem with reloading. I had to leave, so decided I would deal with it the next day. When I came back that next day, the first think I did was sync, and it offered me the upgrade to OS Immediately, the problem was gone. VZ Navigator was perfect. The only thing I had to do was to do several battery pulls, and everything seems to be in working order. I have had no difficulty with battery drain and other problems that several other readers have. I am no techy - I don't know what was wrong or why 6.0 fixed it - but it did!
    02-09-11 08:48 AM
  6. combroker's Avatar
    By the way, when I was having a problem with VZ Navigator before, the error message I kept getting was that the device could not find my current location, so everything came to a screeching halt from that point.
    02-09-11 08:50 AM