1. rboetger's Avatar
    When I first purchased my Storm none of my Bluetooth devices worked. The Desktop Manager, my headset, nor my car would work properly. Finally after 3 beta releases RIM got it right.

    I upgraded to OS 5 and now I am having the same problems. It took me forever to get the Desktop Manager to connect up to my Storm correctly and consistently with the Bluetooth. I cannot get to work with my Toyota!! It pairs but when a call comes in or I try to make a call neither the Storm or the car can talk or listen on the phone.

    Any fixes for this?
    06-04-10 07:41 AM
  2. Kanga717's Avatar
    Had the same issue with my Motorola and Jabra bluetooths. Went to the Blackberry site and downloaded the downgrade to OS 4.7. Everything works fine again now. Version 5.0 must have a major glitch.
    06-04-10 06:52 PM
  3. Shadrackc's Avatar
    Have a storm 2 and my jabra, nissan bluetooth, sony headset, all work like advertised. Perfectly.
    06-06-10 10:44 AM
  4. chuckh0308's Avatar
    What OS are you on? There were some unnoficual leaks that had issues, but most of the carrier approved OS's were fine...the exception being that some people had BT problems with the VZW .328 release. If that is what you're on then I would switch to the .419 (or maybe newer?), as that will fix BT problems and a host of other issues. Another ootion would be to insert the BT handler from another OS. There are instructions somewhere in the OS section. I did it on my 9530, but it was awhile ago and I can't remember which file or OS to use as the host. It did work though!

    Anf you have no idea what BT problems are until you own an iPhone. I am convinced that Apple just plain doesn't want people using BT devices...lol.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-06-10 01:34 PM
  5. docdfour's Avatar
    Yeah, .419 is definitely the way to go for BT. 591 doesn't have any issues connecting, but overall volume is a bit lower than on .419

    Posted from my CrackBerry at wapforums.crackberry.com
    06-06-10 06:51 PM
  6. rboetger's Avatar
    I am using OS version that I installed from the BlackBerry Website.

    How do I get the previous release version of the OS?

    This just SUCKS that Rim can get this right!!!
    06-07-10 01:56 PM
  7. rboetger's Avatar

    I updated to OS and now all of my Bluetooth devices work.
    06-09-10 12:28 PM