1. Anthonyy_B's Avatar
    I have a verizon BlackBerry Q10 and I put a T-Mobile sim in it and I get 4G and everything with it, I use the verizon sim in my iPhone 5s because through my company I had an upgrade on the BlackBerry number so the verizon sim is too small for the BlackBerry. Now when I start up my BlackBerry it doesn't say verizon it says T-Mobile and my verizon sim doesn't work when I make calls anymore. I did a security swipe and it came back up as verizon om start up and gives me verizon 4G LTE but when I go to make a call it goes to 4g (lowercase g) and won't even ring. So I did another security swipe and am using tmobile again. But when I put my dad's verizon sim from his Z10 it says network global and connected to verizon 4G LTE but still gives the same problem when trying to call.....anybody know what this problem can be? i'm currently using tmobile on it now because of this verizon problem....it is a verizon phone though it says verizon on the actual phone under the space bar and on the back battery cover it says Verizon 4G LTE

    Posted via CB10
    01-31-14 09:48 AM
  2. bunky1971's Avatar
    Change your network mode to LTE/CDMA

    Sent from my Transformer TF101 using CB Forums mobile app
    02-01-14 03:05 PM
  3. Anthonyy_B's Avatar
    I tried that....i still went to small 'g' when making a call. I'll try it again later with my dad's verizon sim from his Z10....thanks

    Posted via Q10
    02-02-14 10:01 AM
  4. bunky1971's Avatar
    The other thing i do when swapping vzw and tmo sims in both z10 and z30, is put the device in airplane mode and `hotswap` the sims, sometimes ill reboot but 90% of the time, changing from LTE/CDMA to 4/3/2G and vice versa does the trick

    Sent from my Transformer TF101 using CB Forums mobile app
    02-02-14 01:56 PM

Similar Threads

  1. Verizon Z30 Pre-Production Model What OSes will load?
    By 1magine in forum BB10 Leaked/Beta OS
    Replies: 19
    Last Post: 02-02-14, 03:52 PM
  2. issue with bridge to playbook since 10.2.1 update
    By tkgafs in forum BlackBerry Z10
    Replies: 12
    Last Post: 02-01-14, 10:27 PM
  3. My first 7 Days with my new z30
    By bakron1 in forum BlackBerry Z30
    Replies: 7
    Last Post: 02-01-14, 04:43 PM
  4. Wind Mobile Canada 10.2.1 Update
    By heyitscarter in forum General BlackBerry Discussion
    Replies: 1
    Last Post: 01-31-14, 07:19 AM
LINK TO POST COPIED TO CLIPBOARD