Sign up now for Disney+
  1. hobbs's Avatar
    Good morning all...

    This morning, I changed the forwarding email account for my beloved crackberry.com email address. This change went from a Verizon account to a GMail account. With this change, a new issue has appeared (and it is not the receiving sent emails issue so widely posted about). This issue relates to the address shown when the recipient receives my emails.

    The BIS settings for my GMail account match that of my Verizon account, but recipients are seeing my .gmail.com email address in the message header instead of the crackberry.com email address. If the recipient replies, it does get sent to the crackberry.com email address... but the idea of advertising the gmail.com email address is something that I'd rather not do.

    Looking at my past verizon.net emails, my crackberry.com address is what has always appeared... just how I liked it.

    Thoughts?

    Thank you in advance for your time!
    06-14-07 11:59 AM
  2. anon(153966)'s Avatar
    Your 'original' GMail account, does it FORWARD emails to your Verizon BlackBerry email address? If yes, then make the properties look like:



    If the email is NOT being forwarded to your Verizon BlackBerry email (BIS), I think you're going to have the present issue you have. Even if you log into GMail and add another address as a reply address it will always read: Sent from hobbs@gmail on behalf of hobbs@crackberry.com
    Last edited by navilyn; 06-14-07 at 12:22 PM.
    06-14-07 12:18 PM
  3. hobbs's Avatar
    No...

    My crackberry.com address is now forwarded to my gmail.com address. On the BIS setup side, my reply address for the gmail.com address is my crackberry.com address. I assume this is why the forwarding and replying all work fine? I'm just seeing that emails I send from my BB are showing that they were sent from gmail.com and not from crackberry.com. When I was using verizon.net instead of gmail.com, they appeared as being sent from crackberry.com... which is how I want it to work.

    Thanks!
    06-14-07 12:44 PM
  4. anon(153966)'s Avatar
    Ok, so, when you log into your BIS account on Verizon, the 'properties' for that account should show from @crackberry.com and reply to the same thing. I suggest removing the account in BIS, and re-adding it. While doing so double checking the from / sent to address...
    06-14-07 12:54 PM
  5. hobbs's Avatar
    Ahhh... for the love of Pete! I see the error of my ways. I failed to change the Email Account Name field to be crackberry.com as well.

    Sorry for the oversight... but thank you for the help
    06-14-07 01:01 PM
  6. hobbs's Avatar
    Well... it looks as if I spoke too soon. That still did not accomplish what I am hoping for.

    The following are my settings on the BIS setup:

    Email account name: CrackBerry
    Reply to: username@crackberry.com
    Your name: myname
    User name: username@gmail.com
    Password: *************
    Signature:
    Auto BCC:
    Delete items: selected

    After completely recreating the account and making these changes, I am still finding that any email sent from the CrackBerry account on my BB still advertises the gmail.com account to the recipient. As mentioned before, if the recipient were to reply to the message, it does indeed send to the crackberry.com address. I'm just not liking the fact that recipients are seeing the gmail.com address.

    I have tested this issue by sending emails to myself and viewing them on both my BB and PC. Each displays the gmail.com address as the sender.

    Thanks!
    06-14-07 03:04 PM
  7. anon(153966)'s Avatar
    If I understand you correctly, thus far: This is how it should be for this to work (I believe) have your GMail set to FORWARD a copy of your GMail to your whatever@vzw.blackberry.net (or whatever the BIS email address is). Now configure you VZW BIS address with properties pertaining to @crackberry.com.

    If you used another account, like a normal POP3, other than GMail, it would work the way you're talking about. I beleive albeit GMail is in BIS, when emails are sent it's looking at 'your TRUE GMail account' thus getting the 'sender info' of hobbs@gmail.com. Make sense?
    06-14-07 03:22 PM
  8. hobbs's Avatar
    Below is the cycle of my email...

    1. I send a message from my BlackBerry, using the GMail account. (this is the BIS account that I gave the settings for above).
    2. Recipient receives the email, showing that it was sent from the gmail.com address.
    3. Recipient replies to the email, showing that it will be sent to the crackberry.com address... which is then forwarded to my GMail account.

    What I am looking for is a way that the recipient sees the crackberry.com address instead of the gmail.com address in Step 2. Based upon suggestions above, it looks as though I can change some prefs to my GMail account that would get the job done. I hope

    I will let you know! Thank you again for your time!
    06-14-07 03:59 PM
  9. anon(153966)'s Avatar
    I totally get it, BELIEVE me! But we're missing one main part of the puzzle. For GMail in particular, if your email is not fowarded to you VZW email account it does not work like you want it to. I've tested it many times.

    I'll test it again tonight, and advise...
    06-14-07 04:03 PM
  10. hobbs's Avatar
    Good news!

    GMail allows you to add non-Gmail email addresses to their Settings. By Doing this, I was able to set my crackberry.com email address as the default... then set all replies to be sent from the default address. It seems to work... only Micorsoft Outlook (not Express) shows the from as: Sent from gmail.com on behalf of crackberry.com, but this issue is addressed during the settings change.

    So... for now... it looks like I can live with it. Thank you again for your time and take care!
    06-14-07 05:20 PM
  11. anon(153966)'s Avatar
    Err, I said that in post number 2!?!

    Nonetheless, I tested it again, to make sure I wasn't losing my mind, and I was right in my thinking.

    Mine works correctly because I use a POP3 account (i.e. NOT a GMail account), and thus can give it ANY properties I want, i.e From: whatever@crackberry.com and Reply To: whatever@crackberry.com...
    06-14-07 08:21 PM
  12. J. Rehak's Avatar
    Just wondering why anyone would need a crackberry.com email address, as most (?) have a "regular" email account, plus Blackberry can also provide one?
    07-10-07 12:25 AM
  13. bikerider's Avatar
    First post, please be kind . I had the same problem with my gmail address showing up with the "on behalf of" my ISP email address. I had my ISP address set up as the "reply to" address both in BIS and gmail. When I removed this from my gmail account it solved my whole problem, now all emails sent from my BB only show my ISP address, even on MS Outlook and Exchange.

    Hope this helps - I am new to BB's and just got my 8310 4 days ago. This forum has been a great resource!

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by bikerider; 01-22-08 at 02:19 PM.
    01-22-08 11:19 AM
  14. chaz_cb's Avatar
    Simply to show our CrackBerry pride!

    Posted from my CrackBerry at wapforums.crackberry.com
    01-22-08 12:10 PM
  15. jknotzke's Avatar
    Err, I said that in post number 2!?!

    Nonetheless, I tested it again, to make sure I wasn't losing my mind, and I was right in my thinking.

    Mine works correctly because I use a POP3 account (i.e. NOT a GMail account), and thus can give it ANY properties I want, i.e From: whatever@crackberry.com and Reply To: whatever@crackberry.com...
    I am coming to this via a search.. So please excuse the delay.

    But I am trying to reconcile this very problem.

    Just so I understand, is there anyway to hide or rid of the "on behalf of" in Outlook? I seem to have it working fine everywhere else.

    J
    03-16-08 08:20 AM
  16. lush242000's Avatar
    A crackberry address is ******** awesome!
    03-16-08 08:57 AM
  17. Online's Avatar
    How do you get a @crackberry.com address?
    03-16-08 08:17 PM
  18. Anilu7's Avatar
    Go to My Account and sign up for it. Lol this is 5 years late in replying but others might find it useful...
    10-26-13 05:10 PM
LINK TO POST COPIED TO CLIPBOARD