1. jjvd21's Avatar
    I searched the threads but can't find anything.

    I upgraded to v5.0.0.822 and now my wifi won't connect. My work IT people cannot figure it out, they've tried reinstalling my root certificate, etc. They say they've never seen this before.

    Any advice or instructions on how to go back to a previous software version? Thanks!
    09-27-10 10:03 AM
  2. Ahmed G.'s Avatar
    Download OS 5.0.0.681 by Hutchison or Vodafone UK ( search for it here ). I would have given you the link, but I'm not sure if you own a 9000 or an 8900 .

    After you download and install the OS, follow the steps HERE

    Since you will downgrade, you should select ''replace the files from the Software .. or something like that ;p '' when prompted
    09-27-10 04:35 PM
  3. jjvd21's Avatar
    Thanks for the reply. I have a Curve 8900 on AT&T. Will the Vodafone UK or Hutchison version work for USA? Thanks!
    09-28-10 09:50 AM
  4. Ahmed G.'s Avatar
    Yes, they both will . .You only need to Delete a file called Vendor. Its location is specified in the Link given above ( Upgrading Steps )
    09-28-10 10:29 AM
  5. breakmedown's Avatar
    The DM should have a few "downgrade" options. Mine always does. I think they're 4.6something.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-28-10 11:53 AM
  6. WhiteDevil666's Avatar
    I have a wifi problem too. Mine will "connect" but the wifi indicator is grayed out. Happens on the routers at work, home, and at least 3 restaurants. I switched to att .822 to try and fix the problem and it's the same. I had been running Hutchinson .681 with the same performance. I think there is another problem keeping us from using wifi.
    09-28-10 12:03 PM
  7. Ahmed G.'s Avatar
    I have a wifi problem too. Mine will "connect" but the wifi indicator is grayed out. Happens on the routers at work, home, and at least 3 restaurants. I switched to att .822 to try and fix the problem and it's the same. I had been running Hutchinson .681 with the same performance. I think there is another problem keeping us from using wifi.
    Try the following;

    - go to Browser and click on the BB menu button
    - select options > Browser Configuration

    > set Browser to ( Hotspot Browser )
    > set Browser Identification to ( BlackBerry )

    Mind you, that I have Browser set to "Internet Browser" and I'm having no issues connecting to Wi-Fi. Some, however, have had to set it to Hotspot Browser to connect to a Wi-Fi network
    Last edited by Ahmed G.; 09-28-10 at 04:38 PM.
    09-28-10 12:13 PM
  8. jjvd21's Avatar
    I downgraded per Ahmed G.'s (thanks) post and my wifi is now working again fine. It definitely was the 5.0 version that was derailing my wifi connection. As soon as I went back to 4.6 (or whatever the version is) it connected immediately. Not that this matters, but my company has 1,600 employees in my location with a staff of 15 IT folks, my IT guy said that he's heard that 5.0 causes wifi problems and if I downgraded it would work again. He was right.
    09-28-10 01:32 PM
LINK TO POST COPIED TO CLIPBOARD