1. Doom4life's Avatar
    Issue: Downgrading from .419 to .328, MTP Mode Error and endless reboot as long as device is plugged into a USB port
    Troubleshooting:
    • Reloaded .419 fixes the issues, downgrading to .328 brings back the reset loop
    • Device works on another Windows XP machine, but not an another Windows 7 machine


    I'm trying to troubleshoot a problem with my 9530. About a month ago, Iupgrade fromthe .328 OS to a newer .419 OS. It was ok, but I liked how .328 ran so I decided to downgrade.

    However, I ran into a problem after the apploader would load the OS to the device memory. Once it restarted (just before the second half of a new OS load), the phone would briefly flash a white screen with "MTP Mode Error" and restart. This would result in the appload.exe failing to reload the .328 OS.

    However, if I reload .419, apploader.exe sucesfully reloads without any error, and al is good (except I want .328). This is on a Windows XP laptop, so I decided to try it on my desktop (also running Windows XP). For whatever reason, it works and loaded .328 up. Now the problem I am running into is that anytime I plug my 9530 into the latop, it immediately flashed the Unknown MTP mode screen and goes on an endless reboot loop (unless I unplug the usb chord).

    I don't know what it is, but I doubt its Windows XP, as it'll show the error and reboot if I plug the phone into the laptop before Windows even has a chance to load. However, if I plug in my 8330, it has no issues. I also just tried the 9530 on a Windows 7 PC and it also flashes the MTP mode error.

    Anyone found a fix for this issue?
    07-17-10 10:48 PM
  2. amazinglygraceless's Avatar
    Given how clearly you laid that out I am going to assume you don't need "baby
    step" explanations.

    A few things I would try:
    1) Before anything else, copy the contents of the memory to the computer.
    2) Format the memory card.
    3) Downgrade the OS without the memory card in the device
    4) If the d/grade succeeds out the memory card back and copy the data back
    from the PC to the card.
    5) Reboot the phone and make sure all is normal.
    07-17-10 11:02 PM
  3. Doom4life's Avatar
    I just removed the memory card and puled the battery. Once it restarted, I plugged in the USB cable an the same MPT error with a white screen.

    I'm going to try wiping with BBSAK and reloading (without the mmory card), but I fear it will require me to reload .328 on my desktop....
    07-17-10 11:07 PM
  4. jimmythebest's Avatar
    Any of you guys solved the problem already???? I'm having the same difficulty...
    11-08-10 12:59 PM
  5. Reed McLay's Avatar
    The original poster was experiencing an OS version specific problem.

    Which model do you have and what is the error message/state you see?

    Were you attempting to do an OS upgrade?
    11-08-10 01:16 PM
  6. cellfonepimp's Avatar
    Im also having this issue, I dont think it an OS issue or a cable issue. For whatever reason only BB storms and not all of them, its intermittent and confusing. My problem only started when I installed a new hard drive and needed to install all my programs all over again.

    So I think its the new configuration, so Im currently checking my system and trying to pinpoint the problem.
    11-17-10 04:31 PM
LINK TO POST COPIED TO CLIPBOARD