1. CloakedGod's Avatar
    i have the tmo .330 bold and am having problems connecting to my university's wifi network. i can connect to any other network, but not this one. it says im connected but without internet. it also shows as error with the DNS server. i even went and manually entered in the info for the ip config and still cannot get internet. What should happen is after i connect and try to goto a website, i will be redirected to register the device through my schools username and password, then restart the device and done.

    any advice? other people with iphones and android based phones can connect, but not me. i dont know of anyone else with the bold either so i cannot test it.

    thanks in advance.
    02-11-10 06:17 PM
  2. howie's Avatar
    Are you sure you have all the proper information needed? Sounds like perhaps the gateway IP or DNS or something.
    02-11-10 06:37 PM
  3. CloakedGod's Avatar
    its all set automatically. i did do it manually and got the same error. this really sucks. i only get edge near the U
    02-11-10 07:55 PM
  4. CloakedGod's Avatar
    BUMP! ok, so i have some new information, i was able to connect to wifi once after messing around with the settings. i currently cannot any longer, i get a w004.x error. it has something to do with the browser redirect after connecting (to enter in your university username and password to gain net access). does anyone have any idea as to what the settings need to be for this to work? im getting annoyed, my moto zine zn5 connected instantly without a problem and my blackberry cannot??
    02-16-10 10:29 AM
  5. GJW's Avatar
    BUMP! ok, so i have some new information, i was able to connect to wifi once after messing around with the settings. i currently cannot any longer, i get a w004.x error. it has something to do with the browser redirect after connecting (to enter in your university username and password to gain net access). does anyone have any idea as to what the settings need to be for this to work? im getting annoyed, my moto zine zn5 connected instantly without a problem and my blackberry cannot??
    If a manual login is required, go into Wi-fi Options and turn on the check box for "Prompt me when manual connection or login is required"
    02-16-10 10:34 AM
  6. CloakedGod's Avatar
    i did that, and to no avail. it doesnt require you to login every time, it actually registers your mac address. its a one time deal.
    02-16-10 10:37 AM
  7. idfx's Avatar
    check what kind of security certificate your university uses, and then select that on your blackberry.

    My university uses Thawte Premium, and is WPA
    02-16-10 01:12 PM
  8. CloakedGod's Avatar
    that sounds promising, but how do i determine what security certificate they are using? also, how do i "select" it
    Last edited by CloakedGod; 02-16-10 at 01:34 PM.
    02-16-10 01:32 PM
  9. CloakedGod's Avatar
    wait, are you talking about the encryption method? ie WPA WPA and WEP etc.?

    they use no security like that
    02-16-10 01:43 PM
  10. syb0rg's Avatar
    Sounds to me like they have a splash shield up preventing you from logging onto their network. i read an article that stated alot of colleges are starting to do that to keep the bandwidth up for those that were using Netbooks/notebooks.
    02-16-10 02:13 PM
  11. Artwerks's Avatar
    check what kind of security certificate your university uses, and then select that on your blackberry.

    My university uses Thawte Premium, and is WPA
    So does my university, it uses WPA. I use an Entrust certificate (I use the same certificate as my laptop uses...) and now it works. I had the same problem connecting to the internet last month, the icon stayed gray until then!
    02-16-10 02:46 PM
  12. CloakedGod's Avatar
    So does my university, it uses WPA. I use an Entrust certificate (I use the same certificate as my laptop uses...) and now it works. I had the same problem connecting to the internet last month, the icon stayed gray until then!
    can you explain how you discovered the certificate type and how you selected it on the blackberry please. i i feel like a super noob. my university uses no encryption so i dont know if that makes a difference.

    also, i noticed i was able to connect fully to the network with internet in 2 buildings, but not in the others... very strange. i was thinking about upgrading to the latest version OS listed on this site. maybe that would help.
    02-16-10 03:45 PM
  13. idfx's Avatar
    can you explain how you discovered the certificate type and how you selected it on the blackberry please.
    If you have the internet working on your laptop, normally just go to the connection settings, and "manage wireless networks"
    Find your schools network, go to its properties, look for the security tab,
    then choose settings.
    Under that look at the list called trusted root certificates, and look for whatever is checked off.
    Whatever is checked off is the security certificate.

    Now go to your blackberry, under WiFi setup, there will be a place that says security certificate ... find it, and change it accordingly.

    Hopefully your wifi will work now
    02-17-10 11:42 AM
  14. TheBiggmann's Avatar
    I've got the same problem man. Lemme know if you figure this out. IDFX, i'm not finding anything about certificates in the wi-fi settings on my 9700 just fyi.
    02-17-10 05:00 PM
  15. idfx's Avatar
    I've got the same problem man. Lemme know if you figure this out. IDFX, i'm not finding anything about certificates in the wi-fi settings on my 9700 just fyi.
    ASSUMING your school uses wpa/peap to logon, and thawte premium I suggest erasing any previous wifi profiles for it and adding a manual one with the following steps:

    Go to manually add network:
    -enter the schools networkname(SSID)
    - security type: PEAP --> will give you the following:
    -Username: your logon name
    -password: your password
    -CA certificate: select thawte PREMIUM, or whatever certificate your school uses
    - leave everything else as is
    02-17-10 09:26 PM
  16. TheBiggmann's Avatar
    Hmmm, I can try that today. The only thing is that every building is different. Each network is like UWNet-Ag Hall, UWNet-Chemistry, stuff like that. It says there is no security though when i check on my laptop. When you log in it always brings up a page that you have to sign into, its not a box that pops up. Dunno if any of this makes a difference. I will try what you posted though, thanks!
    02-18-10 01:54 AM
LINK TO POST COPIED TO CLIPBOARD