1. lost2118's Avatar
    I have a 8320 for T-Mobile and I bought this phone 1 week ago. I do NOT have the hotspot at home and do not want it.

    When at home or around any wireless router during phone calls I get disconnected within 5 minutes and it says "Call Failed". I did happen to notice that it says UMA when I am disconnected and I don't know what this UMA is or does either. Is there any way to stop this? I need someones help please. I don't know what other information to give but if I left something out please ask and I will gladly tell.

    Sorry I am new but I searched and I couldn't find anything, also my first BB.

    Thanks
    01-26-08 03:15 PM
  2. SLVR6's Avatar
    Turn off your wifi then! UMA is when you berry has connected to T-mobile servers and is routing your call through the internet (VOIP). The hotspot@home package gives you unlimited calling when connected via UMA. Hope that helps.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-26-08 05:00 PM
  3. John Clark's Avatar
    This is usually caused by an incompatible router, router firmware, or router settings. As SLVR6 said, UMA is the wifi phone/data service through TMo or H@H. You don't need the H@H plan in order to use the UMA service. The H@H plan just gives you the unlimited minutes over UMA. Without it you are just using minutes from your rate plan.

    Again, as SLVR said use the manage connections icon to uncheck wifi and your calls won't be routed over wifi.
    01-27-08 02:31 AM
  4. lost2118's Avatar
    Is there a way where I can leave the wifi on and not have it messing up my calls or do I have to turn it off and on everytime I decide to use wifi? When using wifi to surf the internet I have no problems at all and connect to just about all wireless routers around unless they are password protected, so I think the settings are alright but I can only assume so.
    01-27-08 10:32 AM
  5. tomdick's Avatar
    check you OS version and reload it with the most recent up to date from tmoble

    on the other hand wifi on the curve isnt that much faster and unless your surfing a ton of internet it wouldnt hurt to just sut it off
    01-28-08 12:42 PM
  6. bartystewart's Avatar
    Options - Mobile Network - Preferred Connection - Mobile Network Preferred...

    That helped when i was having the same problem... but I'm not sure if it still uses wifi for browsing or not.... does anyone else know?
    02-09-08 01:47 AM
  7. dalsmavsfan#CB's Avatar
    I've have been getting the call failed error since Valintine day. I'm a tmo users and after several hours with customer support have figured out that it only happens from my home calling area. Tmo is sending someone out to look into it.
    02-26-08 08:38 AM
  8. anulke's Avatar
    There is a help file in regard to this on T-mobile's website. It said to turn the phone off, then on...go to mobile network options and click wifi preferred or whatever, save and the pull the battery for 30 seconds.
    I was having this issue and tried it. I then talked on the phone for an hour and it switched back and forth between UMA and EDGE without dropping the call.

    Good luck!
    03-11-08 11:30 AM
  9. tej220's Avatar
    Go to manage connections, then mobile network options, then under network preference, select "mobile network only" this will stop your phone from ever trying to get onto a wifi network. This should help.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-11-08 02:42 PM
  10. kashman's Avatar
    This is usually caused by an incompatible router, router firmware, or router settings. As SLVR6 said, UMA is the wifi phone/data service through TMo or H@H. You don't need the H@H plan in order to use the UMA service. The H@H plan just gives you the unlimited minutes over UMA. Without it you are just using minutes from your rate plan.

    Again, as SLVR said use the manage connections icon to uncheck wifi and your calls won't be routed over wifi.
    I have a different experience... i have a tmobile hotspot router, 8320 and hotspot calling. I still experience the call failed issue.
    02-27-09 02:54 PM
  11. kashman's Avatar
    I've have been getting the call failed error since Valintine day. I'm a tmo users and after several hours with customer support have figured out that it only happens from my home calling area. Tmo is sending someone out to look into it.
    They told me the same thing... they will survey my area and get back to me. Its been a week. Also, they mentioned it could be a defective SIM card.
    02-27-09 02:56 PM
  12. hubermania's Avatar
    I have a different experience... i have a tmobile hotspot router, 8320 and hotspot calling. I still experience the call failed issue.
    I've got a similar setup: Linksys WiFi router to cable modem, 8220 and hotspot calling. I think the phone assumes if you've got a WiFi connection you've got UMA, regardless of whether your WiFi can reach the outside world. I had occasion to restart my cable modem thus creating a temporary WiFi island, and my phone showed UMA the entire time. Naturally I got the call failed beeps when I attempted a call.
    02-27-09 04:46 PM
  13. dervari's Avatar
    I think the phone assumes if you've got a WiFi connection you've got UMA, regardless of whether your WiFi can reach the outside world. I had occasion to restart my cable modem thus creating a temporary WiFi island, and my phone showed UMA the entire time. Naturally I got the call failed beeps when I attempted a call.
    I don't think this is correct. The phone establishes an IPSEC tunnel to a T-Mo server. I blocked IPSEC one tmie at my Firewall and was not able to establish a UMA connection.

    When you rebooted your cable modem the phone probably didn't realize that the tunnel had dropped. By the time it did and tried to re-establish the tunnel, the internet connection was back up.
    02-27-09 09:42 PM
  14. sailorjim's Avatar
    I have had the same problems for almost a month, worked fine until then on my BB 8820 switches from UMA to Edge and then drops my calls - terrible for busines when talking to customers. I have at T-mo support (very poor support too) 1 replaced SIM, 2 replaced phone 3 bouht new T-mo Linksys router and STILL having the problems. This is an outrage!!!

    I wonder if other wifi type devse might be interfering, like a 2.4 GHZ wireless phone or a wireless mouse and keyboard, although I have had the same ones since I bought the phone in Sept. 2008. I did change to Comcast internet, but that was a month before the propblems started. I can't think of anything elses that has chnged.

    You'd think someone at T-mo or BB would have some answer to this.
    04-15-09 03:51 PM
  15. jcoffin1981's Avatar
    I am not an expert on UMA calling. It has been my experience that T-mobile customer and tech support is not very knowledgeable about this service. I have the T-Mobile Lynksys router as well as a Netgear router. I have the same issue that my call quality is poor and I drop the call every ten to 15 minutes. It also seems that it performs much better on the Netgear router than the T-Mobile router. They may do some minor tweaks geared towards UMA calling but I think this is mostly just marketing. I just moved and this problem seems to have improved slightly. Using the same router and a broadband connection I seem to drop less calls. I think the cable line coming in had some imperfections in the signal. (perhaps you time warner customers know what i am talking about, lol) I think this will effect the connection. Does anyone have any experience that one channel is better than another?
    06-09-09 10:29 PM
  16. FricFrac's Avatar
    This is all due to the WIFI Power Mode setting in the engineering screens. The default "auto" setting will often "time out" to save battery. You need to enter the escreens and set it to "normal" or "active." My problem is that my phone will "forget" whatever setting I choose and revert back to auto. Not sure if this could be a battery issue???
    07-26-09 05:45 PM
  17. shoeluvr's Avatar
    You ROCK! I live in a canyon area which does not get reception for any carriers! I got the blackberry 8900 because it has UMA calling through tmobile, so when I am home, my phone automatically uses my dsl router as like a mini cell tower in my home, and i can call and text just fine on the bberry 8900. For some reason, my UMA calling wasn't turning on, and taking the few steps you instructed below did the trick! Thanks a million!
    ================================

    There is a help file in regard to this on T-mobile's website. It said to turn the phone off, then on...go to mobile network options and click wifi preferred or whatever, save and the pull the battery for 30 seconds.
    I was having this issue and tried it. I then talked on the phone for an hour and it switched back and forth between UMA and EDGE without dropping the call.

    Good luck!
    09-02-10 05:23 AM
LINK TO POST COPIED TO CLIPBOARD