1. petworks97's Avatar
    My wife has a Tour and I have a storm 2. Both have the official OS. When she is connected to her Range Rover sport she sounds lick crap. Its as if her voice is over modulated and distorted. When I use my Storm2 I sound fine. Anyone else having this problem and is there a solution? Thanks.
    01-28-10 12:39 PM
  2. wocampb's Avatar
    What OS is she running on her Tour? I had an issue with the Bluetooth in 2 of my cars as well with the original OS that came on the Tour. When I upgraded to the leaked 5.0 OS for the Tour I sounded a lot clearer in my Range Rover. It seems to be problem with the original 4.7 OS.
    01-28-10 01:02 PM
  3. Bl_ai_r's Avatar
    lord, my bosses iphone in his range rover sounds unbelievably bad.
    01-28-10 06:12 PM
  4. talkingcow's Avatar
    this wont help but

    "9780 used to pair perfectly with the manufacturer system on a 2007 range rover sport. Upgrading from 6.00.294 to 6.00.498 results in the phone showing "connection to LANDROVER failed". Pairing appears to work, car is discovered etc, but the process does not complete. Once in about 20 times (of starting the car) the phone will pair and be able to receive calls, but the address book is screwed up.

    Downgrading back to 294 and everything returns to normal working 100% - which is what I have chosen to do as 498 had so little to offer.

    Because RIM are so unhelpful, it is impossible to ask this question:

    "exactly what did you change between 294 and 498 in the bluetooh implementation/code that would cause the problem described above"
    04-03-11 03:23 PM
  5. talkingcow's Avatar
    run through the streets and rejoice! latest Blackberry version restores full Bluetooth connectivity in my RR Sport!!
    06-04-11 03:24 PM