1. Brie_London's Avatar
    Ok, so I see other posts, but no solutions?

    I've had my Torch 4 days now, and can connect to my browser fine while on 3G. As soon as I turn my wifi on, my browser works for about a minute, and then I just get this message-unable to find the requested server. VERY ANNOYING/FRUSTRATING! I have tried everything mentioned in all of the previous posts...nothing works.

    When switching my SIM card back to my Bold, wifi works perfect. Our other iphone 4 in the house connects perfectly as well.

    I called tech support last night, and they said it is probably because the Torch is not compatible with an N router (I have no clue what that means) while the ip4 and Bold are.
    So what does that mean...I have to buy a new router just to get the wifi on my Torch to work?

    Has anyone had this issue, and been able to fix the problem? I do have data...but I prefer to save that for when I'm not in a wifi area!

    Sorry for such a long post, and thanks in advance for any help!!!
    10-08-10 08:49 AM
  2. SlcCorrado's Avatar
    The torch is N compatible, so that's probably not the issue. Have you updated your os?

    Posted from my CrackBerry at wapforums.crackberry.com
    10-08-10 08:55 AM
  3. Brie_London's Avatar
    I havent done anything with the OS, no. Should I?
    It came with 246.
    10-08-10 09:23 AM
  4. SlcCorrado's Avatar
    Sorry, I'm on my phone What carrier?

    Posted from my CrackBerry at wapforums.crackberry.com
    10-08-10 09:27 AM
  5. Brie_London's Avatar
    I'm with Rogers
    10-08-10 10:09 AM
  6. 5tolen's Avatar
    OK I HAD THE SAME PROBLEM AND I FIXED IT!!! im also with rogers...so do not panic hahaa i can help!!! now if you are using wep!! you gotta make sure that its "shared key" and not "both"...so then you can go to WPS enable it..then the side of ur router theres a button press it...and then it should flash and connect to your device...just make sure its shared...and not both...because ur prolly using wep...if u are not using wep...then u should connect no problem....but connect using the wps feature on ur phone and router...press button mode.....not regular type in password and easy connect i know it is messed up but i did it and it worked....if u need help add me to msn i can explain it step by step it took me a while to fix mine but i did it mopete28@hotmail.com
    10-08-10 11:11 AM
  7. SlcCorrado's Avatar
    That sounds promising Let us know if you resolve the issue
    10-08-10 11:26 AM
  8. Brie_London's Avatar
    You guys rock! I'm at work right now, and gone for the weekend, but will try this as soon as I get home on Monday.
    5tolen...I may be in touch if I can't figure it out!!!

    Thanks again, hopefully this fixes my problems! I looove the phone, but this has been a downside for me!
    10-08-10 11:58 AM
  9. BBshark's Avatar
    Hey Brie,

    I had the same problem but I fixed it and haven't had any problems since

    Make sure that you're on WiFi and connected to your network then do a battery pull. While the phone reboots also unplug the power cord from the back of the router, wait 30 seconds, then plug it again. By the time the phone is up and running your WiFi will work like a charm!

    I wish I could claim that I came up with the solution.....but it was actually the Bell technician.

    Good Luck!
    10-15-10 12:25 AM
  10. pattste's Avatar
    I have a very similar problem. I'm running .246 on TELUS. My Wifi's security is WPA2 Personal with a passphrase and MAC address filtering.

    I enable Wifi and it connects just fine. I can use the browser but it drops after a minute:

    "Unable to connect to the Internet, please try again later. If the problem persists please contact your service provider."

    Basically, the Wifi is unusable on my Torch. I used to have a BB 8530 and Wifi worked fine on it. I should mention that BIS on 3G works perfectly every time.

    I tried rebooting the phone and router as suggested above by the Bell technician and it didn't help. Anybody else?
    10-15-10 08:17 PM
  11. papped's Avatar
    WPA2 or mac address filtering aren't the issue, I use both with no problems.

    Could try a firmware update on the router.
    10-15-10 08:29 PM
  12. avmsam's Avatar
    i have N router and my torch works fine. i also use wpa2 security with wps. i would suggest you reset your router and leave it stock and try then. then if it works then proceed to setup your router and enable wifi security and all that. also, delete the saved wifi profile from the torch.

    if it works when the router has been reset and no changes made then the router n phone r fine, just a matter of settings. however it it doesnt work when you reset the router then perhaps the phone is incompatible with the router.

    fyi im using dlink dir 655
    10-15-10 08:36 PM
  13. brooklin1963's Avatar
    I tried the simple solution of doing a battery pull and unplug power supply to router for 30 seconds... holy crap it worked. I have a Linksys router using wep.

    Lightening fast now using the wifi

    11-11-10 09:57 PM
  14. sportnut's Avatar
    Had problems with this too. Noticed Torch doesn't autodetermine security settings of wireless network too well. My router had "WPA or WPA2" as the security option. Switched it to off and Torch connected and was fast. Turned on "WPA2 Only" and Torch stayed fast. Thus, try setting your router to "WPA2" security only. (or first try it with it off and then start turning things back on).
    01-24-11 11:56 AM