1. Brie_London's Avatar
    Ok, so I see other similar posts, but no solutions?

    I've had my Torch 4 days now, and can connect to my browser fine while on 3G. As soon as I turn my wifi on, my browser works for about a minute, and then I just get this message-unable to find the requested server. VERY ANNOYING/FRUSTRATING! I have tried everything mentioned in all of the previous posts...nothing works.

    When switching my SIM card back to my Bold, wifi works perfect. Our other iphone 4 in the house connects perfectly as well.

    I called tech support last night, and they said it is probably because the Torch is not compatible with an N router (I have no clue what that means) while the ip4 and Bold are.
    So what does that mean...I have to buy a new router just to get the wifi on my Torch to work?

    Has anyone had this issue, and been able to fix the problem? I do have data...but I prefer to save that for when I'm not in a wifi area!

    Sorry for such a long post, and thanks in advance for any help!!!
    10-08-10 09:48 AM
  2. pattste's Avatar
    Bumping this thread as I have the exact same problem. Wifi doesn't work reliably here at home (haven't had a chance to try wifi at another location yet). I have wpa2 with MAC filtering. I'm able to connect to the wifi but typically internet access drops after a minute or two. Occasionally it will keep working for several minutes yet sometimes it will fail to work at all. The diagnostic screen shows that it connects to the wifi correctly but the BlackBerry Infrastructure section of the screen shows no connection. I have no issues at all over 3G. This is not a major problem as I have a 6Gb data plan but I would like the option of using wifi. I should mention that my Torch (which I love) is an upgrade from a Curve 8530, which worked perfectly over wifi here at home.
    10-20-10 08:44 PM
  3. koboss's Avatar
    Brie, i have the same problem as you identical and yes my bold worked fine with my router and wi fi in the house

    please someone give us the answer

    thanks
    10-20-10 11:24 PM
  4. pattste's Avatar
    Update...

    I've fixed the problem. Unfortunately, there is no good explanation. I started by removing all wifi security. I connected to the network and used the Torch on wifi for about ten minutes to confirm that it worked. Then I recreated the wpa2 security settings from scratch with a new passphrase and readded all devices including the Torch. Everything works fine now. But I'll never know what went wrong in the first place. The Torch was they only device that had problems with the previous configuration.
    10-21-10 10:03 PM
LINK TO POST COPIED TO CLIPBOARD