02-07-12 04:57 PM
30 12
tools
  1. goshi's Avatar
    This is what I've found after a week of fooling around with WiFi. ***You must have your mobile network turned on to receive data.*** Period***. IMPORTANT ---- The Torch will AUTOMATICALLY switch to a saved active WiFi instead of using your mobile data (it is a smart phone remember !!)---. If you wish to check to make sure its connecting to Wifi 1-select MANAGE CONNECTION 2-Scroll down to SERVICE STATUS 3- Under Blackberry Internet service it will read Connection: Wi-Fi. All great If you want to see what happens when you shut of your Wifi, do so and go back to SERVICE STATUS it will show Connection : Mobile Network $$ If you leave your WiFi area and do not wish for your phone to access the Mobile Network go back to 1-MANAGE CONNECTION 2- Scroll down to MOBILE NETWORK OPTIONS 3- turn DATA SERVICES to off. This will prevent your Phone carrier charging you data when your data is pushed through outside of a connected WiFi. When you are back in WiFi range choose your network (if already existing ) or add a new network once again by going into 1-MANAGE CONNECTION 2- SET UP Wi-Fi NETWORK (phone will pick up on available networks, if they are locked you will need a passcode, if they are unlocked you can just select and connect). Once connected you will have to turn DATA SERVICES back on (if you shut it off to save $$) to allow your phone to AUTOMATICALLY connect with the WiFi.
    I believe the reason that you cannot simply turn everything off except for Wi-Fi to just receive Wi-Fi is to simplify the phone function(it will do all the thinking) and (AND most importantly) when you are away from a Wifi spot, your service provider can charge you for Mobile Network Data (which you can still turn off remember) because it has to be on to receive WiFi (they are banking$$$ on the fact that you forget to turn it off outside of the WiFi area!! ). I hope this helps to clarify
    02-04-11 03:41 PM
  2. gnosis8's Avatar
    I think I figured something out when all Mobile Network and Wifi settings are enabled or activated except with APN settings (TCP/IP) disabled:

    If I browse with Opera Mini instead of the default BB Browser, I have an internet access to websites. But the default BB Browser can't get any internet access... it needs the APN setting enabled to work. So, perhaps the default Browser has to rely on the Mobile Network data plan and can't surf via Wifi?

    Give Opera a try and see if this is true for you as well.

    I'll be checking my data usage over the next few days and will keep you guys updated.
    Last edited by gnosis8; 02-09-11 at 11:47 AM.
    02-09-11 11:44 AM
  3. gnosis8's Avatar
    Well, no better with doing what I described above. What did seem to help though was to start fresh. I wiped my phone using the "security wipe" option in the phone menu, and also upgraded to OS .448. I think this has helped, because I'm not getting what appeared to be a 6kb push every 30 minutes all day all night anymore. Maybe it was the Facebook app? I don't know because I decided not to re-install most of the apps that I had before. I guess I had something running the background that would not use Wifi connection, and instread always used my AT&T data plan.

    On another note, Opera sucks. It has no touch screen navigation options, and the trackpad/cursor control is hypersensitive so it's all over the place.
    02-19-11 11:31 AM
  4. dockishen's Avatar
    hi all,
    had the same problem with my torch and playing around with the settings brought up an interesting solution.
    in the browser options go to the javascript setting and enable it while you are on wifi bis and automatically the browser starts using the wifi and not the 3g signal . you can then turn the java off if you are concerned about security.
    also it works without touching the APN settings.
    have a go as they say it worked very well for me.
    04-05-11 05:21 PM
  5. ffoward2003's Avatar
    I am having this same exact problem using wpa security on my router.... worked fine with Wep. Any suggestions ?
    02-07-12 04:57 PM
30 12
LINK TO POST COPIED TO CLIPBOARD