1. mallinj's Avatar
    See title. Remove your Bluetooth pairings before you upgrade. Also use DM advanced restore to delete your old Bluetooth settings from your backup data before restoring your data via DM. Trust me, you'll be glad you did.
    09-28-09 10:30 AM
  2. rswaz's Avatar
    This issue may be device dependent. I upgraded to .230 last week and did not remove my BT pairing to my Plantronics 925. After the data restore, everything worked perfectly.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-28-09 10:48 AM
  3. Syco54645's Avatar
    See title. Remove your Bluetooth pairings before you upgrade. Also use DM advanced restore to delete your old Bluetooth settings from your backup data before restoring your data via DM. Trust me, you'll be glad you did.
    what happens otherwise?
    09-28-09 10:51 AM
  4. tmp3150's Avatar
    I didn't remove my bt settings before I upgraded and everything works well for me.
    09-28-09 10:54 AM
  5. mallinj's Avatar
    For the Motorola T505, you cannot delete the device or change properties after you upgrade. Because you cannot delete the device, you cannot re-pair with the Tour.

    Other people have reported that the upgrade screwed up their Bluetooth config too.

    I wonder whether it is device specific.. perhaps it only affects the T505... or devices that work as FM transmitters.
    09-28-09 10:59 AM
  6. Adam Zeis's Avatar
    Mine got fracked to. Had my Jabra SP700 paired and my Bluetooth isn't playing nice now after the upgrade.
    09-28-09 11:46 AM
  7. Afangrywarrior's Avatar
    That explains it.... I cannot remove my BT pairing to my headset for the life of me, can't change any settings can't even click on it in the BT Config menu... I try to connect to another BT component and it says "Trying to establish connection with ...." my exisisting headset and wont let me connect to anything else... I have to do a hard reset and reinstall everything tonight for this, unless anyone knows how to correct it?
    09-28-09 11:47 AM
  8. Hosalabad's Avatar
    I'm in this boat too.

    I upgraded to 5.0.0.230 and while my phone will pair with my JVC KW-AVX820 it will no longer function as a hands free device. I can dial from the JVC and the phone will place a call but I have to use the handset. It worked fine on 4.x

    As a result of the 5.0.0.230 and not knowing to delete the pairings beforehand I can now not delete the JVC to try to repair and see if this resolves anything.
    09-29-09 10:12 AM
  9. dkh7m's Avatar
    same problem here. i'd paired my tour w/ my macbook and now i can't delete or modify the pairing.
    09-29-09 10:25 AM
  10. typezero303's Avatar
    I've got the Moto 305 headset, and I didn't see the whole Bluetooth bug with the 5.0.0.230 update... so I've been trying all afternoon to find a way to fix it.

    I managed to find a way to remove the device. It's trick, and annoying, but it worked for me.


    What I did is go to the bluetooth option screen where I see my paired devices. Sure enough, hitting the Blackberry button does nothing, and clicking on the screen also did nothing. But in my frustration I find something interesting out.

    When I turned on my headset and clicking the Blackberry button over and over and over while the headset was coming up, the option menu flashed open. Hmmm... So I turned my headset off, and did it again, c'ept this time I was a little more careful. I kept on hitting the Blackberry button while the headset was coming up again, and when the option menu came up I quickly stopped hitting the BB button.

    This allowed me to access the Bluetooth Options for the device, and the general Bluetooth options for my Storm.

    From there, I put the security to the lowest settings for the headset, and this allowed me to pair-up the devices. But no real functionality.


    Heres the really good bit. With access the general phone bluetooth options, I removed all Bluetooth supported features(Headset, AV Controller, etc, etc, etc..). Once that happened, my headset was kicked off and lost it's connection. So I went for the BB Button continuous mash + Headset coming up method of accessing the options menu. Once there again *poof!* The Delete Option was there. Disconnected, and deleted the device.

    Once the device was removed, I could then access the bluetooth options with no problem. So I went back, turned on all Bluetooth features again. Re-paired my S305 headset and the phone together. Worked perfectly, all options came up. Options are accessible, and doesn't seem to freeze on the Bluetooth device screen anymore.


    The downside; the S305 still don't work properly. I get music if I play one song, I can skip to next song, but the second I do that I loose audio. Not to sure why. Volume controls work fine, everything else is fine... but the second I switch songs; audio no worky. =(



    Hopefully this helps someone out. I'm doing a battery pull right now, and doing a full re-set to see if that helps out at all. Will post if I move forward any from here.
    09-29-09 11:57 PM
  11. dkh7m's Avatar
    @typezero ... big thanks! i tried your method and it worked. my situation was a little different. my BB was paired with my macbook. i went into macbook's bluetooth setup and hit "configure". tapped the BB button while the mac was looking for the BB and bang! there's the menu. i do not, however, have an option in the menu to delete the pairing, but i was able to fix the settings and can now xfer files from my phone to my computer.
    09-30-09 08:38 AM
  12. carzaddict's Avatar
    i upgraded and it restored all my BT settings fine
    09-30-09 09:13 AM
  13. DJBeanPole's Avatar
    i upgraded and it restored all my BT settings fine
    +1 one no problems
    09-30-09 10:29 AM
  14. pipdicker's Avatar
    Typezero, your method worked for me as well.

    Thanks for the help!
    10-01-09 11:19 AM
  15. Crunch140's Avatar
    Sweet!, thanks for that info, Typezero. I noticed this the other day, and it was driving me crazy.
    11-30-09 01:10 AM
  16. CarSalesman's Avatar
    New followup to this old thread. I had this same problem. I found that by adding yet another bluetooth device, and having that device paired and connected, it then became possible to push the Berry key and delete the old ones. Now that the devices configured before the 5.0.230 upgrade are gone, I can recreate them again.
    12-10-09 06:37 PM
  17. FF22's Avatar
    Well, like some others, I forgot the PAIRING issue when upgrading to a new OS, OS 5...230, Hybrid 712.

    That left me unable to select certain of my multiple bluetooth devices like my Motorola S9 headphones and my Jabra car speaker.

    I attempted to follow the instructions above for turning on the device and repeatedly pressing the BB button for a quick connection. Never worked.

    Since two devices would no longer connect to my Tour I was getting irritated, to say the least.

    While I had thought about a potential solution before, removing the actual Bluetooth Cod file (module), I was reluctant.

    Today I tried the methods outlined in this thread again and again failed.

    So I took the bull by the horns or the Tour by its cods and ripped the Bluetooth Cod out. The question that remained was would the bluetooth database or whatever (the devices installed) be removed or would it survive.

    Upon rebooting - no bluetooth but also for some reason BBmaps was gone (I could tell since my theme no longer had its weather icon in the correct position). I got some other error about Poynt so maybe these things depend on Bluetooth or BBmaps or....

    Oh, well, a search found no bluetooth and no bbmaps. I did not check Applications - I only looked for the icons.

    Next, I reinstalled the bluetooth cod file. Reboot (tic, tic, tic... toc). Bluetooth was back (as was BBmaps).

    Open bluetooth and NO DEVICES were installed. I had SUCCESSFULLY cleaned them out.

    I have proceeded to reinstall my desktop computer, my S9's (two pair actually). I will do the Jawbone after it recharges. The Jabra is in the car but I will go for it.

    Conclusion: I believe I fixed the problem.

    I used BBSAK to both remove and reinstall the bluetooth cod file (I had backed it up previously). I never touched BBmaps but it is back, too.

    The file that I removed and reinstalled is:

    net_rim_bluetooth.cod

    Hope this helps someone else.
    Last edited by F2; 01-02-10 at 09:37 PM.
    01-02-10 09:02 PM
  18. djjmaddox's Avatar
    Glad I finally found this post. Upgraded my Tour to .591 but then went to the 419/hybrid as VZW release was awful. Never thought to delete my bluetooth profiles but the one I used for a modem with my laptop didn't work and I could not delete it or add the laptop again. I was just able to delete it now and re-synced it. Thank you.
    04-18-10 06:37 PM
LINK TO POST COPIED TO CLIPBOARD