1. Stogies's Avatar
    I'm not very hopeful, but does anybody know a way to block service books from being accepted by the device? The reason I ask is because in their greedy effort to suck even more money from their customers, those soulless demons at at&t block BBMaps in order to attempt to force their crapware nav service down your throat.

    I know that you can go to the BBMaps site and download the LBS_RIBBON cod and restore full functionality, but every time at&t broadcast new service books, it wipes it from the device again. This seems like it happens almost daily now. I don't want to use the 3rd party app that opens BBMaps without the native icon because without LBS_RIBBON the Local Search feature doesn't work in BBMaps. I just want those ....holes..... to leave my phone alone.

    I would really be grateful for any suggestions. (Except the one to change providers. As much as I would love to, I'm stuck with them. The few people that I talk to a lot are all on at&t and therefor free. And I'll never get my GF to change, her entire family is on at&t and she uses a TON of M2M minutes....)
    11-16-10 03:08 PM
  2. Rootbrian's Avatar
    The only way to do it is through BES.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-16-10 03:28 PM
  3. Pete6's Avatar
    No, but you can delete them each time they arrive.
    11-16-10 03:32 PM
  4. albee 1's Avatar
    I have experienced bloatware on another level and found the only way to prevent it's service books ability to return was to install the application, then delete it from the Applications list. Let me know if this works for you. In a way you have to temporarily do what you do not want, to get what you want in the end.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-16-10 04:21 PM
  5. Stogies's Avatar
    Thanks everybody,
    Unfortunately, that's about what I expected to hear. I don't have an issue with them sending the spam apps, I just created a folder, moved them all into it, and hid it. My issue is the fact that I'm paying an extra $30/mo for unlimited data, and BBMaps is provided with the device. It's just pure slimy to disable BBMaps in an attempt to force their paid app on me. Stuff like this is why, if I were ever to go behind their back and do something like use a 3rd party tethering app, (without paying yet MORE money for the privilege of using the data I already pay for) I would feel absolutely no guilt in sticking it to them a bit. Heck of a way to treat a long term customer, huh?
    11-16-10 07:19 PM
  6. albee 1's Avatar
    Hey Stogies, the above method worked for me on another unwanted pushed link from my carrier. If you install the culprit, then delete it after the install, for me at least the service book did not return. I just hid the rest because I didn't want to be installing and deleting all night and possibly, day. Haha

    Posted from my CrackBerry at wapforums.crackberry.com
    11-16-10 09:14 PM
  7. Stogies's Avatar
    Hey Stogies, the above method worked for me on another unwanted pushed link from my carrier. If you install the culprit, then delete it after the install, for me at least the service book did not return. I just hid the rest because I didn't want to be installing and deleting all night and possibly, day. Haha

    Posted from my CrackBerry at wapforums.crackberry.com
    Hey Albee,
    It's not a matter of getting rid of an unwanted push item, every time I download BBMaps at&t deletes the .cod from my BB. It used to be that it stayed for a month or so before they resent the books, but lately it's been getting deleted almost daily.
    11-16-10 11:38 PM
  8. Rootbrian's Avatar
    AT&T should be sued, or a lawsuit brought onto them for what they're doing.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-16-10 11:47 PM
  9. albee 1's Avatar
    AT&T should be sued, or a lawsuit brought onto them for what they're doing.

    Posted from my CrackBerry at wapforums.crackberry.com
    Yeah), what happened to the "open platform". I thought they already went through this and it was decided it violates our constitutional rights to restrict us from everything but "their" applications. Bastards! Last resort Stogies: if you wiped and reloaded the OS and deleted the Vendor xml file before loading, I think this would work. Your Os would no longer have an internal Brand.

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by albee 1; 11-17-10 at 08:38 AM.
    11-17-10 08:34 AM
  10. rrrebo's Avatar
    No carrier should be pushing any function that would delete a .cod from your device. I would examine more closely the exact series of events surrounding the disappearance of this .cod. Are you running an official AT&T OS? Try installing a non-AT&T OS package and see if that makes a difference.
    11-17-10 09:14 AM
  11. Stogies's Avatar
    Last resort Stogies: if you wiped and reloaded the OS and deleted the Vendor xml file before loading, I think this would work.
    Yep, that's exactly how I've loaded the last 1/2 dozen os's.

    No carrier should be pushing any function that would delete a .cod from your device. I would examine more closely the exact series of events surrounding the disappearance of this .cod. Are you running an official AT&T OS? Try installing a non-AT&T OS package and see if that makes a difference.
    Well, shouldn't be doing it is correct. Unfortunately.....
    I am running a non-AT&T os and have been for months. The sequence of events seems to be as follows.

    I dl the LBS_RIBBON cod from the BBMaps website. It loads on my phone. All is well. Then if I don't actually *open* BBMaps, it will stay on the device for a good while. But as soon as I actually open the app and use it, it's removed from my device within hours. Not as soon as I close it, but sometime within the next couple of hours it will be gone. It's a repeatable course of action. My theory is that as soon as AT&T has time to "see" that I've dl'd data with the app, they nuke it. And if I *don't* open and use the app, it still gets deleted within a week or so.

    This is recent. I used it on my 8900 before this with no problems and only had to reinstall it every 3-4 months. I've been using it on my 9700 sense April and only had to start reinstalling it about 6 weeks ago. I've installed it more in the past 6 weeks than I did in the previous 18 months.

    I loaded it two days ago and haven't opened it yet and it's still there. I've done two battery pulls in the interim and still have the app loaded. I'll open it now and do a local search and then close it and see how long before it's AWOL again.
    11-17-10 06:27 PM
LINK TO POST COPIED TO CLIPBOARD