1. thisisscandless's Avatar
    I have had my Boost Blackberry for several months everything was working fine on there network, however I went through a pretty serious break up and changed my number 3 weeks ago. Now my texts are not working at all. Boost has the WORST customer service. I have had an "open ticket" through them for 3 weeks with NO response. I'm desperate at this time. I have not been able to receive texts. When I send one, I get a reply within 20 seconds from the number 9320: saying,"you are not allowed to send texts messages. Msg. 2120." Has anyone had this problem? They have trouble shooted my phone for 2 hours with no luck. My firewall is down, everythings fine. I just want to be able to text! Any ideas? Thabks for your time!! -dara

    Posted from my CrackBerry at wapforums.crackberry.com
    04-29-10 03:21 AM
  2. dictoresno's Avatar
    battery pulls havent fixed the issue? confirm with boost what the correct routing number should be for your SMS, see if thats changed in your settings.
    04-29-10 03:57 AM
  3. Motorcycle Mama's Avatar
    ... snip ... Boost has the WORST customer service. I have had an "open ticket" through them for 3 weeks with NO response. ... snip
    Unfortunately, you get what you pay for.
    04-29-10 06:37 AM
  4. thisisscandless's Avatar
    They have the correct routing number, they literally checked my phone for hours. As for the boost service, I've never had a problem until recently.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-29-10 08:49 AM
  5. thisisscandless's Avatar
    As far as the routing number, they did soo much trouble shooting let me make sure we are talking about the same thing, they made me dial ##8... And a few other numbers which brought up a screen that had my number then a different number that looked like a phone number, both were said to be "correct."

    Posted from my CrackBerry at wapforums.crackberry.com
    04-29-10 08:56 AM
  6. albee 1's Avatar
    Has the phone been provisioned after the number change? Menu/Mobile Network/Menu/Start Provisioning

    Posted from my CrackBerry at wapforums.crackberry.com
    04-29-10 09:23 AM
LINK TO POST COPIED TO CLIPBOARD