1. brady0125's Avatar
    I am having difficulties sending out text messages. When i try to compose a text message i recieve the following message below the one i just sent,"(SMS error 4, Message ID 239) Permanent Error" It is in red and i do not know why i am having these issues. Sometimes instead of saying," Permanent Error", it will say,"Network problems." Can anyone help with this? Thank you in advance.
    02-15-11 10:33 AM
  2. DawgMan's Avatar
    What device are you using and what OS is on the device? When did the issue begin? Do you get this on all sms messages now or is it occasionally? Open your SMS folder scroll to the top and hit the menu button, go to Options and check your parameters. You should see things like Data Coding, Service Center, Network to Send Messages, Number of retries.
    brady0125 likes this.
    02-15-11 10:51 AM
  3. Heavy Fluid's Avatar
    What provider is this on? The more information you provide, the more help you will receive.
    brady0125 likes this.
    02-15-11 11:04 AM
  4. brady0125's Avatar
    My provider is Sprint. When i went to my SMS folder, under SMS text i have the following: Data Coding: Ascii Priority: Normal Callback Number: (my number) and that is about it.
    02-15-11 12:19 PM
  5. Heavy Fluid's Avatar
    The first thing that I would do in this situation, is pull the battery with the device powered on. Leave it out for 30 seconds, and put it back in. Let it boot up, and see if you still have the issue.
    brady0125 likes this.
    02-15-11 12:22 PM
  6. brady0125's Avatar
    Is this ok to do? It doesn't seeem right. But the issues i am having with this phone do not seem right either!
    02-15-11 12:26 PM
  7. brady0125's Avatar
    well it tried it and i was able to send (1) message. i tried again to the same person and got,"(SMS error 4, Message ID 241) Permanent Error."
    02-15-11 12:42 PM
  8. Heavy Fluid's Avatar
    I would contact your provider for assistance on this. It sounds like more of a network issue rather than your device.
    brady0125 likes this.
    02-15-11 12:44 PM
  9. Heavy Fluid's Avatar
    Is this ok to do? It doesn't seeem right. But the issues i am having with this phone do not seem right either!
    The infamous battery pull will usually fix your BlackBerry about 95% of the time. It is perfectly fine to do the pull, and once you have your phone for awhile, it will become second nature.
    brady0125 likes this.
    02-15-11 12:45 PM
  10. brady0125's Avatar
    Thank you for the help. I will try out the rest of the day and if i still have issues i will contact Sprint. I will update this thread with an info. i aquire. Thanks again.
    02-15-11 12:53 PM
  11. Heavy Fluid's Avatar
    I would like to see how this is resolved. I hope that it is something simple like a local network outage or something along those lines. I will be watching this thread.
    brady0125 likes this.
    02-15-11 12:57 PM
  12. breakmedown's Avatar
    Try backing your phone to your computer and doing a factory reset. Could be a corrupted file, as this isn't an issue that seems to be common.

    Posted from my CrackBerry at wapforums.crackberry.com
    brady0125 likes this.
    02-15-11 04:09 PM
  13. Heavy Fluid's Avatar
    Try backing your phone to your computer and doing a factory reset. Could be a corrupted file, as this isn't an issue that seems to be common.

    Posted from my CrackBerry at wapforums.crackberry.com
    Kind of an extreme thing to do right off the bat. I would like to see the OP call the provider first before wiping his/her phone.
    brady0125 likes this.
    02-15-11 05:25 PM
  14. brady0125's Avatar
    i may try to contact Sprint through their website first. Is it possible to defrag the phone at all?
    02-15-11 09:36 PM
  15. Heavy Fluid's Avatar
    Not really. Contact them via customer service and not on the website.
    02-15-11 09:59 PM
  16. brady0125's Avatar
    what is the best way to get a hold the Sprint Customer Service if i do not use their website?
    02-15-11 10:04 PM
  17. Heavy Fluid's Avatar
    Call 611 from your handset.
    brady0125 likes this.
    02-15-11 10:07 PM
  18. brady0125's Avatar
    i contacted Sprint this morning and i went through a view test with tech support. i was told to try and updaste my profile,while they did some checks on their end. they had me pull the battery out for 20 sec. and reinstall to see if the rebooting helped. i was able to send out (1) text messgae successfully then i would get the same (SMS error 4, message ID 252) Permanent Error code again. Currently waiting for tech support to call back......
    02-16-11 07:47 AM
LINK TO POST COPIED TO CLIPBOARD