08-05-10 03:05 AM
238 ... 23456 ...
tools
  1. tomte's Avatar
    Hah
    Maybe we could ask the ppp gurus on comp.protocols.ppp...
    04-21-09 04:00 PM
  2. smashtheqube's Avatar
    hah, i think i've found it.
    I've managed to connect 20 times in a row, 100% success.
    i *created* this file :
    /etc/ppp/options.cu.Bluetooth-Modem
    with
    -- cut here --
    dump
    lcp-max-failure 5
    -- cut here --
    "dump" is just there to see what options are actually used by pppd, the real important line is lcp-max-failure 5 :
    the man says :
    Set the maximum number of LCP configure-NAKs returned before starting to send configure-Rejects instead to n (default 10).

    that seems to do the trick !
    is this working for you guys ?

    -- UPDATE --
    I confirm this is really working. I've rebooted, connected/disconnected 30 times and it's getting online every time
    Doesn't work for me. What modem script are you using?
    I'm trying with "BlackBerry 3G CID1" script and it fails in the "Authenticating..." bit -- says "Could not negotiate a connection with the remote PPP server."

    Log says:
    1. Making 3G Connection
    2. Serial connection established.
    3. Using interface ppp0.
    4. Connnect: ppp0 <--> /dev/cu.Bluetooth-Modem
    5. PAP authentication succeeded
    6. IPCP: Maximum Config-Requests exceeded
    7. Connection terminated.
    8. Serial link disconnected.
    04-21-09 04:12 PM
  3. csete's Avatar
    The noipdefault option not working would match what I was seeing on Sunday when I explicitly set the addresses... But, without actual IP connectivity, what good does it do?

    You guys are really messing with my focus at work :-) If I just had a bit more time, I could go digging through the pppd source to understand what might be happening... isn't going to happen until at least 8pm (central US) tonight though.
    04-21-09 04:15 PM
  4. tomte's Avatar
    well, that's weird indeed
    if i skip the noipdefault, i *still* get an IP from the remote host, and the ppp is up :

    Tue Apr 21 22:17:41 2009 : Serial connection established.
    Tue Apr 21 22:17:41 2009 : using link 0
    Tue Apr 21 22:17:41 2009 : Using interface ppp0
    Tue Apr 21 22:17:41 2009 : Connect: ppp0 <--> /dev/cu.Bluetooth-Modem
    Tue Apr 21 22:17:42 2009 : sent [LCP ConfReq id=0x1 <mru 1200> <asyncmap 0x0> <magic 0x320ec09> <pcomp> <accomp>]
    Tue Apr 21 22:17:42 2009 : rcvd [LCP ConfReq id=0x0 <asyncmap 0x0> <auth pap>]
    Tue Apr 21 22:17:42 2009 : lcp_reqci: returning CONFACK.
    Tue Apr 21 22:17:42 2009 : sent [LCP ConfAck id=0x0 <asyncmap 0x0> <auth pap>]
    Tue Apr 21 22:17:42 2009 : rcvd [LCP ConfRej id=0x1 <mru 1200> <magic 0x320ec09> <pcomp> <accomp>]
    Tue Apr 21 22:17:42 2009 : sent [LCP ConfReq id=0x2 <asyncmap 0x0>]
    Tue Apr 21 22:17:42 2009 : rcvd [LCP ConfAck id=0x2 <asyncmap 0x0>]
    Tue Apr 21 22:17:42 2009 : sent [PAP AuthReq id=0x1 user="orange" password=<hidden>]
    Tue Apr 21 22:17:43 2009 : rcvd [PAP AuthAck id=0x1]
    Tue Apr 21 22:17:43 2009 : pap_rauthack: ignoring missing msg-length.
    Tue Apr 21 22:17:43 2009 : PAP authentication succeeded
    Tue Apr 21 22:17:43 2009 : sent [IPCP ConfReq id=0x1 <addr 10.211.55.2> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
    Tue Apr 21 22:17:43 2009 : sent [ACSCP] 01 01 00 10 01 06 00 00 00 01 02 06 00 00 00 01
    Tue Apr 21 22:17:43 2009 : rcvd [IPCP ConfReq id=0x1 <addr 169.254.1.1>]
    Tue Apr 21 22:17:43 2009 : ipcp: returning Configure-ACK
    Tue Apr 21 22:17:43 2009 : sent [IPCP ConfAck id=0x1 <addr 169.254.1.1>]
    Tue Apr 21 22:17:43 2009 : rcvd [LCP ProtRej id=0x2 82 35 01 01 00 10 01 06 00 00 00 01 02 06 00 00 00 01]
    Tue Apr 21 22:17:43 2009 : rcvd [IPCP ConfRej id=0x1 <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
    Tue Apr 21 22:17:43 2009 : sent [IPCP ConfReq id=0x2 <addr 10.211.55.2>]
    Tue Apr 21 22:17:43 2009 : rcvd [IPCP ConfAck id=0x2 <addr 10.211.55.2>]
    Tue Apr 21 22:17:43 2009 : ipcp: up
    Tue Apr 21 22:17:43 2009 : route_interface: write routing socket failed, File exists
    Tue Apr 21 22:17:43 2009 : local IP address 10.211.55.2
    Tue Apr 21 22:17:43 2009 : remote IP address 169.254.1.1

    you may notice the error "route_interface: write routing socket failed, File exists" which is not a good sign either
    04-21-09 04:19 PM
  5. tomte's Avatar
    hmm actually i'm not sure this IP comes from the remote host. it looks more like the local host requests it from the server :
    Tue Apr 21 22:17:43 2009 : sent [IPCP ConfReq id=0x1 <addr 10.211.55.2> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
    and gets acknowledged for some reason..


    --update--
    yup, that's it. the mac is just using my en8 IP (parallels iface) to pppd...
    woosh....
    04-21-09 04:22 PM
  6. csete's Avatar
    I still think that is probably OK if you can get the routing corrected. You may want to use some other IP than the one attached to you primary network, but it seems like most IP addresses "work" with PPP. Although I may be very wrong with that.
    04-21-09 04:28 PM
  7. tomte's Avatar
    well provided it's pointopoint, it should work. I've specified a local ip, (still getting the remote one from the server) and it doesnt work (though i don't have the route error anymore).
    04-21-09 04:45 PM
  8. ydaraishy's Avatar
    you may notice the error "route_interface: write routing socket failed, File exists" which is not a good sign either
    It may be harmless, it could be that the scripts are trying to write a default route which is already specified. If you want to be sure, flush your routing tables first (route flush, perhaps?) and then retry.
    04-21-09 06:21 PM
  9. anon1928001's Avatar
    I was having trouble with this last night as it was my first time trying, but after lots of research and trial and error, I got it to finally work.

    Right now I'm using the Bold 9000 with 4.6.0.247. Mac is updated to the latest version of OSX 10.5.6 I believe. Now, I am not taking any credit for this at all. I found it on another site here. I just followed the instructions from the first post. Downloaded the Bold modem scripts here, and put in all the information he has listed.

    Somehow, this worked for me when nothing else did. I'm guessing its from the actual Bold Modem Script that is linked to. Anyways, I'm jsut reporting that it works with my MAC on Bold 900 firmware 4.6.0.247!
    Ok, this one worked for me (Bold 9000 on Vodafone Netherlands with .247, MacBook Pro with 10.5.6) , but I had to add a few tweaks (sorry if the names deviate a little from what you will see, I translate from German, but you'll get my drift):

    - first installed the modem script as stated into the Modem Script folder

    - connect via Bluetooth, don't enter any data into the field where it says "use as network access" (this comes later on)

    - Then went to settings - > Bluetooth -> configure interface -> check "show in network preferences" for the dialup connection that shows up

    - Switch to Network preferences, you should now have a connection there saying "Blackberry 9000 Dialup" (it does for me, yours might look different), enter your APN information provided by your network.

    - Click on "advanced settings". Choose the Blackberry driver from the "others" list. For the rest I used the same settings for the rest of the panel as samversionone did, except that I unchecked "error correction and compression" and I used the "don't wait for dialtone" setting. (In my experience this is necessary for all modems outside the US.)

    SAVE THOSE SETTINGS! (I am highlighting this, as I forgot first, so it didn't work. But I can't expect everyone to be as stupid as me... )

    - Then - on your BB - go to settings -> network -> data services -> and set to off. Save these settings too.

    - Then back on your Mac, now hit the "connect" button and you're done!

    Works like a charm for me!
    Last edited by tyroleanarcher; 04-21-09 at 06:37 PM.
    04-21-09 06:32 PM
  10. FrankieA's Avatar
    - Then - on your BB - go to settings -> network -> data services -> and set to off. Save these settings too.

    - Then back on your Mac, now hit the "connect" button and you're done!

    Works like a charm for me!
    OMFG. tyroleanarcher, you are the king! That last step did the trick!

    I'm on my mac right now, tethering from my berry on bluetooth.
    OS 10.5.6
    BlackBerry Bold 4.6.0.266

    Speedtest to prove it:


    Last edited by Xcist; 04-21-09 at 08:53 PM.
    04-21-09 08:37 PM
  11. csete's Avatar
    tyroleanarcher: If only it were that simple. I'm not sure what the differences are and where, but the no data services trick didn't work for me before. I just tried it again without any luck.

    In fact, I just wasted another hour making zero progress. I attempted to do this with my IP addresses specified. The link comes up fine, but nothing is routed. I turned on kernel debugging on high and I can see that data is sent on the PPP connection, but nothing is returned. It seems as if the remote connection isn't fully configured if you don't go through the full negotiation. It doesn't seem to be a routing issue, but I may be misreading things.

    tomte: I was unable to get the Bluetooth Modem options file to even work for me. The dump command didn't fire, nor did anything else. I may be doing something wrong there.

    I'm nearing a point of being frustrated enough to give up. The fact that this works for Ubuntu without problems on the .247 firmware or on Mac with older firmware makes it difficult to figure out where to point fingers and work out a solution that works for everyone.... or even one that works for me. I have not actually managed to get a working connection at all, unlike the others on this thread... Not sure what to make of that. I do wonder if I've managed to get things into a state on this machine where nothing is going to work.
    04-21-09 10:20 PM
  12. jcturcios's Avatar
    Well I dont know anything about scripts or ppp but when I was on .185 I was able to tether..now I upgraded to .247 and was not able to..I just tried the turning off data services trick and somehow it does work now!! I am able to connect perfectly 6 times in a row now!

    p.s. the at&t name on top of my screen now changes to "modem mode enabled when im tethering. Im not sure if it changed to that before
    04-21-09 10:40 PM
  13. tomte's Avatar
    turning off data on the bb improved the success rate here too, this is getting weirder everyday. That's a major hindrance, though, i don't want to turn this off and on again everytime i'm tethering, and it has to be a better solution as the BB is working totally okay under XP.

    Csete: i thought i've seen back and forth ppp packets when i manually set up the connection without noipdefault, but i was wrong. I fired up wireshark again and all the packets i can see are outbond, not inbound.
    This is absolutely frustrating. I honestly don't know what to try next...
    04-22-09 02:54 AM
  14. tomte's Avatar
    I've forced the BB in 2G mode and data ON, with 100% success on 10 tries (but i had 30 in a row two days ago in 3G, that doesn't prove anything really
    04-22-09 03:01 AM
  15. csete's Avatar
    When people are turning off data or switching to 2G, what else are you doing? Either I'm flipping the wrong "switch" on my Blackberry or this just isn't working for me. I'm seeing the same error in the logs when trying that.

    Is there a chance that this is an issue with the carrier? Has anyone successfully connected with data services disabled to AT&T?
    04-22-09 06:48 AM
  16. tomte's Avatar
    I go into Manage Connections / Mobile Network Options
    and turn Data Services OFF there. you just need to turn it off during ppp negociation, I turn it on again once ppp connection is established.
    you can change 2G/3G there too, but of course you cannot switch between them in the middle of a data connection.
    04-22-09 07:42 AM
  17. tomte's Avatar
    I've tried to connect the usual way (with data ON, 3G) a few times now and it's successful every time. This tethering thing is getting on my nerves, it's been only two weeks since i started using a blackberry and I feel kinda frustrated ever since by this nonsense.
    04-22-09 07:48 AM
  18. csete's Avatar
    I hate to say that I'm glad you are frustrated too. I'm also kind of glad that it isn't working for someone else. With that said, I have not yet had a single working connection from my Mac. Using the "berry4all" thing, I can do it via USB in a pinch, but cabling is a pain.

    tomte: Let's keep pounding on this as time allows. I'm not entirely ready to give up, although I agree that it is frustrating. I wonder if your idea to go to the PPP experts would be worthwhile. Potentially, they could offer some new ideas of things to try. In particular, since I can always create a non-working PPP connection when I specify the IP addresses, I wonder if there would be a way to turn that into a working connection when I specify the addresses?

    Thoughts?
    04-22-09 08:26 AM
  19. tomte's Avatar
    i am glad too not to be alone with this. This being said, i have been heavily tethering with data ON and 3G since this morning and the negociation has not failed once! I am really lost.
    I'll try to compile this up and post a descriptive summary on usenet's ppp ng anyway.
    04-22-09 12:22 PM
  20. csete's Avatar
    Not fair! :-)

    Let me know what you come up with. I'm completely without a clue as to how to proceed.
    04-22-09 12:24 PM
  21. anon1928001's Avatar
    And I'll try to get a short video or picture sequence of how it worked for me. Maybe this can help any of your guys....
    04-22-09 02:03 PM
  22. tomte's Avatar
    csete :
    Are you sure the following file is not working for you :
    /etc/ppp/options.cu.Bluetooth-Modem ?
    it started failing again tonight, and i tried this : refuse-pap. Success again.
    As the auth on mac is always PAP first but on Windows ms-chap or ms-chap2 is always prefered. As you know this option forces the auth to be challenged via CHAP and somehow changes the way the ppp stack is brought up. Though i agree it's not supposed to interfere with IPCP, i've seen some broken ppp implementations where authentication had an influence on the rest of the chain...
    04-22-09 02:15 PM
  23. csete's Avatar
    I've been unable to use the options file, but I can always drive it from my PPPD script and see if that option helps out.
    04-22-09 02:25 PM
  24. tomte's Avatar
    Maybe your mac is not using the same device...
    In the logfile, do you have something like
    Wed Apr 22 20:36:09 2009 : Connect: ppp0 <--> /dev/cu.Bluetooth-Modem

    Perhaps it's using dev/tty.Bluetooth-Modem instead...
    04-22-09 02:39 PM
  25. csete's Avatar
    I think it is, but I will check. Unfortunately, it is looking like I'm going to, yet again, be working late tonight and I'm not sure if I will get time to try anything tonight.
    04-22-09 04:04 PM
238 ... 23456 ...
LINK TO POST COPIED TO CLIPBOARD