08-05-10 02:05 AM
238 123 ...
tools
  1. samversionone's Avatar
    I was having trouble with this last night as it was my first time trying, but after lots of research and trial and error, I got it to finally work.

    Right now I'm using the Bold 9000 with 4.6.0.247. Mac is updated to the latest version of OSX 10.5.6 I believe. Now, I am not taking any credit for this at all. I found it on another site here. I just followed the instructions from the first post. Downloaded the Bold modem scripts here, and put in all the information he has listed.

    1.) Extract the Modem Script from the attached .zip file and place it in the Mac HD > Library > Modem Scripts folder. Be sure you place it in the root Library folder and not the Library folder associated with your User folder.

    BlackBerry 3G CID1.zip

    2.) Pair your phone with the Mac. Be sure you have set it up as a Trusted Connection and is set to "Yes" and not "Ask".

    3.) In Bluetooth Preferences, select your phone in the list, and then click "Configure this device". This will launch the Bluetooth Setup Assistant.

    4.) Check the "Access Internet..." and proceed.

    5.) Select "Other" for Vendor, and "Blackberry 3G CID1" (name of the modem script) for Phone Model. Leave the Username, Password, and Phone Number blank. Continue.

    6.) Launch Network Preferences, and click "Bluetooth" in the list.

    7.) Select "Add Configuration" from the Configuration drop list. Name the configuration something you can identify. I use my carrier name (AT&T).

    8.) Populate the remaining fields with your APN information, using the wap server URL as the Telephone Number.

    Example for AT&T :
    Telephone Number:wap.cingular
    Account Name: wap@cingulargprs.com
    Password: CINGULAR1

    9.) Check "Show modem status in menu bar"

    10.) Click Advanced, and verify the information is correct.

    Modem

    * Vendor = Other
    * Model = Blackberry 3G CID1
    * Enable Error... = checked
    * Dial Mode = Wait for dial tone before dialing
    * Dialing = Tone
    * Sound = On

    DNS

    * -All Blank-

    WINS

    * -All Blank- (NetBIOS may be populated and disabled)

    Proxies

    * Configure Proxies = Using a PAC file

    PPP

    * Settings = Session
    * Third, Fourth, Fifth and Seventh items checked. Redial 1 Time, and Wait 5 Seconds before redialing


    That's it. You are ready to tether.

    Enable Bluetooth on your phone, and then on the Mac. Click the modem icon from the menu bar, and select Connect Bluetooth. After a few seconds you should see a connection timer.

    *From amkls704 on Howard Forums*

    Somehow, this worked for me when nothing else did. I'm guessing its from the actual Bold Modem Script that is linked to. Anyways, I'm jsut reporting that it works with my MAC on Bold 900 firmware 4.6.0.247!
    Last edited by samversionone; 03-12-09 at 09:32 AM. Reason: Changed Title
    03-12-09 09:05 AM
  2. samversionone's Avatar
    I forgot that you might have to have an account over at blackberryforums to download the bold modem script.
    03-12-09 11:22 AM
  3. DVS_WiNdz's Avatar
    Do you need a tethering plan for this?
    03-12-09 11:34 AM
  4. ImGeorgeous's Avatar
    i'm going to try this out!!
    03-12-09 11:54 AM
  5. samversionone's Avatar
    I don't have a tethering plan, and it still works. I just wouldn't go around downloading movies and stuff.
    03-12-09 12:08 PM
  6. macxsilence's Avatar
    I have tried ever script and other tutorials around the web, for the life of mines, I can not get it to work with any settings.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-12-09 12:15 PM
  7. samversionone's Avatar
    I have tried ever script and other tutorials around the web, for the life of mines, I can not get it to work with any settings.

    Posted from my CrackBerry at wapforums.crackberry.com
    I followed the instructions on there and it worked for me. I tried like 4 or 5 different sets of tutorials and this one with the script was the only one I could get to connect. What I did though is uncheck "enable error correction and compression in modem". Not sure if that make a difference or not. Also, step 5 might be kind of important to leave it blank. I had that area filled in before and it wouldn't connect but after making it all blank, it worked.
    03-12-09 12:42 PM
  8. smashtheqube's Avatar
    I just updated my bold from .210 to .247 just to try this and ... surprise, it doesn't work.
    03-12-09 06:03 PM
  9. wp3gi's Avatar
    Tried it step by step, it works with 4.6.0.167 and 4.6.0.190 but it does not work with 4.6.0.2xx
    03-12-09 06:20 PM
  10. smashtheqube's Avatar
    Tried it step by step, it works with 4.6.0.167 and 4.6.0.190 but it does not work with 4.6.0.2xx
    Yup... this sucks.
    Same thing happened with my Curve after I changed the software on that. So stupid, why does RIM do this. It just wastes everyone's time and frustrates people who only use their tethering in an emergency or tight-situation... in other words SPARINGLY ENOUGH that they wouldn't notice that this is an issue.

    So frickin' stupid.
    03-12-09 06:48 PM
  11. DVS_WiNdz's Avatar
    edit: nevermind
    03-13-09 11:00 AM
  12. kittiyut's Avatar
    No Go for me either (OS .247)
    03-13-09 11:18 AM
  13. smashtheqube's Avatar
    This is a huge annoyance. One of the reasons I got rid of my iPhone was the inconvenient tethering. Now that I'm addicted to the Curve and now the Bold... this really needs to get fixed!
    03-13-09 02:02 PM
  14. smashtheqube's Avatar
    Bump.............
    03-15-09 06:56 PM
  15. Jkilla's Avatar
    not workign for me .247
    03-16-09 01:45 AM
  16. jcturcios's Avatar
    EDIT: I managed to set everything up but still no go.. i did notice something, every time I try to connect to the bluetooth connection via the network preferences, it takes about 15 seconds for an error to pop out on my computer..but during those 15 seconds I notice my blackberry drops the blackberry connection (bb icon next to the signal strength) and then immediately after it picks it back up, the internet connect error pops up on my computer screen. this is the error - could not negotiate a connection the the remote pp server please verify your settings and try again...

    any ideas??
    Last edited by jcturcios; 03-16-09 at 04:52 AM.
    03-16-09 04:37 AM
  17. jcturcios's Avatar
    so, any thoughts?
    03-16-09 01:59 PM
  18. darkone338's Avatar
    if you look configure ppp options to log verbosely, and then look in the ppp.log you'll see that everything *seems* to authenticate fine, but you never receive IP information from the remote ppp server. works fine for me in everything up to 190 and then nothing upwards of that
    03-16-09 04:08 PM
  19. taddley's Avatar
    Does anyone posting in this thread actually have a tether account with ATT?

    Just a thought - .2XX may be protecting against connection until an actual account is established.

    Anyone verify? What does ATT say?
    03-16-09 04:26 PM
  20. smashtheqube's Avatar
    that doesn't seem to matter. It's just a compatibility issue
    03-16-09 06:55 PM
  21. kingofthecrate's Avatar
    Does anyone posting in this thread actually have a tether account with ATT?

    Just a thought - .2XX may be protecting against connection until an actual account is established.

    Anyone verify? What does ATT say?
    here is what the geniuses down at at&t say,

    (ME) Hi, I want to set up the tethering plan for my account so I can can avoid spending the extra 60 dollars for a usb wifi, and use my blackberry bold instead. I was told in a store that I could add the blackberry enterprise option for an additional 30 dollars and be able to tether.

    (at&t) yes sir that is correct, let me check your account and see what you have now and we'll set this up for you. ok everything is set up.

    (me) ok well I use a mac, so will this still work on my machine?

    (at&t) let me check for sure, please hold. (comes back) no sir, im sorry but unfortunately at this time we do not have support for mac OS. (story of my life) so i will your account and your only option is to go with the usb wifi.

    (me) no thanks.



    so as far as theyre concerned, they say it is not even possible to use the tethering with at&t. now wether or not you get the option put on. mabe it will work, but ive read all over that you dont need to have the tether option to make it work.

    Ive also seen people say they use it with the 2xx OS but me along with other are having issues.
    03-16-09 09:52 PM
  22. taddley's Avatar
    Ive also seen people say they use it with the 2xx OS but me along with other are having issues.
    Yep. Same. And I'm tired of not knowing for sure.

    I've posted a thread at the "Ask the ATT Rep" forum to see if I can get some definitive feedback. I'm also going to post a thread at the Mac forum.

    I want to knock this question out for good. I'll post what I find.
    03-17-09 06:54 AM
  23. samversionone's Avatar
    Update: I've been trying to use what I posted for the past few days and it doesn't seem to always work. There are times when it connects just fine and other times when I just can't get on at all. I really have no idea what is going on with it. It is actually very very annoying.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-17-09 10:52 AM
  24. dchiarav's Avatar
    me neither...i'm downgrading to .167 and will let you know what happens. what's the latest firmware version that one can use that allows for BT tethering?
    03-22-09 12:27 PM
  25. kingofthecrate's Avatar
    me neither...i'm downgrading to .167 and will let you know what
    happens. what's the latest firmware version that one can use that allows for BT tethering?

    I downgraded back to .167 (ugh) and it tethers just fine. I guess ill try .190 or .185 since the battery issue and the video viewing issues got corrected in those later firmware upgrades. I just
    Hope someone can crack whateber it is with os .2xx that is causing an issue.
    03-22-09 12:38 PM
238 123 ...
LINK TO POST COPIED TO CLIPBOARD