1. crc2253's Avatar
    Hello Everyone,
    My carrier was just bought by T-Mobile and the transition has been pretty smooth. One thing I have noticed was that all of my friends phones now are branded T-Mobile but mine is still branded SunCom. My browser and T-Zones are not working. I spoke with someone from CS and they could not figure out what was going on and they credited me $5 and said they would get back in touch with me. CS said that my phone is not displaying the T-Mobile brand was because I had upgraded my OS which I offered up the info. Can anyone help or have any input on my problem. Any help would be great.
    09-16-08 09:37 PM
  2. kickinitlive247's Avatar
    but does it really matter if it shows suncom or tmobile?
    09-17-08 01:12 AM
  3. kfrey's Avatar
    What OS do you have and you can try loading the one for T-mo. I think you may need to get T-mo service bookes

    Posted from my CrackBerry at wapforums.crackberry.com
    09-17-08 01:22 AM
  4. crc2253's Avatar
    Tried the service books and didn't work. I installed 4.5 just before the change to T-Mobile. Could I install t-mobiles os and then reinstall 4.5?
    09-17-08 05:59 PM
  5. shwy's Avatar
    t-mobile doesn't have the 8310, so they won't have the OS.
    09-17-08 06:44 PM
  6. benzworm's Avatar
    this happened with the cingular to at&t switch, eventually yours will change too, i think it is based on your sim card number....
    09-17-08 07:13 PM
  7. shwy's Avatar
    I converted with my cingy sim over to AT&T with no problems.
    09-17-08 07:14 PM
  8. griphon's Avatar
    Is not that bad. And if you have a WIFi enabled device, like the Curve 8320, you will really like it.
    09-17-08 07:20 PM
LINK TO POST COPIED TO CLIPBOARD