1. muckrak3r's Avatar
    I have a T-Mobile Curve 8320. I had a Linksys router a few months ago and changed to a netgear rangemax.

    Now my phone and my wife's phone (same model) both see the network and connect to it, but there is a yellow indicator and the Wi-Fi icon on our blackberry desktops doesn't go black (active).

    We have crap T-Mobile service and I am hoping someone can help, thanks!

    I have deleted all Wi-Fi connections, re-added just this one, pulled the battery out, and lowered my channel on my router to 2.

    Any suggestions?

    edit: I just did the Wi-Fi Diagnostics on the phone and it says under UMA Connection: (red X) then Error Code: W006.1
    Last edited by Muckrak3r; 06-23-09 at 03:43 PM.
    06-23-09 03:38 PM
  2. Reed McLay's Avatar
    W006.1 - ISP or T-Mobile network error.

    W006.2 - ISP or T-Mobile network error.

    W006.3 - ISP or T-Mobile network error.

    Meaning: The phone is unable to establish network connectivity: This could be a problem on the ISP side or the network side.

    1. The connection to the WAN port of the wireless router is down: either the cable is unplugged or the DSL/Cable modem (whichever applies) is turned off. This could also be caused by an outage of the DSL/Cable service.

    2. Check if MAC filtering is enabled on the wireless router. If it is, check that the phone MAC address is on the Safe List, if not, add it.

    3. The network that the user is trying to connect to uses Web Redirection: this means that when trying to connect to the network in question with a laptop, you are required to enter username and password or pay to use the service. The phone cannot connect to such networks.

    4. IPSec is not enabled on the router you are trying to use. Enable it in the router settings and try again.

    5. The problem can be caused by network issues. At this point, the user might want to try at a later time.
    Some suggestions
    06-23-09 06:00 PM
  3. muckrak3r's Avatar
    tried all those - no go. if i knew which ports to forward i could easily do that.

    otherwise i will have to switch back to my freeze up and have to reboot once a month Linksys piece of crap...
    06-23-09 10:00 PM
  4. hubermania's Avatar
    Do you have another router upstream of your Netgear? My wifi router went dead a couple months ago, and I had to jerry-rig my network to have cable modem to wired router to travel wifi router. Could not get UMA to pass through the wired router. I was forced to setup the travel router's IP as a DMZ in the upstream wired router. Once I did that, the wired router allowed all the protocols needed for my UMA to come back to life.
    06-24-09 05:09 PM
  5. muckrak3r's Avatar
    I just have the netgear running from my dsl modem.
    06-26-09 09:37 PM
  6. CansFan's Avatar
    I have the same issue and error code when I ran the diagnostic here at my sis' house. UMA works fine for me at home and at other places but here it will connect and have her SSID on the screen without giving me UMA.

    I have T-Mobile and an 8320 too. Tried all the above mentioned suggestions for this certain error code (changed channel that was conflicting with another router in range) but no go still.

    Any suggestions? This si really ticking me off!!
    07-18-09 04:39 PM