1. grujaz10's Avatar
    Hello,

    I have a serious issue with my 9900. I purchased a telus unlocked 9900 and am using it on att. Before the 9900, I was using the 9810 but decided not to use it while i still had it. So when I activated the 9900, they actually used the same IMEI number from the 9810 for almost a week and a half - until i decided to return the 9810 within the 30 days to reset my upgrade. Prior to the change in IMEI numbers, the 9900's gps was working perfectly almost every single time. However, ever since changing over my IMEI number, the gps (along with several other issues) has been extremely inaccurate. Sometimes it only finds my location within .6 miles, which doesnt even put me on the right street usually. This is true with either google maps or BB maps.

    Any help on how to fix it or even what to ask att to do would be greatly appreciated. I really need the gps to work like it used to.

    Thanks,
    10-10-11 09:18 AM
  2. FBA's Avatar
    It has nothing whatsoever to do with ATT or you IMEI. It can be a whole bunch of other things -

    Have you tried a reboot/battery pull?
    10-10-11 10:04 AM
  3. phonegeek#AC's Avatar
    Hello,

    I have a serious issue with my 9900. I purchased a telus unlocked 9900 and am using it on att. Before the 9900, I was using the 9810 but decided not to use it while i still had it. So when I activated the 9900, they actually used the same IMEI number from the 9810 for almost a week and a half - until i decided to return the 9810 within the 30 days to reset my upgrade. Prior to the change in IMEI numbers, the 9900's gps was working perfectly almost every single time. However, ever since changing over my IMEI number, the gps (along with several other issues) has been extremely inaccurate. Sometimes it only finds my location within .6 miles, which doesnt even put me on the right street usually. This is true with either google maps or BB maps.

    Any help on how to fix it or even what to ask att to do would be greatly appreciated. I really need the gps to work like it used to.

    Thanks,
    What OS ver are you using??

    If you haven't upgraded to .440 yet try that.


    PG
    10-10-11 10:25 AM
  4. Aceroller's Avatar
    I am using an unlocked Telus on AT&T as well, and I have called AT&T and updated the IMEI number for the new 9900, and I am not having any problems with my GPS. I am running .440 BTW.
    10-10-11 03:46 PM
  5. psiclne's Avatar
    Got my unlocked Telus 9900 last week, took the sim from my 9780 put it in and set it all up with no issues. I never call the carrier. Not even when I got my unlocked 9780. Everything works fine on mine.
    10-10-11 05:28 PM
LINK TO POST COPIED TO CLIPBOARD