1. andonakis's Avatar
    So I bought a 2006 X5 7 months ago. Bluetooth worked great. Pairing between the storm and bimmer worked flawless. Well just like that bluetooth in the X5 stopped working. So I call the dealer and bmw usa, they both tell me my storm is not supported and that I probably have to replace the TCU unit. This is the module that makes the bluetooth work. So in other words, if you don't have a cell phone that is not in their list of supported phones your sophisticated new storm doesn't stand a chance and that goes for the iphone too. Now the newer bimmers don't have this problem because the module is updated. Anyone else having this problem??? To tell you the truth this is the stupidest thing I ever heard. They are telling me that my phone caused the tcu module to go bad because my storm is not supported. My voice activation don't work either. Bunch of BS if you ask me.
    02-04-10 03:44 PM
  2. JRSIMPSON's Avatar
    Total BS!! I would remove the battery cables on the beemer for maybe an hour, turn on the head light switch and hit the break pedal. Then put the cables back on, start the car and try to connect the blackberry.

    Like your Blackberry, removing the battery cables off the battery for a few minutes will reset the computers on your car. Turning the headlights on and hitting the break pedal with the cables off the battery will make sure all residual voltage is gone.
    02-04-10 04:55 PM
  3. Fillyo's Avatar
    Sounds like BS, I have a 2006 330i and my former Storm 1 worked flawless, as well as my current Storm 2. I have never had any issues. According to their logic, any phone released after 2006 would not be supported, since they did not exist yet. Do what the former post said and try that. Delete you pairing off the phone and repair it too.
    02-04-10 05:01 PM
  4. andino's Avatar
    You don't have to pull the battery on your car for an hour. 15 mins will do. Also don't do driving right after as you will stall. You'll need to let you car idle for 15 mins so that the ECM can relearn everything. Hopefully that will fix your non-link issue
    02-04-10 06:51 PM
  5. dsmith3427's Avatar
    I work for Lexus and in no way can a phone via bluetooth cause any modules to go bad. Call BMW directly. Avoid this dealer as well.
    02-04-10 07:28 PM
  6. andonakis's Avatar
    The thing is I did call bmw directly and said the same thing. To be honest if I new this I'd seriously would not of bought this car.
    02-04-10 08:40 PM
  7. Brockmant's Avatar
    The thing is I did call bmw directly and said the same thing. To be honest if I new this I'd seriously would not of bought this car.
    Bwahahaha. Its like they were making up a lie just to sound important so that you would get off of their back. Crazy!
    02-04-10 09:10 PM
  8. Flying Biker's Avatar
    Is there a forum that you know of for your BMW? If there is, maybe you could ask the same question there. Like CB, I find that if I have an issue with any of my motorcycles or vehicles, I go into their respective forums and usually get the right answer from very knowledgeable people unlike going to a stealer and getting the runaround.
    02-05-10 01:13 AM
  9. ccstorm1894's Avatar
    call the guys at bavarian autosport. I used to own a antique 528 and had a terrible time finding parts or info, and they were very helpful, and never gave me bad advice. also can probably find you an aftermarket solution if necessary.
    02-05-10 08:56 AM
  10. gbizzoco's Avatar
    Try this website: BIMMERPOST = BMW Forum, BMW News and BMW Blog

    This is a great website for BMW owners. You'll find posts on almost any topic for your BMW. I am willing to bet that you aren't the only one with this problem.
    02-05-10 09:29 AM
  11. bb-bandit's Avatar
    So I bought a 2006 X5 7 months ago. Bluetooth worked great. Pairing between the storm and bimmer worked flawless. Well just like that bluetooth in the X5 stopped working. So I call the dealer and bmw usa, they both tell me my storm is not supported and that I probably have to replace the TCU unit. This is the module that makes the bluetooth work. So in other words, if you don't have a cell phone that is not in their list of supported phones your sophisticated new storm doesn't stand a chance and that goes for the iphone too. Now the newer bimmers don't have this problem because the module is updated. Anyone else having this problem??? To tell you the truth this is the stupidest thing I ever heard. They are telling me that my phone caused the tcu module to go bad because my storm is not supported. My voice activation don't work either. Bunch of BS if you ask me.
    total BS. I have 2004 BMW 330i. My storm works flawlessly with the bluetooth and uploads the phone book to my radio. Discount the battery cable as other posters have said and re-synch. I am a member at Bimmerfest: BMW Forum, BMW Research, BMW News, BMW European Delivery, 335, M3. They are very helpful. I don't believe at all that you need a new TCU.
    02-05-10 09:40 AM
  12. andonakis's Avatar
    Have tried a few x5 forums with some solutions. Thanks to all that responded. It seems there a several others are having the same problems.
    02-05-10 09:55 AM
  13. bbfogie's Avatar
    I have a 2009 335i, and the phone functions work fine with my Storm2, but I have to unpair the device and car when using VZ Nav or else I can't hear the turn by turn directions.

    I also was advised by the dealer not to use any phone that's not listed as approved, but that's just stupid.
    02-05-10 12:49 PM
LINK TO POST COPIED TO CLIPBOARD