1. Devil's Avatar
    Hey,

    Just upgraded to the Storm 2 from Storm 1.
    On my Storm 1, even if I was under a block of concrete (like under a basement, or parking levels), it would use Aided GPS via Celltower Triangulation and help me get a location lock. SocialScope made use of this when I tried to "check in" to various destinations using FourSquare.

    However, SocialScope on Storm 2 doesn't seem to be getting a lock unless I'm under clear sky.
    Instead of going through tons of threads, I figured I'd ask here and also hope for a solution.

    Thanks!
    07-11-10 12:10 PM
  2. greydarrah's Avatar
    You didn't mention the OS that your running and some do a better job with GPS than others. You might wan to try .517, .607 or .713.

    Also, Have you gone to options>advanced options>gps and made sure that location aiding is in fact enabled?
    07-11-10 12:49 PM
  3. Devil's Avatar
    You didn't mention the OS that your running and some do a better job with GPS than others. You might wan to try .517, .607 or .713.

    Also, Have you gone to options>advanced options>gps and made sure that location aiding is in fact enabled?
    My apologies.
    I had .607, where the problem existed. Updated to .713, and it still exists.
    Also, GPS options are indeed enabled.

    Thanks!
    07-11-10 12:58 PM
  4. kriptikchicken's Avatar
    Did you used to use SocialScope on your Storm1?

    Unfortunately I don't have SS so can't comment on that app. But I have just managed to get a GPS fix with Poynt and Google Maps, indoors, and the weather outside is heavily overcast. (Scotland!)

    It took a bit longer than normal... 1-2mins.
    07-11-10 01:06 PM
  5. Devil's Avatar
    Yup, SocialScope on Storm 1 was awesome.
    Unfortunately, my GPS GMaps or SocialScope doesn't work unless it's in open skies. GMaps on Storm 1 didn't work quite well indoors on the S1, but SocialScope did. Now both of them don't work indoors unless it's under clear open skies.
    07-11-10 01:15 PM
  6. Devil's Avatar
    still no go..
    07-14-10 05:46 PM
  7. titusilvering's Avatar
    the storm2 GPS is indeed not that powerful. Can't tell if its hardware specs or due software controller.
    Last edited by titusilvering; 07-14-10 at 06:54 PM.
    07-14-10 06:52 PM
  8. Devil's Avatar
    Really sucks.
    07-15-10 11:46 PM
  9. xsilentxninjax's Avatar
    i believe its from.713... i have problems with poynt and other gps apps not finding my GPS locations. i never had a problem with this before i updated. google maps and loopt as well.
    07-21-10 05:05 PM
  10. Devil's Avatar
    Yup and its set to allow.
    Somethings wrong. Something to do with triangulation. Not GPS. Just wish I knew how to fix this because i bought this unlocked in the Philippines. My old Telus storm worked flawlessly when it came to this.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-23-10 10:36 AM
  11. Devil's Avatar
    Right after I typed the earlier message, I still re-did it. But this time, I denied location data, rebooted and on boot, it said Allow or Deny. I allowed, and it kinda worked at a location where it didn't work earlier.

    A few minutes later, I tried it elsewhere.. and it didn't work. So I guess it worked for a bit, which makes me feel that it's a little bit of a software issue.
    07-23-10 01:59 PM
  12. bmoney1229's Avatar
    The GPS on the S2 does unfortunately suck! I use a tracking program when i go on trips which tells me all sorts of cool info (distance, speed, avg speed, breadcrumbs, etc.). the S2 GPS is soooo bad, that at one point it said i had gone over 15,000 miles at an average speed of 10,000 mph. I assume this was because it was bouncing around between cell towers, but who knows. I've also seen times when google maps thinks I'm in South Africa
    07-23-10 05:02 PM
  13. HMBgal's Avatar
    i believe its from.713... i have problems with poynt and other gps apps not finding my GPS locations. i never had a problem with this before i updated. google maps and loopt as well.
    Mine works well, but it does take some time (up to a minute at times) to lock on. It also makes my phone hot (110 degrees+) in about five minutes of use.
    07-23-10 07:02 PM
  14. Devil's Avatar
    i believe its from.713... i have problems with poynt and other gps apps not finding my GPS locations. i never had a problem with this before i updated. google maps and loopt as well.
    Did you downgrade?
    07-24-10 01:16 AM
  15. dannynixon's Avatar
    I have no problems with google maps and/or poynt. I'm in the uk and I get a position lock in 30 seconds Max, indoor or out. I also use bim active and get a GPS lock in around that time.

    Is social scope a free app? If so I'd like to give it a go to see if there see any problems.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-24-10 01:51 AM
  16. Devil's Avatar
    It's a private beta app
    07-25-10 09:58 AM
LINK TO POST COPIED TO CLIPBOARD