1. demopedro's Avatar
    Hello! I am wondering if anyone has a list of the models that work with Sprint that run the 4.6 (or above) OS?

    I ask as I am looking to run PDANET on a Blackberry but I need to know what models to look for as I am buying one used as I REFUSE to sign another 2 year contract with Sprint!

    I found a SWEET deal on a 8830 World but it's OS 4.5! (right?) Also am I STUCK paying $150+ for ANY used Blackberry with 4.6 or higher? (Who is NOT on a budget these days!)

    I am just getting SICK of the performance of my MOTO Q9C AND I BROKE the LCD screen on Saturday so I need a new phone anyway!

    I have just heard that PDANET runs GREAT on 4.6! If ANYONE has a good tether program for the 4.5 OS too I would take ANY advice.

    I do not want to switch to AT&T and go iPhone like everyone else...and just want to stand pat with Sprint for 2010 and wait to see what happens. Plus....I have heard a LOT of good things and like the reviews of the Blackberrys.....

    Any help for this newbie would be GREAT! THANK YOU!
    02-01-10 05:45 PM
  2. blackstrat's Avatar
    Once you purchase it upgrade the OS

    Posted from my CrackBerry at wapforums.crackberry.com
    02-01-10 06:02 PM
  3. Cobra46's Avatar
    The 8830 and 8330 are basically out of the question if you need 4.6. There is a Boost mobile release of 5.0 that will work on the 8330 as long as it is not an 8330M. As far as other models, anything released after the 8350i will have 4.6 or above. The 9630 has 4.7 (and hopefully 5.0 soon), the 8530 has 5.0, and the 8350i has 4.6.
    02-01-10 06:08 PM
  4. demopedro's Avatar
    Hey Black....But you can't upgrade the 8830 to 4.6 can you? I think Taco is on the right track....I think I need to look at 9630, 8530, or 8350i. Any more info would be great. Thanks so far guys....
    02-02-10 12:19 PM
  5. Xopher's Avatar
    The 88xx series won't be updated past OS 4.5. Neither will the original Pearl 81xx series, or the GSM 83xx series Curves. None of these have enough memory (64MB) to handle the newer OS versions. The 8330 has seen a reduced OS 5.0 mainly because it has more RAM (96MB) than the other models.

    I would think most of these would have been considered at the end of their life.

    83xx -> 85xx (and 89xx).
    81xx -> 91xx (coming soon)
    88xx -> 9000, 9700, and 9630/9650

    I wonder if the Pearl Flip 82xx is going to see 5.0, since it came out with 4.6 to begin with (and 128MB RAM).
    02-02-10 06:37 PM
  6. demopedro's Avatar
    Well....I NOW hear it MAY be a mute point as Sprint may cut tethering alltogether by 2011? I guess I may try "Smartview" and see if that works.....Sprint is really making me angry....I have NOT had a good experience with them in the last 2 years....
    02-03-10 05:18 PM