1. tbacba's Avatar
    I'm on my second Curve from Sprint and I'm getting the same problem I had with the first one -- the map function in Sprint Navigation has stopped displaying my location (or the location of any of my favorites, recent spots, etc.) The map shows 'loading', but nothing appears on the screen. I have unloaded and reloaded the Navigation application, done a complete wipe, and called Sprint and Telenav support but no one can help. It worked fine up until today and then just stopped. The actual navigation function still works properly, just no map display. Any ideas? Help!
    07-25-08 09:04 PM
  2. NysFinest4Ever's Avatar
    I have had this happen to me before.. it just says loading and it stays that way.. regardless of what I tried.. It did this for about 2 days.. I thought it had something to do with the OS I upgraded too. I am using a beta OS. However after about a few resets and a battery pull it still did the same thing.. then it just started working. I have NO idea why. I did absolutely nothing. I just tried it again after about 2 days of it keep saying loading and it worked. Sorry I cant give you pointers. other than keep trying.
    07-25-08 09:41 PM
  3. tbacba's Avatar
    Ok thanks, I will keep trying. VERY frustrating.
    07-26-08 07:38 AM