1. Sharke's Avatar
    I always use a bluetooth headset with my phone when I'm out and about on the job all day, but I would rather not keep it attached to my ear at all times. But if I put it in my bag then my bag is forever hitting the redial button on the headset, much to the annoyance of whichever particular person I last called. It drives me crazy but I can't find a way to stop it, short of unchecking the "hands free" setting in bluetooth options, however this means I can't answer or disconnect a call with the headset - I have to do it from the phone.

    To be honest this is as much a fault with bluetooth headsets as it is with the phone. Every headset I've ever owned has had a one-press redial function which activates itself in a pocket or bag. But you would think that, knowing this, Blackberry would give the option to block it. I tried setting "Allow Outgoing Calls" to "if unlocked" in bluetooth settings, however this doesn't apply to the phone on standby, which is how I keep my phone when I'm not using it. Not only that, setting this option gives rise to a very serious bug....if you make a call with the phone on standby and disconnect using the headset, it is henceforth impossible to bring the phone out of standby and I have to do a battery pull.

    Get this crap sorted, RIM. Can't believe I'm still putting up with this nonsense in 2010. Or am I being completely and utterly stupid and missing some obvious workaround? I would love for someone to tell me I'm stupid!

    Any thoughts?
    05-25-10 07:28 PM
  2. Freckbj's Avatar
    Have you tried the keyboard lock (holding the A button down)
    05-25-10 07:35 PM
  3. Sharke's Avatar
    Well, it's been a couple of minutes since I posted this and already I've discovered that I am indeed being completely and utterly stupid. I don't need to uncheck the hands free option, all I need to do is to set "Allow Outgoing Calls" to "never." I can still make calls using the phone, but the redial on the headset is disabled. And I can still disconnect from the headset. My entire life is transformed - and all it took was to shift my brain gears up from "gnat" to "human."
    05-25-10 07:36 PM
  4. Sharke's Avatar
    Have you tried the keyboard lock (holding the A button down)
    That might work too, although I prefer to have my phone on standby.
    05-25-10 07:37 PM
  5. Sharke's Avatar
    Oh and sorry, RIM.
    05-25-10 07:38 PM
  6. Leapin_Toufu's Avatar
    ...To be honest this is as much a fault with bluetooth headsets as it is with the phone. Every headset I've ever owned has had a one-press redial function which activates itself in a pocket or bag...
    If it still bothers you, you might want to consider a Motorola bluetooth headset with a "flip". I recommend the H17.
    05-26-10 12:48 AM
  7. Jude526's Avatar
    and I have a jawbone icon the thinker it has an on and off switch.....
    05-26-10 02:08 AM
LINK TO POST COPIED TO CLIPBOARD