1. BerryJ12's Avatar
    Hi, I have the curve 8900, but since the navigation/trackball applies to a bunch of different models, i decided to post this question in the general section.

    So a few days ago, I got my blackberry wet, and everything still works fine, except that the trackball does not "click" or "select" but scrolls fine both vertically and horizontally.

    I know similar questions have been asked, but I've been getting around this problem by using other methods to "click" (mostly the enter key, sometimes the space bar and the menu key, and the alt key for lists) but I'm having trouble clicking for email setups and settings. Basically none of those buttons work when I try to select an email provider (yahoo, gmail, live, etc) from the list when I go to add a new email address. I sorta got past it by cliking menu and selecting "next" which seems to let me manually add email addresses. The main problem tho, is that once I go to edit my email settings for specific accounts where it lets you change "general options" "login information" "delivery options" "synchronization options" and "advanced options" everything other than general options is collapsed and I can't get them to expand with the enter, space, menu, or alt keys.

    Since the trackball not clicking is a rather common issue, I was hoping that someone figured out a way to get past this (using different keys, or perhpas changing the options some other way..somehow)

    I would appreciate any help regarding this.
    Thanks in advance.
    02-08-11 11:10 PM
  2. Kevin691's Avatar
    Have you tried scrolling over an item and hitting the enter button?
    02-08-11 11:27 PM
  3. BerryJ12's Avatar
    yes i have tried the enter button, space button, and alt button. normally one of the three would work but for this none of them seems to work for me.
    02-09-11 01:06 AM
  4. albee 1's Avatar
    How about highlighting and pressing menu, highlight select then press enter.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-09-11 08:04 AM
  5. BerryJ12's Avatar
    unfortunately theres no "select" button in the menu
    02-09-11 12:34 PM
  6. albee 1's Avatar
    Here's a link that should help you. Good luck!

    http://forums.crackberry.com/f83/tra...-click-209795/


    The third or fourth post tells how to fix it.
    Posted from my CrackBerry at wapforums.crackberry.com
    02-09-11 01:04 PM
  7. BerryJ12's Avatar
    i dont think cleaning the ball wil help, since the problem occured when I got the phone wet, not cuz the trackball got dirty. I think its more likely that whatevers going on under the ball got damaged from the water, so I kind of gave up on fixing the ball and have been focusing on ways to get around the phone without using the click function of the ball.
    02-09-11 03:07 PM
  8. albee 1's Avatar
    If it's not clicking, the post explained what to do. It has nothing to do with the ball. Good luck.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-09-11 06:07 PM
LINK TO POST COPIED TO CLIPBOARD