1. JesseO's Avatar
    I have a blackberry torch an I use wifi at home and I still seem to be using data from the 3G network and being charged. Any tips on favoring the wireless over the network?
    02-07-11 11:48 PM
  2. anton-k's Avatar
    I get the feeling that when you download apps, you use 3G even when you're on wifi, so it counts towards your data limit. That's my only explanation for why my data useage is abnormally high when I download apps when I'm at home, on wifi.
    02-08-11 12:04 AM
  3. luqman24's Avatar
    Yes I've noticed this too. Very awkward. Was at 43MB when I came home today and now I'm at 70 MBs. I haven't downloaded anything except Facebook Chat pro and been surfing the web, bbm, facebook, watching a couple of videos, ect all on wifi. If your think that I might not have been connected, I had UMA instead on 3G on the top right to confirm it. I'm with Rogers and am wondering if this is the same on anyone else on the Rogers network.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-08-11 12:12 AM
  4. gbsn's Avatar
    Some applications only work through the carrier signal and dont get tunneled through wifi, the only way to fully utilize wifi is by tuning off the cell phone radio and leaving only wifi turned on.
    jcp007 likes this.
    02-08-11 02:29 AM
  5. dochouse7's Avatar
    Make sure any applications that can set download preferences have them configured as wifi preferred instead of 3G. Also check the Mobile netework options on the device and make sure it is also set to wifi preffered.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-08-11 10:00 AM
  6. Erandhawa's Avatar
    +1 to dochouse7 some applications will let u pick if u want to use wifi or bis make sure u select wifi whenever possible.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-08-11 11:10 AM
  7. joeldf's Avatar
    Make sure any applications that can set download preferences have them configured as wifi preferred instead of 3G. Also check the Mobile netework options on the device and make sure it is also set to wifi preffered.

    Posted from my CrackBerry at wapforums.crackberry.com
    There is no "WiFi preferred" setting in the mobile network options for the Torch - at least none that I can find.

    There are only separate option pages for Mobile network (use data or not and while roaming or not, and use 2G only or 2G/3G - that's it), and for setting up WiFi networks.
    02-08-11 05:45 PM
  8. luqman24's Avatar
    There is no "WiFi preferred" setting in the mobile network options for the Torch - at least none that I can find.

    There are only separate option pages for Mobile network (use data or not and while roaming or not, and use 2G only or 2G/3G - that's it), and for setting up WiFi networks.
    Looks like this...



    Posted from my CrackBerry at wapforums.crackberry.com
    02-08-11 06:31 PM
  9. ajwalker's Avatar
    Seems my Torch in the US on AT&T doesn't have the option to set a preference.

    Maybe it's a Rogers thing?
    02-08-11 10:15 PM
  10. kfroese's Avatar
    Could be a Rogers thing. My Bell Torch doesn't have that option either.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-08-11 10:30 PM
  11. luqman24's Avatar
    I believe this option is there because of the UMA feature (wifi calling) if its not available on TMO, which have UMA as well on their OS6 devices, then I could be wrong.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-08-11 10:55 PM
  12. joeldf's Avatar
    I believe this option is there because of the UMA feature (wifi calling) if its not available on TMO, which have UMA as well on their OS6 devices, then I could be wrong.

    Posted from my CrackBerry at wapforums.crackberry.com
    I think you're right. Having UMA add other features to the OS install. Take a look at the "blackberry.alx" file with any OS setup on a PC. Looking at the vendor_id codes and the files that install with them will show that. Vendor ID codes do more than just deal with "vendor themes".

    For AT&T, this is what we see in under Mobile Network Options:

    02-09-11 01:21 PM
LINK TO POST COPIED TO CLIPBOARD