09-13-11 11:49 AM
646 ... 242526
tools
  1. Sandman333's Avatar
    Wow, 42 pages. I was going to try this to get my 9550 GPS unlocked to use with something other than BBMaps, but I don't have a week to read all that. I read the first page that lists all these programs you need to do this- but no links to them?
    04-03-10 07:56 PM
  2. goodB0Y's Avatar
    Wow, 42 pages. I was going to try this to get my 9550 GPS unlocked to use with something other than BBMaps, but I don't have a week to read all that. I read the first page that lists all these programs you need to do this- but no links to them?
    All the info you need is in the instructions provided by heartlesshero and Houseape (thank you guys!!!) and I would recommend reading all the pages just so you can get an idea of what some people have had problems with and how to fix them your self.

    If you don't have the time to read all of the instructions provided and all of the pages in this thread than this fix/patch may not be for you... but I will say again that all the info you need is in the .pdf file and instructions on the first page.

    As for links to the apps you will need google is your friend!!! There are a ton of links if you "GOOGLE" it....

    good luck
    04-04-10 04:23 AM
  3. Sandman333's Avatar
    You're right. I would like to be able to use the GPS with other apps (Verizon) but this is just a little too complicated for me.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-04-10 07:30 PM
  4. HouseApe's Avatar
    Anyone have any ideas with my problem I am having up a couple posts.

    Posted from my CrackBerry at wapforums.crackberry.com
    Do you have BlackBerry Desktop manager installed? What version?
    04-05-10 10:29 AM
  5. HouseApe's Avatar
    You're right. I would like to be able to use the GPS with other apps (Verizon) but this is just a little too complicated for me.

    Posted from my CrackBerry at wapforums.crackberry.com
    Verizon does not support aGPS on any apps other than BB Map and VZNav so this will not help you.
    04-05-10 10:31 AM
  6. Evolved's Avatar
    Model: BB Curve 8530
    Carrier: Verizon
    OS: Battery is dead so I can't retrieve right now but OS is whatever the phone shipped with.

    I was successful on my 1st attempt using the "test" menu to get GPS to fix and tried it again and it worked the 2nd time as well. Haven't tried BB Maps yet but Google Maps was only showing "within 1300 meters" so obviously it isn't using the GPS. Might just have to get VZ Navigator. :-(
    04-07-10 12:04 PM
  7. Evolved's Avatar
    Will this work with the Verizon BB Curve 8530?
    04-08-10 08:43 AM
  8. HouseApe's Avatar
    Will this work with the Verizon BB Curve 8530?
    No Verizon does not support aGPS except for BB Maps
    04-08-10 02:43 PM
  9. A299reh's Avatar
    I am using Blackberry Desktop Manager version 5.0.1 and have an 8330M version 4.5.0.169 (Platform 3.4.0.51) and when following these directions I get a read error when I try to read and save bin file. I have tried all of the addresses and lengths you have listed am I just out of luck or am I doing something wrong??? I am using altell as my carrier
    Last edited by A299reh; 04-11-10 at 09:40 AM. Reason: additional info
    04-11-10 09:31 AM
  10. BLKJAK's Avatar
    First - Thank-you TheHeartlessHero for enabling me to get my GPS functioning after one year of ownership!

    I am a Cellcom of Green Bay, WI user. Not sure how many of us exist here I used the following to make my GPS functional:

    Phone: Curve 8330m (CDMA)
    OS: v4.5.0.186

    Skip the UniCDMA/WinHex portion of the instructions...it didn't work and wasn't needed. Go straight to the QPST section. The service programming code is: 000000.

    For the PDE information, I had to use Telus. The other carrier information would not work out. So I used:

    PDE IP Address: 216.198.139.92
    PDE Port Number: 8889
    PDE Transport = IP
    Position Calculation = Mobile

    I loaded GPSed to verify the GPS was getting a lock. I tested this from inside my house, right inside my patio door, and it was very cloudy today - if that matters. GPSed got a on/off lock. I moved close to the glass door, and it locked solid. Go figure . So, I then tried Google Maps. It got a lock in 10 seconds. It's the first time I got a little blue triangle on the screen...sweet! It said I was within 8 meters. Close enough for what I am going to use it for. BB Maps works too!

    Good luck to the rest of the Cellcom users. There is hope!
    Last edited by BLKJAK; 04-12-10 at 08:55 PM. Reason: Corrected OS version number.
    04-12-10 05:31 PM
  11. bilaliz's Avatar
    thanks OP for posting this fix, it was (as expected) driving me crazy

    here is how i screwed up my phone and then fixed it,
    bbmaps, nav4all and others were working until January when i decided to install lifeinpocket, which of course wouldnt work in canada, but it screwed my my gps and now it wouldnt work with ANY of the applications, bbmaps, google maps etc. and since i had another gps, i didnt give jack until i heard about trapster ... so after a lot of googling, i ended up here and it worked for me

    my device = 8830
    os: 4.5.0.127
    DM = 5 i think

    the values in unicdma that worked for me 0x1067ed90, and Length : 1703936
    p.s i could dl ver 2.1 at work so i used ver 1.095,
    my computers virtual ports were originally com 3 and com4, and unicdma picked the bb up
    however once i hooked up qpst, it would NOT detect the phone, so i changed the ports to 1 & 2, still no go, then i restarted the PC and bingo

    i can confirm the bell settings - they do work
    PDE IP Address: 206.47.201.75
    PDE Port number: 8888
    PDE Transport: IP
    Position Calculation: Mobile

    once again ... tx tx tx tx
    04-16-10 11:03 AM
  12. lancer1991's Avatar
    I apologize if this has been answered, but on my PC at work which is running Vista 64-bit, there is no COM & LPT in Device Manager. At home it shows on XP.

    Also, I don't see any info on anything for the IDEN network. Where do I go about finding the ip, etc I need to try this fix? The issue I have is TeleNav seems to find my location immediately, well 30 seconds or less most of the time, but if I go into Options>advanced>GPS, a refresh can take upwards of 2 plus minutes and 50% of the time it fails. This has impacted things like Google Maps, GPSLogger, and others.

    Thanks.
    05-05-10 11:08 PM
  13. ryanmercer30's Avatar
    This may seem like a stupid question but how can I downgrade my Telus 8350i to 4.5.138 so I can get my phone recognized and what not. I have searched for over 2 hours and cant find anywhere to download it as it is such an old OS.

    Thanks, Ryan.
    05-08-10 09:44 PM
  14. Jennydotz's Avatar
    Thank you to all who have contributed to this thread--the instructions in post 1 worked!! So far so good.

    GPS had worked in the past, didn't use it for some months and it didn't work today: Curve 8330m, US Cellular OS4.5.0.138 (which I downgraded from .169 in this process--totally forget why--I got so lost) I used the 2nd suggested set of entries for US Cell from the OP (64.58.50.45, 8889, IP, Mobile) I just followed the directions blind with absolutely no Idea what I was actually doing

    I called USC to get my 6-digit code since every single address/length entry I tried from the OP failed for me (reading errors every time, no bin file generated). So that wasted hours of my time, should have called to begin with. I ran QPST and never did get a correct model for my phone (no SURF options given, only FFA--I have no idea what those mean, but everyone else seemed to enter a SURFXXXX option for their unknown model phone). I just tried every option available til one gave me the gpsONE tab. The last one, of course. Scary error message (a "serious error" has occurred. . . phone model has changed, blabla) halfway through writing to the phone, said it would quit connection. I thought for sure it would be a bust , but voila--GPS worked!

    THank you Heartless Hero (and all contributors) for the great directions!
    06-16-10 10:49 PM
  15. Lexridge's Avatar
    I have been trying to make this work on my 8330m since Friday, on the nTelos network. I had contacted several tech support people at ntelos, and although all tried to be very helpful, nobody could give me the numbers I needed. My cousin also had a nTelos phone, a BB 8530 (Curve 2) which the GPS also did not work on. I used build .323 to read his, and was able to get the IP address and port from that. However, his bottom two fields were blank, so I filled them in, and volia, his GPS became active.

    So, I filled in those numbers on mine, and unchecked all the boxes on the right (using build 215) and finally, my phone's GPS started working. YAY!!! I get 11 sats in about 5 seconds.

    Here are the fields for nTelos:

    PDE IP Address: 10.120.255.130
    PDE Port number: 8888
    PDE Transport: IP
    Position Calculation: Mobile

    SPC is 000000 on most, if not all nTelos phones.

    NOTE: While all boxes need to be unchecked on the 8330, the top two DO need to be checked for the 8530. I tried this on the 8330 and it did not work.

    NOTE2: I was told by nTelos Advanced Tech Support, the numbers for Virginia would follow the Sprint or Verizon numbers, but I have no way to test or prove this, as I am not located in Va. I would find it odd if it worked actually, considering they could not give me the numbers listed above.

    NOTE3: The pdf document states that the boxes need to be "checked off." That is a bit confusing considering the photo shows all the boxes are checked. When ever I "check something off", I actually put a check mark next to it.

    Hope this helps someone, and thanks to the original author of this thread.

    Cheers
    Last edited by Lexridge; 06-22-10 at 09:27 PM.
    06-22-10 09:14 PM
  16. Devil's Avatar
    Has anyone tried this on Storm2? .713?
    07-19-10 12:05 PM
  17. rlbnorth's Avatar
    I have a Storm 2, trying to get this to read the memory Address and Length.

    I'm on Bell network.

    Anyone with Storm 2 got this to work?
    07-26-10 06:35 PM
  18. stabmaster's Avatar
    Okay so here's a riddle I've been working on; any help is much appreciated.

    I have a USCellular 9630 and I got the SPC from customer service. Edited GPSone a few different ways- it doesn't seem to matter much whether I use USCC info, Alltel, or Verizon- they all work to some degree.

    HOWEVER, when I add the info for QPST and let the phone reset, i get a really good, really quick lock on Google Maps before I reconnect the mobile network (10 meters). After mobile network is re-established I get a 3600m radius or so... immediately. Once I deactivate the mobile network I get a 10 meter lock again. Any idea how i can get Google Maps to do what it is supposed to? I deactivated "gps services" and "location aiding" individually and simultaneously and that didn't help.
    07-29-10 01:21 PM
  19. rasmith3530's Avatar
    I have a USCellular 9630 and I got the SPC from customer service.

    HOWEVER, when I add the info for QPST and let the phone reset, i get a really good, really quick lock on Google Maps before I reconnect the mobile network (10 meters). After mobile network is re-established I get a 3600m radius or so... immediately. Once I deactivate the mobile network I get a 10 meter lock again. Any idea how i can get Google Maps to do what it is supposed to? I deactivated "gps services" and "location aiding" individually and simultaneously and that didn't help.
    Just stabbing at a guess here, but seeing that it becomes inaccurate when you connect the network, I would think that US Cellular is either blocking the Port (8888 or 8889 depending on which settings) or the IP address. Port blocking would be my number one bet. Unfortunately, there really isn't much when it comes to tools out there to verify this from your BlackBerry device.
    08-06-10 10:03 AM
  20. cristgoatz's Avatar
    Pde ip: 0.0.0.0
    pde port: 4911
    pde transport: Ip
    position calculation: Mobile
    03-10-11 10:55 PM
  21. Julioys's Avatar
    have an UniCDMA 2.1 without virus ? because all that I found have high virus

    thanks
    09-13-11 11:49 AM
646 ... 242526
LINK TO POST COPIED TO CLIPBOARD