09-13-11 10:49 AM
646 ... 2223242526
tools
  1. Frankie Figs's Avatar
    I applied the fix a couple of months ago... and it worked great for me. I'm on Virgin mobile which uses the Bell network. I used the bell settings and saw a huge boost in gps performance.

    My question is I've done a couple of os upgrades since then and it never seemed to hurt or change the new settings that I did with Qpst... but suddenly it stopped working and I went into Qpst and found my settings back to what they were before? Now I did do an os downgrade ( problems with .175 and my ringers not working) but I was under the impression that the os had nothing to do with the "stuff" in the service programing...

    So my question is can my service provider push changes to my phone? or will upgrading or downgrading os's change those settings?
    I would like to know this as well.
    01-15-10 11:59 AM
  2. jabilllaw's Avatar
    Ok, I completed this process twice and each time my GPS remained non-functional . I have an bb 8330 flashed from verizon to metro. I downloaded gpsed and moble gmaps. and thanks to another fix was able to get the yahoo maps to work. but I have no gps. I know the gps is not working because on gmaps when I ask it to find me it doesn't even look for satellites it just dialogues "GPS position not yet determined make sure the phone can receive/determine......... prior to this fix I tried to use a key generator and turn my help screen to an engineering screen which worked. I entered the new settings into the gps: yet no working gps. I would like to have this feature as I travel alot. I have no data plan
    01-16-10 05:47 PM
  3. Crav's Avatar
    Ok, I completed this process twice and each time my GPS remained non-functional ...I have no data plan
    @jabilllaw, others could chime in, but no data=no GPS, period. Read through this thread for an explanation.


    To the last 20+ people who have posted on here but have not gotten a helpful reply:
    IMO, there is nothing we can really do to help you get yours working if you have read through ALL the posts in this thread and it still doesn't work.

    On that note, have you guys read through ALL the posts? You will notice that many posts on here a question, and whether they get answers or not, they post again all they did to get it working.
    Apparently, there is some secret formula that is different for different models on different carriers, but the general method provided by Heartless Hero IS indeed the base formula, you just have to tinker like hel with it, ok?

    The Curve is now pretty old, and regardless of the love people used to boast about for the Curve, many have probably moved on to the newer phones, which have a dedicated GPS chip and don't require all these hacks.

    If you are new to this forum, please don't think you can just get on here and post a question in the hopes someone else will do all the work for you like "help me, I can't get it to work." It's rude, bad forum etiquette, and ridiculous, and no one will answer it.
    It's a better idea... to read through this thread until you get to a user with your phone and your carrier, and then PM them.
    01-17-10 07:33 AM
  4. jabilllaw's Avatar
    Crave,
    FYI. I have read through all of the post on this and various forums regarding my situation and many of them say that there is an answer to the gps lock out situation generated by verizon. I may have misunderstood the purpose of the forum when I joined. Having purchased a blackberry I found the site and mistakenly thought it was a place for the sharing of information about blackberry phones. If my request regarding my situation with my phone has caused anyone any undo stress or generated a problem of any kind for them; forgive me and I hope they have been able to work through it.
    Last edited by jabilllaw; 01-17-10 at 02:57 PM.
    01-17-10 02:48 PM
  5. Chevyracing252's Avatar
    Just an FYI, I managed to correct this problem by simply loading OS 5.0.0.419 on my USC Tour, and now my GPS works GREAT!! GMaps shows me with 3 meters in most cases. Thanks everyone

    Posted from my CrackBerry at wapforums.crackberry.com
    01-19-10 10:46 AM
  6. Dinnearash Vareesh's Avatar
    Just an FYI, I managed to correct this problem by simply loading OS 5.0.0.419 on my USC Tour, and now my GPS works GREAT!! GMaps shows me with 3 meters in most cases. Thanks everyone

    Posted from my CrackBerry at wapforums.crackberry.com
    Are you noticing any issues with the new OS so far? I'm still slightly skeptical about putting it on my USC Tour.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-19-10 11:40 AM
  7. Chevyracing252's Avatar
    None so far. Reboot time is MUCH better than 4.7 (only 4.5 minutes vs. The 8+ it used to take with OE loaded 4.7). I did use ShrinkOS to remove a buncha crap before the 5.0 load, but so far I LOVE 5.0 and my GPS work better than my hybrid 8330 did!

    Posted from my CrackBerry at wapforums.crackberry.com
    01-19-10 11:43 AM
  8. Dinnearash Vareesh's Avatar
    None so far. Reboot time is MUCH better than 4.7 (only 4.5 minutes vs. The 8+ it used to take with OE loaded 4.7). I did use ShrinkOS to remove a buncha crap before the 5.0 load, but so far I LOVE 5.0 and my GPS work better than my hybrid 8330 did!

    Posted from my CrackBerry at wapforums.crackberry.com
    I'm still slightly a newb when it comes to installing stuff with Shrink Os and such. Could you PM me with more information. Ie - links to Shrink OS, how and what you removed. I would really appreciate the help.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-19-10 12:08 PM
  9. Chevyracing252's Avatar
    I will have to PM you the guide that I used when I get home from work tonight, but it is really simple if you follow the guide very closely. I plan on doing the same upgrade on my wife's USC tour tonight when she gets home.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-19-10 12:15 PM
  10. Dinnearash Vareesh's Avatar
    I will have to PM you the guide that I used when I get home from work tonight, but it is really simple if you follow the guide very closely. I plan on doing the same upgrade on my wife's USC tour tonight when she gets home.

    Posted from my CrackBerry at wapforums.crackberry.com
    Thanks man.

    Posted from my CrackBerry at wapforums.crackberry.com

    Posted from my CrackBerry at wapforums.crackberry.com
    01-19-10 02:56 PM
  11. HouseApe's Avatar
    Ok, I completed this process twice and each time my GPS remained non-functional . I have an bb 8330 flashed from verizon to metro. I downloaded gpsed and moble gmaps. and thanks to another fix was able to get the yahoo maps to work. but I have no gps. I know the gps is not working because on gmaps when I ask it to find me it doesn't even look for satellites it just dialogues "GPS position not yet determined make sure the phone can receive/determine......... prior to this fix I tried to use a key generator and turn my help screen to an engineering screen which worked. I entered the new settings into the gps: yet no working gps. I would like to have this feature as I travel alot. I have no data plan
    Thats why it wont work.
    01-19-10 03:33 PM
  12. HouseApe's Avatar
    I applied the fix a couple of months ago... and it worked great for me. I'm on Virgin mobile which uses the Bell network. I used the bell settings and saw a huge boost in gps performance.

    My question is I've done a couple of os upgrades since then and it never seemed to hurt or change the new settings that I did with Qpst... but suddenly it stopped working and I went into Qpst and found my settings back to what they were before? Now I did do an os downgrade ( problems with .175 and my ringers not working) but I was under the impression that the os had nothing to do with the "stuff" in the service programing...

    So my question is can my service provider push changes to my phone? or will upgrading or downgrading os's change those settings?
    I would like to know this as well.
    This is a firmware mod and the OS will have no effect on it.
    01-19-10 03:37 PM
  13. P-Dizz221's Avatar
    Can somebody with an 8330 VZW give us info if it worked for them or not?? i've been dying to try this. since i updated to the leaked 5.0 hybrid my BBMaps lost its GPS capability. Also....

    Device manager wont open!! i dl'ed Desktop M 5.0.1, when i open device manager along with it (or without) it wont open! it just shows me the Properties Window

    can someone please help!!!!
    01-19-10 11:55 PM
  14. jelp2's Avatar
    I just tried it on my wifes 8330,(VZ) with the new Boost 5.0 O/S so far its a no go!
    01-26-10 07:19 PM
  15. jelp2's Avatar
    Can someone with an VZ 8330, use QPST and read from their phone the gpsONE settings and post them.
    I know it's listed in the OP, but I was wondering if it has changed since then.
    Last edited by jelp2; 01-27-10 at 07:58 PM.
    01-27-10 07:47 PM
  16. HouseApe's Avatar
    Try installing (overwrite) the lbs API's and Maps .cod from 5.0.230 with BBSK

    Attachment 53014

    Should make it work again. I dont have VZW to test with.
    01-27-10 08:43 PM
  17. MusicMtl's Avatar
    Ok, I got my Tour gps working on Telus. OS 5.0.0.419. I had previously done the gps fix as detailed by the OP here, but to no effect (well, gps worked in bb maps but not google maps). I thought that once I upgraded my OS, the gps would start to work in google maps, but nope. My friend's worked and mine didn't. His was on the default settings and mine were edited with qpst. So, this is what I did:

    0.0.0.0
    Port 1
    IP
    Mobile

    Allow is ticked, and so is the first option in the list (sorry, I don't remember the label name. Spherical?). The other options are left blank.

    Basically, restored to the Telus defaults. Don't ask how, but the gps works now!

    Posted from my CrackBerry at wapforums.crackberry.com
    01-27-10 09:21 PM
  18. jelp2's Avatar
    Try installing (overwrite) the lbs API's and Maps .cod from 5.0.230 with BBSK

    Attachment 53014

    Should make it work again. I dont have VZW to test with.


    I downloaded the file but when i try to open it, it says no files to unzip or its corrupted.
    01-28-10 07:49 AM
  19. HouseApe's Avatar
    Try this one.

    Attachment 53048
    01-28-10 10:05 AM
  20. FireMedic559#CB's Avatar
    So just to make sure I understand definition of "overwrite" Go into BBSAK and "load CODS", find files from Zip folder and add without deleting the ones on the BB?

    Anyone do this on VZW 8330 and GPS now works? Hybrid Works GREAT!! and dont want to mess it up. Still having memory leak but i've had that since most versions of 4.5 so not sure if just my phone. But .348 shrunk was leaking about 13-14mb per 14hr period and on 4.5.0.175 about 3-4mb per 24hr (of course used Quickpull every day) Only had V2 since about 10p last night so maybe still settling cus' its still leaking
    01-28-10 12:09 PM
  21. HouseApe's Avatar
    Well you should delete the files first then load the ones from the zip. If your GPS worked on 5.0.230 but not on the 5.0.438 then this "should" fix it.
    01-28-10 01:28 PM
  22. FireMedic559#CB's Avatar
    Never used the .230 hybrid so I guess its worth a try since it doesnt work now
    01-28-10 02:00 PM
  23. Frankie Figs's Avatar
    Has anyone with an Alltel plan/device on the VZW network had issues with data? It seems like I lose data, from 1XEV to 1xev to 1x over the course of about an hour. BBM wont work with anything less than 1XEV and my GF and I use that to talk. I have to do a batt pull to get 1XEV back but usually I have to do 2 batt pulls because it will usually drop to 1x in about 5 mins on the first reboot. I never had a problem til I did this GPS fix. I know its a possibility thats its in the network but it seems like too much of a coincidence.

    BTW, Im running 4.5.0.169 with 5.0.0.100 files.
    01-29-10 01:18 PM
  24. jelp2's Avatar
    Try this one.

    Attachment 53048
    I loaded the cods up, but BBMaps isnt showing up anywhere to run it. It does show its loaded in the options>application screen. Did a couple battery pulls. The problem is definitely Boost .438, though. I reinstalled .175 and GPS worked great.
    Last edited by jelp2; 01-29-10 at 02:17 PM.
    01-29-10 01:43 PM
  25. flop's Avatar
    Should I do this to fix my 8310 by copying the settings from my working 8800? They are both on the same network.
    01-29-10 03:48 PM
646 ... 2223242526
LINK TO POST COPIED TO CLIPBOARD