09-13-11 11:49 AM
646 ... 1920212223 ...
tools
  1. ddskiend's Avatar
    Fix did not work on my Sprint 8330. I followed directions precisely. Does the fact that I'm connected to a Enterprise Server prevent me from changing things? However, the second time I went through the procedure, all the settings were still on the phone when I viewed them in QPST. Could something my company is sending out to my BB be disabling the GPS?
    08-26-09 10:18 AM
  2. tim484's Avatar
    Does this fix work for the BB-Bold? i just upgraded to 297 and the GPS stopped working.
    08-26-09 02:59 PM
  3. prowler1968's Avatar
    I have an Alltel 8330m and I have been trying every fix I can to get the GPS to function.

    I am currently running OS 4.5.0.169. I have entered the engineering screen with the Alt-Shift-H combination and went to the web site to get the unlock code per the GPS Fix located elsewhere in the forums.

    With this, every reboot always reset the IP and Port numbers, etc. that I entered to get the GPS to function.

    Even so, this is subject to work sometimes and sometimes not.

    I tried also the QPST to permanently set the IP and Port. This does survive the battery pull or quick pull program.

    However, I still have to access the engineering screen, go to GPS and press the application button to select "Start GPS". This always goes back off after any type of reset.

    Is there a way that the QPST tool can lock the GPS in the "Start" mode so I do not have to repeatedly enter the Engineering screen to set this back?

    At least the IP and Port is surviving the resets/OS upgrades, etc.
    08-26-09 04:26 PM
  4. ajm144k's Avatar
    man i just want to say thanks for this guide.

    unlocking true gps on my curve might have put it over the top as to whether or not i like it better than my htc diamond. now i play the waiting game with threaded sms...


    oh, and i can tell you that alltel msl's are all 0's.
    Last edited by ajm144k; 08-28-09 at 02:14 PM.
    08-28-09 02:11 PM
  5. diggy15's Avatar
    I got it to work fine on my alltel 8330. Thanks for the walk through

    Posted from my CrackBerry at wapforums.crackberry.com
    08-31-09 02:00 PM
  6. HouseApe's Avatar
    I have an Alltel 8330m and I have been trying every fix I can to get the GPS to function.

    I am currently running OS 4.5.0.169. I have entered the engineering screen with the Alt-Shift-H combination and went to the web site to get the unlock code per the GPS Fix located elsewhere in the forums.

    With this, every reboot always reset the IP and Port numbers, etc. that I entered to get the GPS to function.

    Even so, this is subject to work sometimes and sometimes not.

    I tried also the QPST to permanently set the IP and Port. This does survive the battery pull or quick pull program.

    However, I still have to access the engineering screen, go to GPS and press the application button to select "Start GPS". This always goes back off after any type of reset.

    Is there a way that the QPST tool can lock the GPS in the "Start" mode so I do not have to repeatedly enter the Engineering screen to set this back?

    At least the IP and Port is surviving the resets/OS upgrades, etc.
    The best thing to do is Start BlackBerry Map then select find location (this will prime the GPS). Once it finds you then start navagation. Takes less than 15 seconds for me.

    It will shut off the GPS chip when no app is using it to save battery life that's why your seeing it off in the E Screens.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-03-09 10:58 AM
  7. austinc70's Avatar
    Does anyone have the network settings for Cellular South?
    Any info would be helpful.
    Thanks
    09-03-09 05:20 PM
  8. HouseApe's Avatar
    Someone in this thread has got it to work. Just search for it.
    09-04-09 10:02 AM
  9. opnsrcaddict's Avatar
    Has anyone gotten Google Maps and other third party apps to work on a Verizon BB yet? I have the 8130 Pearl, I tried this hack and I don't think it did anything. I did get a 'serious write error' though. I've been looking through this thread, and I haven't really been able to find an sure answer.
    09-04-09 10:00 PM
  10. anon(368121)'s Avatar
    Has anyone gotten Google Maps and other third party apps to work on a Verizon BB yet? I have the 8130 Pearl, I tried this hack and I don't think it did anything. I did get a 'serious write error' though. I've been looking through this thread, and I haven't really been able to find an sure answer.
    Other than on the Storm and Tour, no. And they won't work unless Verizon opens up aGPS (assisted GPS) services.

    Since the Storm and Tour support standalone (autonomous) GPS, they work with a variety of 3rd party GPS apps. The 8130 only supports aGPS.
    09-05-09 11:02 AM
  11. opnsrcaddict's Avatar
    Other than on the Storm and Tour, no. And they won't work unless Verizon opens up aGPS (assisted GPS) services.

    Since the Storm and Tour support standalone (autonomous) GPS, they work with a variety of 3rd party GPS apps. The 8130 only supports aGPS.
    Looks like I might buy a keychain GPS then next pay check .
    09-05-09 02:30 PM
  12. sarivers's Avatar
    Looks like I might buy a keychain GPS then next pay check .
    I got fed up with my 8330m and my wife and I got the new Tour. Verizon had a buy one get another free. Man, the GPS is fantastic on the Tour. From day one it got 7 to 9 satellites locked within 5 to 10 seconds. Blackberry Maps and Google Maps both work. With this feature working it really makes the Blackberry special. Glad I traded in my Curve.
    Last edited by sarivers; 09-08-09 at 09:32 PM.
    09-08-09 09:29 PM
  13. macm1013's Avatar
    okay, im lost, (no pun intended),
    i still have no clue as to what "QPST" is.
    u guys are speaking a language i havent learned yet
    09-09-09 12:11 AM
  14. jetblack5820's Avatar
    So I started a thread a while back relating to the GPS issue. I was told to do the quick fix with garmin and it worked. Several weeks later and it doesn't work again.

    I am on US Cellular network, and use the Curve 8330.

    I have thoroughly read through this entire thread and have gathered the required information/programs to attempt this fix.

    So initially everything was working great until step 16. Locating the SPL/MSL Code (which I was under the impression that it was by default 000000 since USCC and Alltell are similar networks). I had no idea how to locate that even with Hex Workshop.

    I proceeded to step 17 assuming that I could try 000000.

    When I get to step 20, and "Service Programming" is opened I get the "Phone Selection" window and the default model entered is "CARD5500-1900". I can see the selection mentioned in step 21, however this seems to be a window early as this is the same window that pops up upon opening the program. I then click "OK" and it shoots me to the screen where I scroll to the right and find "gpsone". Nothing mentioned next is available (ie. "Read from Phone").

    Upon some searching around, I realized that my BB is not accessible anymore. When I go to My Computer---->Blackberry (K it says it is inaccessible and may have been moved.

    This leads me to believe that in the earlier steps, I have reconfigured the COM ports and now am unable to read from the device (Obviously an issue).

    I guess I have posted this to ask:

    1) How do I reconfigure the COM ports? I have gone back and switched everything back and forth time and time again and no luck. The phone still seems to be in working order (for the time being at least)

    I did follow the advice:

    "NOTE: If it says it Couldn't open port COM#, select the other Blackberry port. If you had to manually change the port as in steps 7-9, change the modified port back and then change the other Blackberry port."

    And

    "NOTE: You may have to disconnect your Blackberry and close the open programs (BB DM & UniCDMA) and start from step 10 again after reopening BB DM, reconnecting your Blackberry, and reopening UniCDMA. A restart could also be required." (minus the restart)

    After step 11, which was fruitless.

    2) Is the COM port issue the reason that the "Service Programming" will not locate my phone? (Or am I just reading the GUI of QPST/all the steps wrong?)

    and finally......

    3) What should my next step be?

    Am gonna leave it be for now until someone can maybe post a tip. Everything before this was flawless and seemed to work just fine.

    Is this just an issue with changing and fumbling around with the COM ports? (Believe me I have been to the Device Manager a hundred times.)

    If anybody in their infinite wisdom can point me in the right direction I would GREATLY appreciate it. I don't think I have effed this phone up..............have I?

    Edit to add: I forgot to mention that when I tried to go back to UniCDMA after step 11 (Following the Noted advice) UniCDMA would not read my phone at all like it did the first time. Even after going back and forth with the Device Manager and changing the COM ports. Probably just a symptom of the overall issue, however wanted to give full disclosure!!
    Last edited by jetblack5820; 09-10-09 at 09:16 PM. Reason: adding information
    09-10-09 09:11 PM
  15. jetblack5820's Avatar
    Alright alright, after the novel I posted........I got it working.

    I did the reboot and started from scratch and after working with the com ports I was able to gain access to the BB, thus allowing me to continue on.

    One issue I want to point out is the fact that I still could not see the BB on the My Computer screen. I grabbed my BB and realized it was locked, so I unlocked it and only then did it allow me to have access from within the computer. This could have been the issue initially. I have a keyboard locker (stupid accidental phone calls) and that kept locking my BB during the process. So that could have very well have been my problem initially. I don't know, but I wanted to point that out in case anyone else is having the same problem and has the (a) keyboard locker installed. Also could have been the reboot, but everything worked perfectly after I disabled the keyboard app.

    Thank you to the gentlemen who wrote this thread and kept up to date with it, I now have almost instant GPS lock on no less than 9 (so far) satellites. It remains to be seen, however, if this particular fix will be permanent as the last fix (I realize it was very generic) did not.

    Will update, but until then I am very happy with this!!

    (Curve 8330; US Cellular)
    09-10-09 10:40 PM
  16. mtruman2's Avatar
    I have tried everything to get my GPS o work on my Alltel 8330. ! finally had the time and the nerve to try your fix - and after a couple of reboots - it works! Thank you so much for your help. You rock! lol
    09-11-09 11:24 PM
  17. Chevyracing252's Avatar
    I applied the gps fix to my USCC 8330 a few weeks ago and initially, it was GREAT! Instant sat locks on 9 to 12 sats every time, but now I can't get the stupid GPS to lock at all. I got ready to re-apply the fix thinking that USCC had cleared the GPSOne Information from my phone again, but all of the ip info was still there and matched the info in the guide. Any other suggestions? Thanks in Advance.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-15-09 09:42 AM
  18. Chevyracing252's Avatar
    Ok, I just tried the garmin quick fix and now my gps works quickly, but loses the lock about 5 seconds after getting it then it takes another 10-15 seconds to obtain a new lock. Let me know what your thoughts are (at least to hold me over for a couple of months until USC releases the Tour. :-)

    Posted from my CrackBerry at wapforums.crackberry.com
    09-15-09 01:48 PM
  19. MusicMtl's Avatar
    Hi everyone,

    I was able to get the MSL code for my Tour. If I use the same version of QPST as for the Storm (in the instructions provided in this thread), and follow the same procedure, will it work? I'm wondering if someone else has tried this. I don't want to brick my phone!

    (I did the GPS fix previously with my Curve 8330, and had no problems at all.)

    Thanks!
    09-20-09 06:18 PM
  20. MusicMtl's Avatar
    Well, I took a chance and made the changes. It worked. GPS loads much faster in BBMaps, Poynt, etc, but Google Maps still does not work! Impatiently waiting for Google to release a new version...
    09-22-09 03:03 PM
  21. Shifty_P's Avatar
    my uniCDMA keeps saying that the phone is not connected in the bottom left corner
    09-27-09 02:41 PM
  22. mjcarter's Avatar
    Where can i get the qrst program?
    09-27-09 08:59 PM
  23. jzklein's Avatar
    dose this work to fix the 8330 5.0.0.230 GPS problem?
    10-02-09 09:09 AM
  24. ExtremeJ's Avatar
    Worked excellent on my g/f Telus 8330, a quick note though, if uniCDMA doesn't read the phone memory, you will have to downgrade the phones OS and it will work, other than this little setback, works perfectly... thanks.
    10-04-09 10:04 PM
  25. qd4w's Avatar
    I have read through this entire thread and I just want some clarification. I have the 8330 with Alltel service. I have OS 4.5.0.169 currently on my phone. I will need to install DM 4.6 because I currently use 4.5. Since I know my SPC (000000) do I need to downgrade my OS to .131 or lower?
    10-06-09 03:45 PM
646 ... 1920212223 ...
LINK TO POST COPIED TO CLIPBOARD