09-13-11 10:49 AM
646 ... 1415161718 ...
tools
  1. roadwarrior69's Avatar
    So when you "read" from phone is the setting still blank?

    not totally blank, it has the service programming field populated and slot cycle index set.

    I don't see too much on the setting tab though like field service is blank and roam messages just has numbers 1 - 6 but no messages

    it also has the gpsOne tab filled in with what I put in last time (usc codes)
    06-14-09 11:11 AM
  2. HouseApe's Avatar
    not totally blank, it has the service programming field populated and slot cycle index set.

    I don't see too much on the setting tab though like field service is blank and roam messages just has numbers 1 - 6 but no messages

    it also has the gpsOne tab filled in with what I put in last time (usc codes)
    Dont touch anything other that the gpsOne tab. So all the settings and all the boxes (checked) is still there when you read. Any you are using the Alltel settings correct ?

    Try and uncheck all the boxes and then check them again then write to phone. Do not unplug bb or touch your pc until the BB boots back up. Then turn the raido back on and try the GPS again in BB Map Start Nav.

    If it dont work see what the log file says ALT + LGLG
    06-14-09 01:49 PM
  3. roadwarrior69's Avatar
    Dont touch anything other that the gpsOne tab. So all the settings and all the boxes (checked) is still there when you read. Any you are using the Alltel settings correct ?

    Try and uncheck all the boxes and then check them again then write to phone. Do not unplug bb or touch your pc until the BB boots back up. Then turn the raido back on and try the GPS again in BB Map Start Nav.

    If it dont work see what the log file says ALT + LGLG

    BUnch of stuff in the Log, what should I be looking for?
    06-14-09 01:57 PM
  4. HouseApe's Avatar
    any GPS errors ?
    06-14-09 02:31 PM
  5. roadwarrior69's Avatar
    any GPS errors ?
    Yeah there were gps errors, I cleared the log need to rerun to get what they were.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-14-09 02:56 PM
  6. roadwarrior69's Avatar
    Got it to work on my 8330m

    I dbl chked the build for qpst and it was b91 not b215. The piser about it was that the zip had the build correct, it was only when I was pulling my hair out and decided to check the program help to validate build were I found it

    It works - fast in bbmaps, 11 sat found too.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-14-09 10:24 PM
  7. HouseApe's Avatar
    I did not think to ask you that one. Good to know and glad it now works!!!
    06-15-09 11:26 AM
  8. liquid_crack's Avatar
    So, for anyone with a new USCC 8330m, you will have to use a bit of "social engineering" to get your SPC from US Cellular foks, and you will want to use the same 2.7 Build 215 of QPST that works with other 8330's.
    I also have USCC 8330m .138.
    I am also having no luck geting the uniCDMA to read.
    What sort of explanation did you use to get them to give up the SPC?
    Please, teach us this mystical art of "social engineering." Sorry just not feeling creative/brave at the moment.
    Also, is it possible that all USCC phones have the same SPC?
    06-17-09 11:11 PM
  9. roadwarrior69's Avatar
    I also have USCC 8330m .138.
    I am also having no luck geting the uniCDMA to read.
    What sort of explanation did you use to get them to give up the SPC?
    Please, teach us this mystical art of "social engineering." Sorry just not feeling creative/brave at the moment.
    Also, is it possible that all USCC phones have the same SPC?

    Well, I have two 8330m. I have been in discussions with USCC for over a month, trying to get my GPS to work etc.... They sent out replacement phones telling me the device was bad, they transfered me over to RIMM - lots of time and lots of phones swapping back and forth to get this working.

    My mystical art.... I one morning after trying the unicdma and getting all the apps downloaded on the net decided to just call them. I asked the data services tech that I'm trying this fix (yes, he was worried), then I sent him the PDF so he can be educated on the fix, then when he was convinced that I was not going to F up the phone - he gave me the code. ... simple. It was a 10 min talk, he learned a little - I got my code.

    He was then interested in how things would turn out, so he wanted me to get back to him, and I did - told him it works and now I can find GPS Sat from my bed room.

    Two days after doing this, I decided to fix my other 8330m, this time things were not working so well. I back tracked did all my steps - nothing. I recalled USCC and talked it over with them, telling them the story again, and how I got the SPC and fixed my GPS. Then they explained that every phone has a unquie SPC code, so I asked for my SPC and they gave it to me - simpile, 10 min talk.

    I now have both 8330m working on GPS (by the way I need a good app BBMaps is too sloooow - any ideas anyone?) and life is good.

    Edit: Not sure why service companies do not know of this, and why they do not put a fix in? I've gone so far to ask for monthly credit (and I've gotten them) for the GPS not working, bc this is a service that they sell and I'm paying for.

    So adivse to you home gamers - If your not getting this fix to work, ask for a credit.
    06-18-09 07:56 AM
  10. Md_Sailor's Avatar
    ...Am i wrong or did Verizon not enable the GPS feature on Blackberrys this year? is this Really Necessary?
    06-18-09 09:56 AM
  11. liquid_crack's Avatar
    I now have both 8330m working on GPS (by the way I need a good app BBMaps is too sloooow - any ideas anyone?) and life is good.
    Well roadwarrior69, it seems the squeaky wheel does get the grease! I walked into the store where I bought the phone, asked for the SPC code, got it no questions asked. So that puts me one step closer.

    I've applied the fix following all the well defined steps, and I am still yet to see any change in behavior from my phone.


    My phone - U.S. Cellular BB 8330m (grey) CDMA - v4.5.0.138
    My location - Chicago, IL (West Suburbs)
    I get EVDOx1 service connection

    1. QPST: using SURF6300-BB profile
    2. QPST: PDE settings for Alltel/USCellular
    205.142.19.100
    8888
    IP
    Mobile
    3. QPST: all check boxes on left side of gps panel checked=TRUE
    4. QPST: applied settings,... errors,...rebooted etc., checked settings after with QPST and they stuck, good.
    5. BB phone and internet connect and work fine, phew!
    5. BB GPS Settings: Device GPS/Location ON
    6. BB Application Permissions: GPS Allowed

    7. The guide said I'm supposed be enjoying my GPS now, grrrr!
    I've tried on the following apps:
    BB Maps
    Google Maps
    Black Star Navigator

    Do you or anyone else with USCC 8330m have any further suggestions.

    Is it possible I need to *228 my phone? I am hesitant do so since I have heard rumor this may reset my SPC code, I don't want to have to ask for it again if I can avoid it.

    I've also seen suggested removing the GPS enabled apps, then reinstalling them, can anyone confirm this is a real solution?

    The funny thing is, when I was traveling a few weeks ago in CA and NV, Google Maps (not using GPS) was able to get accurate locks on my location in no time down to the street corner. When I am in my home network area, it places me anywhere from 1 mile to 50 miles off location, and jumps around a lot. What's that all about?

    I've already spent a couple of nights working on this, I considering getting back in line with the rest of GPS disabled cattle. Mooo!

    Thanks in advance to anyone who helps!
    06-18-09 09:11 PM
  12. liquid_crack's Avatar
    w00t!

    I can confirm U.S. Cellular 8330m as working!

    I got it working, i tried QPST_2.7_build_231.exe instead
    Found it here: hmmm, seems I'm not allowed to post links yet

    Try
    http
    slil.ru/23570298/7317f844.4a3bb218/
    QPST_2.15_build_231.rar

    , the file is misnamed.


    USCC 8330m CDMA v4.5.0.138
    Windows XP Pro SP3
    BB Desktop Manager 4.7
    QPST 2.7 b231
    basemodel: SURF6300-BB
    gpsOne settings for Alltel/UsCellular

    Thanks to everyone for all the help!
    06-18-09 11:16 PM
  13. HouseApe's Avatar
    w00t!

    I can confirm U.S. Cellular 8330m as working!

    I got it working, i tried QPST_2.7_build_231.exe instead
    Found it here: hmmm, seems I'm not allowed to post links yet
    What build did you use that didnt work?
    06-19-09 09:23 AM
  14. Pita_146's Avatar
    Does this work with the 8230 flip?
    06-21-09 09:56 AM
  15. hapyman's Avatar
    Hey everyone,

    I've implemented the fix and still can't get access to any satellites in BBmaps, google maps, blackstar or anything for that matter. The installation went very smooth and was able to get everything to operate correctly. I've read through most of this thread and it seems everyone with my phone & network has it up and running.

    8330m CDMA
    Alltel
    4.5.0.127
    BB Desktop Manager 4.5
    QPST 2.7 build 215
    basemodel: SURF6300-BB

    gpsOne settings for Alltel/UsCellular

    All boxes are checked and good (rechecked it multiple times)

    Firewall is OFF

    GPS/Location is ON

    Thanks!
    Last edited by hapyman; 06-21-09 at 10:14 PM.
    06-21-09 10:06 PM
  16. roadwarrior69's Avatar
    The secrite for me was in the qpst version. Its got to be the few versions that work.

    I was putzing around with a 91 build and the zip was named b215, but until I looked at the help I wasn't able to confirm.

    Lesson learned, if your not getting your **** to work, validate build version

    Posted from my CrackBerry at wapforums.crackberry.com
    06-21-09 10:14 PM
  17. hapyman's Avatar
    I just checked and the build is 215.

    Do you think I should give build 231 a shot like liquid_crack? Is there any harm in trying a different, more recent build?
    06-21-09 10:18 PM
  18. roadwarrior69's Avatar
    I just checked and the build is 215.

    Do you think I should give build 231 a shot like liquid_crack? Is there any harm in trying a different, more recent build?
    Do u have your spc code? Are u able to read and write from the phone?

    Make sure u don't disconnect the phone at the final step while the error msg are poping up, let it reboot all the way then unplug after.

    Last point, go outside and try to lockin on gps, can do it in bbmap if u want

    Posted from my CrackBerry at wapforums.crackberry.com
    06-21-09 10:25 PM
  19. hapyman's Avatar
    Do u have your spc code? Are u able to read and write from the phone?

    Make sure u don't disconnect the phone at the final step while the error msg are poping up, let it reboot all the way then unplug after.

    Last point, go outside and try to lockin on gps, can do it in bbmap if u want

    Posted from my CrackBerry at wapforums.crackberry.com
    Yeah my spc code was the default Alltel one: 000000.

    I rebooted my phone all the way before unplugging it as I had seen it in another post.

    Also tried outside. No luck, no satellites

    May try to write to the phone again, for the third time for S&Gs. When I read the settings from the phone on QPST everything looks kosher.
    06-21-09 10:29 PM
  20. hapyman's Avatar
    Tried pushing the information to the phone again. This time I updated my Desktop Software from 4.5 to 4.7. Didn't think this would be the problem but thought I would try anyhow.

    Just a couple of observations here, not sure they mean anything:

    When booting up the QPST, under the 'Phone Selection' dialog, my phone number is listed wrong.

    Second, when I push the info to the phone and allow it to reboot the radio is turned off initially and I have to

    Anyhow as I am writing this the GPS is just starting to work.

    Not sure what did it... may be the Desktop Software since that is the only thing I changed. Thanks for all your help.
    06-21-09 11:04 PM
  21. roadwarrior69's Avatar

    Not sure what did it... may be the Desktop Software since that is the only thing I changed. Thanks for all your help.
    Great news, enjoy!

    Now u will be on a quest for best gps app - good luck, I'm still searching!!

    Posted from my CrackBerry at wapforums.crackberry.com
    06-21-09 11:08 PM
  22. hapyman's Avatar
    HAHA... you are right my friend . Just downloaded LifeInPocket and AmazeGPS. Will have to give each one a whirl tomorrow and see how good they work. Also have blackstar and may try TrekBuddy and Nav4All.

    With that being said Google Maps may do just fine. Sometimes those voices on GPS systems can get annoying. Sounds like a backseat driver telling me what to do.
    06-21-09 11:41 PM
  23. HouseApe's Avatar
    You need to use the higher port number so the correct phone number shows up.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-23-09 09:36 AM
  24. RaulSuarez's Avatar
    does anyone know the Network Settings & Addresses and Address & Length for UniCDMA for a virgin mobile canada BB 8330???? i want to use this guide but dont know thi info cuz all the info in guide is for US cellular providers
    06-23-09 08:30 PM
  25. HouseApe's Avatar
    does anyone know the Network Settings & Addresses and Address & Length for UniCDMA for a virgin mobile canada BB 8330???? i want to use this guide but dont know thi info cuz all the info in guide is for US cellular providers
    Um no It was made up for Telus at first then expanded to include other carriers. Anyways the SPC "should be in the same location" Just use the Bell settings as Virgin is running on Bell's network.
    06-24-09 10:04 AM
646 ... 1415161718 ...
LINK TO POST COPIED TO CLIPBOARD