1. samsams's Avatar
    For the third time for no reason I cannot send sms from my 8100 pearl.
    The other times after a few days I could send them again.
    After trying to send a msg it says " Protocol Error"

    My simcard works fine on another 8100 pearl and sends out sms.
    T-mobile says they are not aware of any problems on the network and it could be a problem with my BB.
    Is there a way to check it myself if there is an error somewhere?
    10-14-08 08:40 AM
  2. jeffh's Avatar
    You could try resending your service books. You may be able to do that from your carrier's website. The Email Setup Wizard also has an option to resend service books. You can also re-register your Host Routing Table:
    Options / Advanced Options / Host Routing Table / Menu / Register Now
    10-14-08 09:05 PM
  3. samsams's Avatar
    THX

    Have requested new servicebook by logging in to T Mobile.
    But that is only for email (which works fine) or not?

    Going to Options / Advanced Options / Hostblablabla / Menu I can re-register yes, but there are 5 different codes that apear, the first one in bold.
    Do I have to re-register for each of those codes?
    When I View each of these codes a lot of abracadabra appears for me but at least it all seems " registered"

    So far still same Protocol-Error and no SMS going out.

    Any other suggestions will be very appreciated.

    THX from Holland
    10-15-08 05:11 AM
  4. jeffh's Avatar
    Service Books control various aspects of your device, not just email. Re-sending them sends them all, which may help and can't hurt. The same applies to the HRT entries. Register Now re-registers them all. That fixes some issues, and can't hurt.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-15-08 09:06 AM
  5. samsams's Avatar
    THX
    But sadly nothing you suggested helped.

    Could an upgrade to 4.5 help?
    10-15-08 09:19 AM
  6. jeffh's Avatar
    I'm not a big fan of upgrading the OS as a trouble-shooting approach, since OS upgrades can introduce their own problems. You might want to Google "SMS protocol error" and see if you turn up anything.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-15-08 09:26 AM
  7. samsams's Avatar
    Thx for your help anyway.

    Guess what? I resolved the problem myself by going to
    Options / SMS / Network: GSM in stead of the GPRS or GPRS Preference options.
    I use the GPRS network of T-mobile but I guess now that it works different for sending SMS. Strange, still don't understand it but at least it works now. :-)

    So thx again for yr input.
    10-16-08 03:50 AM
  8. jeffh's Avatar
    Thank you for posting your solution. Even if you don't understand it, at least it gives the next guy with the same problem something to try.
    10-16-08 08:51 AM
LINK TO POST COPIED TO CLIPBOARD