1. crisg723's Avatar
    I have a Netgear wireless N router, but it is supposed to allow for devices with b/g protocol. However my 9700 does not stay connected to it. The BB will say its connected to it, but no signal will go thru, and the router will not give an answer if I ping it. Does anyone else have this problem? I have a laptop that connects using wireless g, and other devices have connected as well, seems to only be my 9700.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-29-10 01:33 PM
  2. syb0rg's Avatar
    Do you have MAC filtering turned on?
    12-29-10 01:40 PM
  3. aparkins30's Avatar
    syb0rg is probably right, you probably just need to add the MAC id to acceptable IDs on your router. My 9700 runs fine through my router, which is also an N router (but b/g compatible)
    12-29-10 01:48 PM
  4. crisg723's Avatar
    I have MAC filtering turned off, I'm using WPA security, and my router also has WPS setup which I tried but didn't work either. My 9700 connects for a while, then the WiFi icon turns grey, then white again for a while, then grey again.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-29-10 02:22 PM
  5. syb0rg's Avatar
    I have MAC filtering turned off, I'm using WPA security, and my router also has WPS setup which I tried but didn't work either. My 9700 connects for a while, then the WiFi icon turns grey, then white again for a while, then grey again.

    Posted from my CrackBerry at wapforums.crackberry.com
    Sounds like the phone is dropping the Wi-Fi signal, i would strongly recommend updating your phones OS, as this might be a minor bug in the native firmware.
    12-29-10 03:02 PM
  6. WolfmanRobby's Avatar
    3 things to try-

    1- Netgear has put out some buggy firmware and they know it. It causes problems with Non-N band devices. For most devices, they pushed out updated firmware. I would verify that you have the latest firmware for your Netgear router.

    2- You say your are using WPA, so this shouldnt matter. But, there's a known bug where the NetGear Generates a 65 character WEP key and the field on the BB only lets you enter 63 or 64. So, the key never get's fully entered. The fix is to switch to a shorter WEP key that you manually enter on the router and then your wireless devices.

    3- Turn off the N band on the router. While MANY devices say they are backwards compatible, they seem to give priority to N band devices and drop the B/G band. Unless you have have an internet connection faster than 54Mbs, you won't notice any difference using only B/G for everything. (Except maybe file copies across the local LAN).
    12-29-10 03:19 PM
  7. crisg723's Avatar
    Updated the firmware on the router, been connected for about 40 mins, so far so good.
    12-29-10 04:12 PM
  8. BoldtotheMax's Avatar
    Humm, might have to try this when over the rents' house next time as I can nver seem to connect to their N Netgear router.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-29-10 08:12 PM
  9. Rootbrian's Avatar
    Firmware is always a first to check besides any filtering put in place. It could also be the wifi profile on the blackberry too, so if the firmware didn't do anything (in your case it seemed to work), then it's the bb's wifi profile that just needs to be purged and re-created when you connect again.

    I got rid of my mimo router as it wouldn't let any blackberry connect at all. TrendNet FTW!!

    Posted from my CrackBerry at wapforums.crackberry.com
    12-29-10 10:13 PM
LINK TO POST COPIED TO CLIPBOARD