1. SoenkeWeiss's Avatar
    Searching the forums I couldn't find this problem being reported before.

    For my "work privacy" I have to restrict my caller ID at all times, this works fine if I make calls using the Blackberry Curve 8520 itself and with my bluetooth headset. Now, what happens if I press the "redial" button on the bluetooth headset is that the caller ID is being sent all of a sudden. Does this make any sense? Is this a problem in the Blackberry software? I tried out 2 Blackberrys and 2 headsets, usually I use a Samsung WEP470 headeset.
    08-20-10 07:27 AM
  2. b1gbleu's Avatar
    How do you usually block the caller id?
    08-20-10 08:35 AM
  3. SoenkeWeiss's Avatar
    Phone Options -> General Options -> Restrict my Identity -> Always

    You may try it out yourself, it's not a problem with the bluetooth device as on my iPhone it works all the time, meaning the number is being hidden when dialing using the keypad or the redial button on the headset.
    08-20-10 08:47 AM
  4. b1gbleu's Avatar
    I don't have that option on my BB. It does sound like it's your phone, as you say it doesn't do it with the iphone. Have you tried another BT device with your BB?
    08-20-10 09:08 AM
  5. SoenkeWeiss's Avatar
    Yes, I did. And I tried another BB as well. I'm on Vodaphone UK btw.

    How would you restrict your caller ID?
    08-20-10 09:26 AM
  6. b1gbleu's Avatar
    I believe it's on a per call basis, *82 or something like that. If I want to call someone without letting them know it's me, I usually borrow someone else's phone.
    I got a guy that owed me money that way, he blocked my # and wouldn't answer anon calls
    08-20-10 10:20 AM
  7. SoenkeWeiss's Avatar
    No, you're wrong, it's a normal setting. Anyway, don't matter.
    08-20-10 02:00 PM
  8. b1gbleu's Avatar
    I'm wrong? You asked me how I block caller ID. What's a nomal setting?
    Remember, you're the one with the caller ID problem, not me.
    08-20-10 06:08 PM
  9. T
    I send any hidden/restricted numbers straight to voicemail.
    09-12-10 06:50 AM