05-08-08 08:06 PM
46 12
tools
  1. APcell's Avatar
    I am using Gmaps with Blackberry 8310 and it cannot seem to find my location using the internal GPS

    I know i was able to do so, same phone just a week ago, and pinpoint the location within 10m accuracy (and also got a little pointer that shows the direction of travel when moving/driving around).

    Then i think i updated to this 2.0.3 version and somehow i only get location from towers () .. This version has 'my location beta' and i do have that feature activated .. yet, no gps accuracy !?

    Is anyone esle having the same problems with the 8310 and Gmaps ??

    Thanks,
    AP.

    P.S. yes, i am outside, BBmaps works, Options-Advanced-GPS-Refresh shows 5 to 9 satellites registered, and every other GPS application that i have installed (GPSed for example) is having no problem communicating with the GPS
    yes, all permissions for Gmaps is set to ALLOW
    Last edited by APcell; 04-21-08 at 01:38 PM.
    04-21-08 01:36 PM
  2. Xopher's Avatar
    What happens if you have BB Maps running in the background? Will GMaps use the GPS?
    04-21-08 05:44 PM
  3. APcell's Avatar
    Good point .. and the answer is NO

    I had 9 satellites logged and pinpointed accuracy with BBmaps
    while at the same time Gmaps was at 1400m accuracy !

    I guess i can just use BBmaps but i really liked Google/with gps and i know it works so?! this is really weird ..
    04-21-08 09:05 PM
  4. jeffh's Avatar
    Good point .. and the answer is NO

    I had 9 satellites logged and pinpointed accuracy with BBmaps
    while at the same time Gmaps was at 1400m accuracy !

    I guess i can just use BBmaps but i really liked Google/with gps and i know it works so?! this is really weird ..
    Please don't be offended by my question, but I notice that you are new to the forums, and thus, perhaps, to blackberrys. To the question: Did you exit BBMaps, or leave it running in the background? Google Maps lacks the ability to keep an EXTERNAL gps puck locked. I don't know about the INTERNAL gps, because it is disabled on my 8830. But with an external gps, you have to have another program such as BBMaps or GPSed running in the background, or Google Maps will lose the GPS signal and revert to tower triangulation.

    You do need "My Location Beta" enabled as you have.
    04-21-08 09:20 PM
  5. raymond's Avatar
    Sometimes it takes few seconds for the gps to kick in for google maps. I found MSN's Live serch mapping to be just as functional. But, when in doubt, just leave it sit. When I'm having issues I just walk or drive a block or so and wait for it to kick in.

    Hope that helps.
    04-21-08 10:20 PM
  6. etervotion's Avatar
    I am using Gmaps with Blackberry 8310 and it cannot seem to find my location using the internal GPS

    I know i was able to do so, same phone just a week ago, and pinpoint the location within 10m accuracy (and also got a little pointer that shows the direction of travel when moving/driving around).

    Then i think i updated to this 2.0.3 version and somehow i only get location from towers () .. This version has 'my location beta' and i do have that feature activated .. yet, no gps accuracy !?

    Is anyone esle having the same problems with the 8310 and Gmaps ??

    Thanks,
    AP.

    P.S. yes, i am outside, BBmaps works, Options-Advanced-GPS-Refresh shows 5 to 9 satellites registered, and every other GPS application that i have installed (GPSed for example) is having no problem communicating with the GPS
    yes, all permissions for Gmaps is set to ALLOW
    what os are you using? I had that same problem before (while trying the beta) and only 2.01 would work. However with the latest beta, 4.5.0.18, gps is down to 3 meters and that is with 2.03 Gmaps
    04-21-08 10:47 PM
  7. APcell's Avatar
    Right, good point - i am using the internal gps and i do have BBmaps running in the background (so i am pretty sure that the gps receiver is "hot") .. i also try to refresh it manually (and that happens relatively fast) .. other progs like GPSed also have no issues accessing the gps location .. it's just Gmaps that refuses to use the gps data (permissions all set to ALLOW).
    Also, it is SAD that Gmaps 2.0.3 menu has an option “Bluetooth GPS” but not option “Internal GPS” ..

    - thank you guys for the help !


    Please don't be offended by my question, but I notice that you are new to the forums, and thus, perhaps, to blackberrys. To the question: Did you exit BBMaps, or leave it running in the background? Google Maps lacks the ability to keep an EXTERNAL gps puck locked. I don't know about the INTERNAL gps, because it is disabled on my 8830. But with an external gps, you have to have another program such as BBMaps or GPSed running in the background, or Google Maps will lose the GPS signal and revert to tower triangulation.

    You do need "My Location Beta" enabled as you have.
    04-22-08 12:47 PM
  8. APcell's Avatar
    what os are you using? I had that same problem before (while trying the beta) and only 2.01 would work. However with the latest beta, 4.5.0.18, gps is down to 3 meters and that is with 2.03 Gmaps
    -- IS THAT AN 8310 that you are using? --

    Good point - I am using OS 4.5.10 and i was getting 3 meter accuracy before (when Gmaps was working properly - with 4.5.10 that is) ..

    I would update to OS 4.5.18 IF I COULD FIND THE DARN THING .. but are there any other known issues i may have with that BETA?
    what's your experience?

    - for example -
    JiveTalk works with .18 ?
    GPSed works with .18 ?
    Geotagging with the Berry-camera in .18 ?

    - these are must have progs/features for me .. i don't care than much about having the latest OS (or Gmaps - since BBmaps works fine) .. but i need those.
    Last edited by APcell; 04-23-08 at 02:02 PM.
    04-22-08 12:55 PM
  9. jeffh's Avatar
    ...Also, it is SAD that Gmaps 2.0.3 menu has an option Bluetooth GPS but not option Internal GPS ...
    I don't have "Bluetooth GPS" on my Gmaps 2.0.3 menu, perhaps because I am running an external bluetooth GPS. One way I can tell that the external GPS is locked is by the bluetooth indicator on the BB flashing once a second or so. I assume the internal GPS has no such heartbeat signal.

    I believe other users are using Gmaps 2.0.3 with internal GPS's. I don't know what else to suggest. I hope somebody can post a solution.
    04-22-08 03:00 PM
  10. APcell's Avatar
    Thanks Jeff,
    Yes, no heartbeat for internal GPSrs .. I guess the solution would be to upgrade to 4.5.18 or downgrade to 4.2 (it seems I am stuck in beta-twilight-zone) lol !!
    The newest version of Gmaps I got from mobile_google_com (or www_google_com/glm) did have that reference to Bluetooth try that out and see what happens. I am looking for an older version now


    I don't have "Bluetooth GPS" on my Gmaps 2.0.3 menu, perhaps because I am running an external bluetooth GPS. One way I can tell that the external GPS is locked is by the bluetooth indicator on the BB flashing once a second or so. I assume the internal GPS has no such heartbeat signal.

    I believe other users are using Gmaps 2.0.3 with internal GPS's. I don't know what else to suggest. I hope somebody can post a solution.
    04-22-08 05:04 PM
  11. APcell's Avatar
    I don't have "Bluetooth GPS" on my Gmaps 2.0.3 menu, perhaps because I am running an external bluetooth GPS. One way I can tell that the external GPS is locked is by the bluetooth indicator on the BB flashing once a second or so. I assume the internal GPS has no such heartbeat signal.

    I believe other users are using Gmaps 2.0.3 with internal GPS's. I don't know what else to suggest. I hope somebody can post a solution.

    here is a screen shot of Gmaps 2.03 menu and the Bluetooth GPS option that was added (2.01 doesn't have that option) .. and imo that's why the new version CANNOT find the internal GPS !

    Last edited by APcell; 04-23-08 at 02:52 PM.
    04-23-08 02:39 PM
  12. jeffh's Avatar
    here is a screen shot of Gmaps 2.03 menu and the Bluetooth GPS option that was added (2.01 doesn't have that option) .. and imo that's why the new version CANNOT find the internal GPS !
    According to the Help screen, I definitely have Version 2.0.3 (#2035). I don't have the ability to capture screen shots, but my menu reads
    Search
    My Location
    Directions
    Satellite View
    Clear Map
    Show Traffic
    Favorites
    Zoom
    Help
    Exit

    I can pan using the trackball, so maybe that's why I don't have that menu item. Maybe I don't show the Bluetooth GPS line BECAUSE I'm using an external GPS. I don't know. I went outside and turned on the GPS. Google showed my location to 3 meters, so I know it was reading the GPS, but no GPS line in the menu. Maybe if I switched the BB GPS settings to Internal GPS, it would show that line? No...I went to Options/Advanced Options/GPS and changed the GPS Data Source to "Device GPS," saved, and went back to Google Maps and still don't have the Bluetooth GPS entry in the menu. Of course, the 8830 internal GPS is disabled, so maybe that's explains it.
    04-23-08 03:09 PM
  13. APcell's Avatar
    According to the Help screen, I definitely have Version 2.0.3 (#2035). I don't have the ability to capture screen shots, but my menu reads
    Search
    My Location
    Directions
    Satellite View
    Clear Map
    Show Traffic
    Favorites
    Zoom
    Help
    Exit

    I can pan using the trackball, so maybe that's why I don't have that menu item. Maybe I don't show the Bluetooth GPS line BECAUSE I'm using an external GPS. I don't know. I went outside and turned on the GPS. Google showed my location to 3 meters, so I know it was reading the GPS, but no GPS line in the menu.
    this is weird .. I BET it's because when you download OTA the server sends you a certain software based on your cell (i recall some _blackberry_40 somewhere and i have seen a screenshot for the 8820 that said _blackberry_44) .. so I believe that Gmaps OTA is actually sending me the WRONG 2.0.3 version (the one for phones w/o internal GPS - and that's why it is looking for the BT devices!!!!) - hey .. why don't you send me your axl and cod files so i can try your version !!!!!

    - in the mean time -
    I installed version 2.01 and it works within 3 meters so ..

    here's a crazy idea .. your BT GPS works with 2.0.3 (2008) and
    my internal works with version 2.0.1 (2007) ..
    maybe we should not mess with it anymore !!


    P.S.
    This is the menu and the accuracy with last year's 2.0.1 installed (and i am actuall inside!!)



    but it would be interesting to test if your alx file w/o the BT in the menu would actually work with my cell (and i can send you my axl file too).
    Last edited by APcell; 04-23-08 at 06:58 PM.
    04-23-08 06:46 PM
  14. APcell's Avatar
    when i go to www_google_com/gmm
    using my cell's browser .. the server recognizes my phone as "BlackBerry 40"



    -- This is the 2.0.3 (2008) version (with Bluetooth in the menu) that does not recognize my gps !!


    What do you see when you go to that website (using your 8830) ???
    Last edited by APcell; 04-23-08 at 06:58 PM.
    04-23-08 06:55 PM
  15. FF22's Avatar
    Verizon 8830 here. I went to the site and it offers

    V 2.0.3 for BB 42 (yes, FORTY-TWO) whatever that is!

    I already have Gmaps but how do I find which version - there does not appear to be a Help-about??

    edited to add: BB-Options, Advanced, apps, show 2.0.3
    Last edited by F2; 04-23-08 at 07:23 PM.
    04-23-08 07:20 PM
  16. APcell's Avatar
    Verizon 8830 here. I went to the site and it offers

    V 2.0.3 for BB 42 (yes, FORTY-TWO) whatever that is!

    I already have Gmaps but how do I find which version - there does not appear to be a Help-about??
    - interesting -

    to check your version go to: Main Screen - Options - Adv. Options - Applications ... find Google Maps, and check next to it .. you will most likely see 2.0.3

    NOW .. if you DO have the 2.0.3 .. in the Gmap's menu .. do you see the "Bluetooth GPS" option or not ??

    Also .. can you send me the axl and cod files so i can install that in my 8310 ??
    Last edited by APcell; 04-23-08 at 09:57 PM.
    04-23-08 07:26 PM
  17. jeffh's Avatar
    I get the same result as F2. (version 2.0.3) on your blackberry 42. Because I downloaded OTA, I don't have the alx and cod files on my pc. Also, those don't appear to be allowed attachments for uploading. I tried to see if I could d/l GMM to my desktop pc, but it just takes me to the desktop application, so I can't find any way to get a copy of my files to send to you.
    04-23-08 11:22 PM
  18. FF22's Avatar
    - interesting -

    to check your version go to: Main Screen - Options - Adv. Options - Applications ... find Google Maps, and check next to it .. you will most likely see 2.0.3

    NOW .. if you DO have the 2.0.3 .. in the Gmap's menu .. do you see the "Bluetooth GPS" option or not ??

    Also .. can you send me the axl and cod files so i can install that in my 8310 ??
    NO Bluetooth option in the menu!!! Sorry. Maybe the software is adaptable and shows only necessary options.
    04-24-08 12:03 AM
  19. APcell's Avatar
    I get the same result as F2. (version 2.0.3) on your blackberry 42. Because I downloaded OTA, I don't have the alx and cod files on my pc. Also, those don't appear to be allowed attachments for uploading. I tried to see if I could d/l GMM to my desktop pc, but it just takes me to the desktop application, so I can't find any way to get a copy of my files to send to you.
    I also tried to find a zip-version of those files but i couldn't .. so, there are "different" 2.0.3 versions (based on BB model) .. but i think we (may) both have the wrong one .. as in, you may like that feature that lists all your BT devices .. and i would definitely like to have the internal gps working.

    on the other hand, yours works, mine doesn't !
    04-24-08 12:37 PM
  20. APcell's Avatar
    NO Bluetooth option in the menu!!! Maybe the software is adaptable and shows only necessary options.
    If that 2.0.3 version is "adaptable" it really adapted the wrong way over here .. cause i don't have the right features.
    On the other hand, version 2.0.1 (without the Bluetooth option in the menu) works !!

    I have been checking online and OTA and I just can't get away from downloading that same version .. i used Google Updating software, google.com/gmm, google.com/gml, same 'ol .. no luck ..

    IS THERE ANYONE THAT HAS v.2.0.3 without the Bluetooth option in a zip file ???
    04-24-08 12:42 PM
  21. etervotion's Avatar
    just a random thought. Not too familiar with the "service book' stuff but could that be the option? I see that you are on tmobile. i have the 8310 curve and on att and my 2.03 doesn't have the bluetooth gps. I did get it from the google.com/gmm (or whatever it was) and downloaded ota. I did remember a post that says don't use it with the packaged version from google updater. I am also running 4.5.0.18 and everything works perfect. It might take a couple of minutes (sometimes not even that long) to find me but overall it does a great job. Occasionally i would have to go to options -> Advanced Options -> Gps -> refresh gps location to see how many satellites and to see if it can pinpoint me. Once i see that, i just launch google maps.
    04-24-08 12:58 PM
  22. APcell's Avatar
    i have the 8310 curve and on att and my 2.03 doesn't have the bluetooth gps. I did get it from the google.com/gmm and downloaded ota. I am also running 4.5.0.18 and everything works perfect.
    Yes, i am on T-mob, OS 4.5.18, my OTA (and G-updater) both send me the same 2.0.3 version with the BT option in the menu ..

    - wait ! - you just hit the nail on the head !!
    I just recalled that T-mob only provides Berry 8320 wifi .. no gps .. and FOR THAT REASON .. i am sent the Bluetooth version when i log into google/gmm !!
    So it is not phone specific .. it is carrier specific !!

    My Berry is unlocked .. so if i could find an ATT sim card i would be ok .. !!

    Can you locate your axl/cod files in your PC, zip them and then email me at AntP1234 @ hotmail . com ??

    Either way .. thanks Etervotion .. good point !!
    04-24-08 01:12 PM
  23. etervotion's Avatar
    i downloaded ota but i will see what i can do to find you a copy of the one that i am using.
    04-24-08 01:24 PM
  24. APcell's Avatar
    Get version 2.0.3 (40 - with Bluetooth option and no internal GPS) here:

    http://google.com/gmm/apps/v2.0.3/L1/BlackBerry-40/GoogleMaps.jad?make=BlackBerry&model=40&ver=v2.0.3

    Get the 2.0.3 (42 - with internal gps functional for BB 8310) from here:

    http://google.com/gmm/apps/v2.0.3/L1/BlackBerry-42/GoogleMaps.jad?make=BlackBerry&model=42&ver=v2.0.3

    both links are for OTA intallation files. (i.e. jad files - i.e. you need to type all that in your cell's browser)



    P.S.
    I think that Google should (1) let us download whatever we need instead of sending us what they THINK is right (that is based on the carrier - in my case T-Mob - i would always get the #40 version of 2.0.3) and ..
    (2) PLEASE let us download the zip files and possibly older versions too .. why should OTA be the ONLY way to install ??
    Last edited by APcell; 04-24-08 at 08:33 PM.
    04-24-08 08:22 PM
  25. etervotion's Avatar
    Here's a link for the 2.03 (40) with bluetooth
    http://tinyurl.com/54bbzv

    Here's the 2.03 with (42) internal GPS
    http://tinyurl.com/4zwtr2

    Same exact link that apcell posted. Its just in an easier to type version. I figure source link is already posted so lets give our thumbs a break haha.

    I tried to back up the one i had apcell but apparently ya beat me to it.
    04-24-08 08:52 PM
46 12
LINK TO POST COPIED TO CLIPBOARD