1. nastyboy2's Avatar
    my UMA started working today. the only thing i did was follow the troubleshooting steps below. i'm not sure if this is what fixed it, but when i woke up this afternoon my UMA was on.

    under the help section at mobile.blackberry.com, i followed the instructions for troubleshooting uma problems. pull up the page on your bb and click on help and then click on hotspot@home(uma) is not working. then click on the install root certificate and the install trust certificate then reboot.

    HotSpot @Home (UMA) Troubleshooting

    If you recently restored data from your previous BlackBerry smartphone to your new BlackBerry Curve™ 8320 smartphone, HotSpot @Home (UMA) might not work as expected and your device may not be able to make a UMA connection. In this case, you won’t be able to make voice calls over Wi-Fi, and you won’t see “UMA” displayed on the home screen. To resolve this issue follow the instructions below to install new root and trust certificates. Here are additional ways to determine if your device has this problem.


    • When you are prompted, click OK and Yes.
    • When you are prompted to enter a password, type "blackberry".

    1. To install the root certificate:
    • Click Install Root Certificate.
    • Next, click the "Import" button and follow the instructions on the screen. When prompted, choose to trust the certificate.
    • When complete, and you only see a "View" button on the screen, press the Escape key to return to this page.

    2. To install the trust certificate:
    • Click Install Trust Certificate.
    • Next, click the "Import" button and follow the instructions on the screen.
    • When complete, and you only see a "View" button on the screen, press the Escape key to return to this page.

    3. Remove and reinsert the battery to reset your device.

    Please note: To avoid this problem in the future, if you need to restore from a backup of an older BlackBerry device, use Advanced Backup and Restore, and de-select the “Handheld Key Store” and “Trusted Key Store” databases.
    05-23-08 09:20 PM
  2. sunkast's Avatar
    Fix for what problem?
    05-23-08 09:28 PM
  3. nastyboy2's Avatar
    UMA doesnt work with os only wifi shows up.
    05-23-08 09:36 PM
  4. sunkast's Avatar
    Ahh. That's not surprising at all then considering the software is still in development.
    05-23-08 10:53 PM
  5. Reed McLay's Avatar
    Thank you for that information. I had seen the instructions to avoid doing a restore from an older configuration, but it ended with instructions to call T-Mobile support to restore the connection.

    This is not unique to v4.5, it also happens to the production versions.

    05-24-08 09:57 AM
  6. sgt-d's Avatar
    no uma in .37 (yet).

    i originally had .37 running for 24 hours with no uma, so i went back to .18.

    i found your post today and tried .37 again... this time i started with a manual backup that i told not to include the handheld and trust key stores. during the upgrade i told it not to backup/restore my device. the flash went in perfectly. after that i restored my device with my custom backup. no uma.

    i manually deleted the t-mobile certs, then rebooted. then i went to the blackberry home page, help and followed the link for uma problems. finally i installed the root certificate followed by the trust cert. no uma.

    w006.8 / t-mobile network error

    no love. :/
    05-24-08 01:13 PM
  7. mettleh3d's Avatar
    After some users reported that the memory leak/battery problem wasn't solved in the slightest, hey, .18 ain't all that bad.
    05-24-08 01:21 PM
  8. sgt-d's Avatar
    .18 was ok, but i can't tell you how many times my phone said "off" instead of "edge". i was constantly having to disable and re-enable all connections.

    .10 was better in that regard, but worse with memory imo.

    aside from their issues, at least uma worked.

    i'm going to let this (.37) go for 24 hours and just see if the uma problem corrects itself.

    i called t-mobile and had them reset my network but that didn't help either.

    maybe it just takes time, who knows. :/
    05-24-08 01:50 PM
  9. nastyboy2's Avatar
    my uma worked all day yesterday. today it doesnt work. i tried all those steps too.
    05-24-08 09:23 PM
  10. nastyboy2's Avatar
    finally got uma back with os .37 after trying all day. here are the steps i took.
    go into options, then security options then certificates.
    delete the 2 t-mobile usa inc listings.
    it will ask you to enter a password before removing keystores.
    go into options, then advanced options, then service books.
    delete the 2 wifi tcp/ip entries.
    reboot the curve.
    the 2 wifi tcp/ip entries in service book will reappear after the reboot.
    go to mobile.blackberry.com with the bb browser and click on help.
    click the hotspot@home(uma) is not working link and follow the instructions to install the root certificate and the trust certificate.
    reboot again and see if you have uma.

    if it doesnt work, an extra step to try would be to go into advanced options then host routing table and hit menu then register now to resend service books to your device.
    Last edited by nastyboy2; 05-25-08 at 04:13 AM.
    05-25-08 04:01 AM
  11. sgt-d's Avatar
    @nastyboy2: no luck here. i deleted the service books and the certificates, then rebooted. the service books showed up automatically. i went to the blackberry uma help page and reinstalled the root and trust certs, then rebooted. still no uma. i haven't seen uma one time in .37. all i get is w006.8 "t-mobile network error".
    05-25-08 10:13 AM
  12. sgt-d's Avatar
    @nastyboy2: i tried again, this time re-registering right after deleting the certs and books. still nothing.

    incidentally... you are the only person i've heard of with working uma in .37. early reports showed several people that had it working, but later they all recanted once they saw they too had the w006.8 error in wi-fi diagnostics.
    05-25-08 10:36 AM
  13. agitprop's Avatar
    Just a friendly warning to you all trying this fix. For some reason I buggered up my sim card when I rebooted had to go today and get a new one from tmo (no charge but fone was down for twelve hours). Be very carefull I happened after the reboot from deleting the service books. Downgraded to 4.2.2 but no change. Just be careful folks. Oh and no UMA lol I dont regret trying but could had a little better timing on my part
    05-25-08 03:35 PM
  14. sgt-d's Avatar
    i upgraded my linksys to dd-wrt v24 voip (final), no change, but didn't think it would help.

    back on .18, uma works fine
    05-25-08 11:02 PM
  15. agitprop's Avatar
    Here is the latest: Even after the sim card debacle I decided to upgrade my bb back to beta .37 (I know I'm a ****) Anyway, when I was done UMA worked! But is was unusable in terms of sound quality (very quantized.) So I shut it off and made a regular wireless call. This morning I turned it back on and it showed up. Then I did a soft reset and it went away. I am wondering if rim disabled it in this beta cause of quality issues and we are accidently turning it on sometimes?
    05-26-08 10:43 AM
  16. sgt-d's Avatar
    just to make sure we are comparing apples to apples:

    are we all using the same exe?

    the only way to confirm this is by verifying the md5.

    my md5: 222fd0a80ffd63fb946597e7f1d50506

    you can use md5summer to get the md5 for your exe.


    also, still no uma here, i even attempted a voip version of dd-wrt to no avail.
    05-26-08 02:31 PM
  17. sgt-d's Avatar
    er, i also re-installed after deleting the vendor.xml as mentioned on other posts. no uma.

    i'm done with .37 until there is a working solution. :/
    05-26-08 06:47 PM
  18. agitprop's Avatar
    Okay here is the latest latest. I got to thinking (always dangerous in my case), That UMA worked after I did an upgrade from 4.22 to 4.5 directly. And died after I did a soft reset. So you guessed it I downgraded to 4.22 and the upgraded to and it worked!. Only took 3 hours to do it.
    Anyway YMMV good luck with the info
    05-27-08 11:29 AM
  19. absoluteevel's Avatar
    The VOIP version of DD-WRT just includes a SIP server... It has nothing to do with UMA.
    05-28-08 06:33 PM
  20. Icedout20's Avatar
    I have noticed when watching the UMA trying to establish a connection that the Ip address that is displayed in the Security Gateway Address is Then it will display a URL and that URL resolves to This could have something to do with the issue.
    05-29-08 11:45 AM
  21. sgt-d's Avatar
    i found a real working solution to the uma problem...

    06-08-08 03:41 PM
  22. jhard's Avatar
    i found a real working solution to the uma problem...

    Haha I was just gonna write that
    06-08-08 03:45 PM