1. kahj1975's Avatar
    I have a Bold 9700, and I remember only looking at WiFi phones because I was sold on the fact that when there was no signal (frequent occurrence since I am with AT&T...), you could still access data (browser, email, etc.).

    Lately I've been wanting to access data when I have no signal and the browser doesn't work, I can't send/receive email. The WiFi is connected to my home network, but none of these work. Anybody know why? Is it a setting on my phone I am missing? Or do you need a signal to use WiFi? If that is the case, then I don't see a point in needing WiFi on a phone...

    Let me know if I am missing something...
    11-28-10 04:34 AM
  2. thompson_704's Avatar
    I'm assuming you have a data plan, if you don't that's your problem right there. You need a data plan in order to use wifi, I'm sending this message with my radio turned off just to prove it does work

    Posted from my CrackBerry at wapforums.crackberry.com
    11-28-10 05:05 AM
  3. kahj1975's Avatar
    Yes I have an unlimited data plan
    11-28-10 05:07 AM
  4. kahj1975's Avatar
    WiFi Logo is white and black (sorry I initially missed the last part of your reply)
    11-28-10 05:09 AM
  5. Motorcycle Mama's Avatar
    Is your data working correctly when you DO have a cell signal?
    11-28-10 07:40 AM
  6. techjunkieforlife's Avatar
    Your SIM card also has to be in, even if the radio is switched off you need it. You can't even allow it to connect over wifi then rip out the SIM card as it drops connection.

    I would check your router settings to make sure you are connected, check this on the phone also. You can be connected to the router but not the internet, maybe you have IP assignment restricted or MAC addresses?

    The wifi logo will be black and white when connected and greyed out when on but not connected to BIS.
    11-28-10 08:29 AM
  7. Branta's Avatar
    Select Manage Connections / WiFi Options, then click the menu button and select WiFi Tools / WiFi Diagnostics.

    Scroll down to BlackBerry Infrastructure section and see if you have any clues there. You should have a valid address, IP address, and green checkmarks next to the Authenticating Router and Authenticating Server entries.
    11-28-10 02:22 PM
  8. Kehjj04#CB's Avatar
    Hm. I have verizon but my WIFI works wonderfully in my house (good thing because i get no service)
    11-28-10 02:32 PM
  9. crackcookie's Avatar
    I have a Bold 9700, and I remember only looking at WiFi phones because I was sold on the fact that when there was no signal (frequent occurrence since I am with AT&T...), you could still access data (browser, email, etc.).

    Lately I've been wanting to access data when I have no signal and the browser doesn't work, I can't send/receive email. The WiFi is connected to my home network, but none of these work. Anybody know why? Is it a setting on my phone I am missing? Or do you need a signal to use WiFi? If that is the case, then I don't see a point in needing WiFi on a phone...

    Let me know if I am missing something...
    You can't access RIM data on just wifi, I think you need your signal to get that. I think that is your problem.

    You have to use the wifi browser, and access your email through there.
    11-28-10 03:53 PM
  10. K Bear's Avatar
    You can't access RIM data on just wifi, I think you need your signal to get that. I think that is your problem.

    You have to use the wifi browser, and access your email through there.
    Yes you can if your provider and device allow UMA.
    11-28-10 04:04 PM
  11. kahj1975's Avatar
    I think the problem may be solved. I visited an ATT store today to ask them about it. They did not have WiFi working in the store, but showed me that even though my phone showed my wireless network name that it still may not have been connected. Visiting family today, I tried it with their wireless network, starting from scratch, entering the security key, and everything works fine, I can access browser and send email. Once I get home, I will try again from scratch and see if it works. Thanks for the suggestions!
    11-28-10 04:40 PM
  12. Branta's Avatar
    You can't access RIM data on just wifi, I think you need your signal to get that. I think that is your problem.
    Wrong!

    BIS data is available over wifi, I have even used it over a satellite TCP/IP link from a ship at sea with the nearest cellular service hundreds of miles away. If your phone has a wifi connection established you can turn the cellular connection Off (Manage Connections) to prove - just send a test email to yourself.
    Laura Knotek likes this.
    11-28-10 04:59 PM
  13. DoctorNeutron's Avatar
    Options/Advanced Options/Browser...Both entries need to be "Internet Browser", N'cest Pas ?
    When you do get it working and then things start going South, even after a real battery pull, just
    reach over to your WiFi's power cord and pull it out and leave it out for 1 minute. Doctor Neutron
    Last edited by DoctorNeutron; 11-28-10 at 05:46 PM. Reason: more info
    11-28-10 05:43 PM
  14. kahj1975's Avatar
    So I thought it was solved and it's not. It's weird, at 2 other houses, I was able to disable and re-enable the connection and the WiFi symbol is lit up. However, when I got home, I tried the same thing, and I get the same problem I initially wrote about. The WiFi symbol is actually grayed out, not lit, but I see my Wireless SSID name shown, but I still cannot view web pages or send email when I turn off Mobile Network and turn on WiFi . This is frustrating. I guess there is some setting I am missing for my home router, but not for the other 2 houses I visited today.

    This week I will try calling AT&T to see if they can help at all. Anyone else have any suggestions? Thanks,
    11-28-10 11:53 PM
  15. pbflash's Avatar
    Have you tried rebooting your router? I used to have to do this about once a week with my old router when I had my 9000.
    11-28-10 11:59 PM
  16. Laura Knotek's Avatar
    So I thought it was solved and it's not. It's weird, at 2 other houses, I was able to disable and re-enable the connection and the WiFi symbol is lit up. However, when I got home, I tried the same thing, and I get the same problem I initially wrote about. The WiFi symbol is actually grayed out, not lit, but I see my Wireless SSID name shown, but I still cannot view web pages or send email when I turn off Mobile Network and turn on WiFi . This is frustrating. I guess there is some setting I am missing for my home router, but not for the other 2 houses I visited today.

    This week I will try calling AT&T to see if they can help at all. Anyone else have any suggestions? Thanks,
    Did you try rebooting your router?
    11-29-10 12:00 AM
  17. kahj1975's Avatar
    I tried rebooting it last night with no luck. I will be checking with ATT tonight. I tried going through all advanced options, but still have the problem. I am actually sending this reply on my netbook, using my home WiFi network, but for some reason it's not working on my phone...
    11-29-10 07:59 AM
  18. kahj1975's Avatar
    Select Manage Connections / WiFi Options, then click the menu button and select WiFi Tools / WiFi Diagnostics.

    Scroll down to BlackBerry Infrastructure section and see if you have any clues there. You should have a valid address, IP address, and green checkmarks next to the Authenticating Router and Authenticating Server entries.
    I looked at WiFi Diagnostics, and under BB Infrastructure, I see a red X next to "Connecting". Also I see a slanted gray line next to "Authenticating router" and "Authenticating server". However under the WiFi category I see a green check next to "Association" and "Authentication"

    I also heard someone say reboot my router. I tried to unplug, wait some time and replug in, but no luck. Is there anything else I need to do to reboot it?

    I called AT&T, and they were no help whatsoever, didn't even suggest any settings for me to look at...5 minutes of my life I can't get back. I'm willing to try anything at this point. Maybe I just need a new router. My current router is pretty old...
    11-30-10 12:11 AM
  19. dannylill1981's Avatar
    the problem is with your router not you bb service, if your getting the grey symbol and you SSID that means your connected to your router but the phone cannot connect to bis through your router. your carrier wont be able to help as the problem is on your router as youve already proved by visiting friends/family and having it work at there houses. sorry im not sure how best to help you......
    Last edited by dannylill1981; 11-30-10 at 05:03 AM. Reason: spelling
    11-30-10 05:02 AM
  20. kahj1975's Avatar
    Problem solved. I spent 5+ hrs last night getting frustrated with my old router and adjusting settings with no success. Then I rolled down to Best Buy after work tonight, bought a new Belkin N router, and setup took less than 10 minutes, and the WiFi now works on my Bold 9700! Thanks for all the responses!
    11-30-10 09:30 PM
LINK TO POST COPIED TO CLIPBOARD