1. tommybowler's Avatar
    Bought a blackberry the other day. The internet seemed really slow (as if it was using the gprs) I had the wifi connected to my broadband (16mb/s). Anyway to check that the wifi card (in the phone) was working properly I turned my mobile network off. So it was just the wifi trying to access the internet. Anyway I tried to connect to the internet solely using wifi and I got an error message "The radio on the device is currently turned off (Which it isn't) or the battery is too low (Full battery and tried plugging in and restarting) for the radio to be used. As a result the browser cannot retrieve any web pages...bla bla bla charge ur phone contact ur service provider etc.)" So The GPRS is working and connecting my mobile to the internet however when I want to do some more heavy browsing and I connect to my home network, it doesn't connect. Can anyone help me? Sorry about how lengthy this message is, I just thought I would explain the problem properly as to reduce everyones time. Thank you in advance.
    06-30-10 04:36 PM
  2. tommybowler's Avatar
    also forgot to mention when I connect to the wi-fi i only get a white dash and not a green tick. Please help even if its only a suggestion!
    06-30-10 05:02 PM
  3. jospringfield's Avatar
    I'd really appreciate it if one of you techies out there had an answer to this - I've got exactly the same issue. I'm connected to the network, the network name is shown at the top of the screen - got an IP and mac address and can see the blackberry (curve)on the router, but as soon as the GPRS is switched off, I get the 'radio is turned off or battery too low' message. and it refuses to use the wifi connection it has.
    08-16-10 08:03 AM
  4. xpdamus's Avatar
    If you get the message about the radio being turned off, then it is true - the mobile network radio is turned off, you switched it off!

    Its giving you this message because although your wifi SSID is displayed, the phone has timed-out in trying to use the wifi, and has tried to fall back to the mobile network connection (which you've switched off) and rightly so gives you the message that the radio is switched off.

    It is my understanding that you only get the green tick if your blackberry has successfully connected to the blackberry infrastructure via the rcp.eu.blackberry.com ssl port 443 (replace 'eu' with your locale) this address is used to connect securely for BIS or BES to connect via WIFI (instead of GPRS or 3G)

    I've found that when other devices on my wifi network are connected using a secure pin/pin code to my router, that this ssl connection drops. It may be just my router, i'm not sure, but i've narrowed down this issue for me.

    I have to disconnect other devices using wifi and reconnect my blackberry by cycling the wifi connection on and off.

    HTH.
    08-25-10 02:11 PM
  5. valentin567's Avatar
    might be wrong answer
    did you tryed in your browser config and general config in browser to turn to hotspot instead of internet
    sory if dont helped
    some aplications like some radios have wifi option or prefer wifi if conected so this might be issue
    09-03-10 01:39 PM
LINK TO POST COPIED TO CLIPBOARD