1. ninjastu's Avatar
    how do you get your 8310 to show your own phone number in `phone`
    i am on o2 and it just says `my number : unknown number`
    05-27-08 04:01 PM
  2. WJRobbins's Avatar
    Go to Call Log, Select Options with your Menu key, under General Options change Show "My Number" to yes.
    05-27-08 04:05 PM
  3. perkyaim99's Avatar
    My phone # shows up in the call log.
    05-27-08 04:08 PM
  4. Panja's Avatar
    Go to options > advanced options > sim card > press the blackberry key (menu key) than choose "edit sim phone number"
    Fill in your phone number and press enter.

    Voila... In the phone application it should show your phone number now.
    .
    Last edited by Panja; 05-27-08 at 04:35 PM.
    05-27-08 04:09 PM
  5. ninjastu's Avatar
    Go to options > advanced options > sim card > press the blackberry key (menu key) than choose "edit sim phone number"
    Fill in your phone number and press enter.

    Voila... In the phone application it should show your phone number now.
    .
    fantastic it works thank you...been puzzled over this one for a while
    05-27-08 05:37 PM
  6. jcj1's Avatar
    you have to goto options, advanced options, sim card, press menu and edit sim phone #
    05-27-08 05:47 PM
  7. steveyork136's Avatar
    you have to goto options, advanced options, sim card, press menu and edit sim phone #
    what if that doesn't work?
    I've just unlocked my curve from orange and put in my O2 sim, but the number its displaying in the Sim Card menu is too long by 6 numbers, when I try to edit it says writing but then just displays the same incorrect number.

    any suggestion welcome
    10-11-08 02:36 AM
LINK TO POST COPIED TO CLIPBOARD