1. BeezDeep's Avatar
    I tried searching for the answer to this but couldn't find anything. In a nutshell- since my upgrade to 6.0.431 I have to shut off the WiFi in order to get anything onto the browser. I don't live in an area where my 3G is particularly strong so it would really help if I could use the WiFi. Any thoughts on how to get past this?

    Note that I've already tried deleting and reconnecting to my WiFi service which worked fine... and there's no problems with my 9650 detecting my SSID. I just can't browse! Thanks
    01-28-11 02:50 PM
  2. ealvnv's Avatar
    try deleting the wifi profile and rebooting the phone, then do wifi scan and re add wifi profile.... also rebooting the wifi router might help
    01-28-11 03:01 PM
  3. BeezDeep's Avatar
    Thanks man... tried this but still doesn't work. Other suggestions?
    01-30-11 05:33 PM
  4. JediSquirrel's Avatar
    My friend is having the same issue. Works fine on 3G, but when he connects to his wi-fi network the browser stops working (times out when trying to get to a page). Other wi-fi functions, such as sending and receiving BBMs while on the phone work properly. He's tried deleting the wi-fi profile and rebooting. He's also resent the service books and registering the host routing tables, even though they should be unrelated to the wi-fi problem, but we are trying everything. He's on verizon with the official install loaded. He did not have a prior leaked version of 6 installed if it matters.

    Any suggestions would be welcome!
    01-30-11 10:41 PM
  5. bodeb's Avatar
    Check your browser setup in Options and see what it is set to. I recall that if it is Hot Spot you may have problems.
    01-30-11 11:11 PM
  6. JediSquirrel's Avatar
    Check your browser setup in Options and see what it is set to. I recall that if it is Hot Spot you may have problems.
    The 9650 doesn't have that option. I think that was on the Pearl.
    01-30-11 11:22 PM
  7. 7scarabs's Avatar
    The 9650 doesn't have that option. I think that was on the Pearl.
    Sure it does...

    Options/Advanced Options/Browser/Default browser configuration.
    01-31-11 12:12 AM
  8. Goldthorn's Avatar
    I have this problem I called sprint and they in turn transferred me to RIM. Sprint blames RIM. RIM blames sprint. I just want to go back to os 5 and when this problem is fixed, just post on the board then I will upgrade again.
    01-31-11 03:10 AM
  9. JediSquirrel's Avatar
    Sure it does...

    Options/Advanced Options/Browser/Default browser configuration.
    not under OS6 - you can't get to "advanced options" by clicking on Options anymore and I can't find and advanced options anymore. I went into the browser and clicked options from the menu in there and there isn't an option to switch from anything to hotspot or vise versa.
    01-31-11 07:50 AM
  10. edwingmel's Avatar
    Same problem here. When I use WiFi browser won't work. I can send email and messages but I get the timeout message when using browser.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-31-11 10:33 AM
  11. Culex316's Avatar
    Try wiping and re-loading the OS
    01-31-11 10:40 AM
  12. edwingmel's Avatar
    No thanks. I can live without it.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-31-11 10:44 AM
  13. JediSquirrel's Avatar
    New development for my friend. Browser works fine on his work wi-fi but not his home. Going to have him try rebooting his router at home after work...
    01-31-11 10:46 AM
  14. e_lochry's Avatar
    This is the same problem I've been having since I loaded os6.and still,nothing has worked.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-31-11 01:29 PM
  15. Din-Toran's Avatar
    Most of you are probably familiar with this issue... You upgraded to OS6 and basically lost the ability to use WiFi. Since then you've had it disabled to make your phone usable again or went back to OS5.

    Well today I spend 4 hours on the phone with upper level Verizon data techs and blackberry techs working on this together. Guess what? We fixed it.

    In the end, the answer was so simple it wasn't even funny, but I'll just cut to the chase here, skip the long story and tell you how to fix it.

    These are the exact steps that we took. the first one may not be necessary, but since this method fixed it, I won't leave it out.

    1. go into the main Options, (by clicking at the very top of the screen), and disable the Mobile Network. (Leave Wi-Fi on)
    2. Go to Options > Device > Advanced System Settings > Click on Service Books to open it.
    3. Under Service Book, there are two Wi-Fi TCP/IP service books. Delete both of them.
    4. Exit Service Books so that you are back in Advanced System Settings and open Host Routing Table
    5. Push the Blackberry button to bring up the menu and select "Register Now"
    6. Exit back to the main screen and go into the settings to turn your wireless network back on. (you will get a message about registering on the network)
    7. Pull the battery off of your phone, wait 30 seconds and re-instert it.
    8. Phone boots up, give it a minute or two.
    9. Go back into settings, turn off Wi-Fi, wait a minute and then turn it back on.
    10. Exit back to the main screen and enjoy a working Wi-Fi network again.
    jerry12 and Jtlogan like this.
    03-17-11 06:17 PM
  16. oceandigital's Avatar
    Thanks Din-Torn, that looks useful although I have not tried it yet.

    Does this solution work for Blackberry's without a dataplan?
    03-19-11 09:19 PM
  17. e_lochry's Avatar
    thank you for the time you spent dealing with this issue.however,i tried it step by step 3 times and the problem is still there.
    03-22-11 08:14 PM
  18. BeezDeep's Avatar
    You cant actually follow it exactly because one can't send out a registration with the network off. Trying it thought. Fingers crossed.
    03-27-11 01:16 AM
  19. BeezDeep's Avatar
    And by the way Din-Toran: you can delete the service books but they always come back after a reboot. As the 2 wifi lines did. The wifi had previously started working after awhile on it's own. I just need to know how to get the rest of the damn bugs out of 6. My top solution is to go back to os5.
    03-27-11 01:26 AM
  20. Jtlogan's Avatar
    Thanks, Din-Toran. This worked for my Sprint 9650. You have found the solution to a problem that kept thousands of people from using their WiFi!
    04-07-11 01:27 AM
  21. byalican's Avatar
    thanks din-toran ,but @ step 6 i dont get a message about reg. on the network!!

    what can i do?
    04-18-11 04:58 PM
  22. cesonmez's Avatar
    Most of you are probably familiar with this issue... You upgraded to OS6 and basically lost the ability to use WiFi. Since then you've had it disabled to make your phone usable again or went back to OS5.

    Well today I spend 4 hours on the phone with upper level Verizon data techs and blackberry techs working on this together. Guess what? We fixed it.

    In the end, the answer was so simple it wasn't even funny, but I'll just cut to the chase here, skip the long story and tell you how to fix it.

    These are the exact steps that we took. the first one may not be necessary, but since this method fixed it, I won't leave it out.

    1. go into the main Options, (by clicking at the very top of the screen), and disable the Mobile Network. (Leave Wi-Fi on)
    2. Go to Options > Device > Advanced System Settings > Click on Service Books to open it.
    3. Under Service Book, there are two Wi-Fi TCP/IP service books. Delete both of them.
    4. Exit Service Books so that you are back in Advanced System Settings and open Host Routing Table
    5. Push the Blackberry button to bring up the menu and select "Register Now"
    6. Exit back to the main screen and go into the settings to turn your wireless network back on. (you will get a message about registering on the network)
    7. Pull the battery off of your phone, wait 30 seconds and re-instert it.
    8. Phone boots up, give it a minute or two.
    9. Go back into settings, turn off Wi-Fi, wait a minute and then turn it back on.
    10. Exit back to the main screen and enjoy a working Wi-Fi network again.
    Unable to find requested server. damn it
    05-21-11 05:55 AM
  23. jerry12's Avatar
    Most of you are probably familiar with this issue... You upgraded to OS6 and basically lost the ability to use WiFi. Since then you've had it disabled to make your phone usable again or went back to OS5.

    Well today I spend 4 hours on the phone with upper level Verizon data techs and blackberry techs working on this together. Guess what? We fixed it.

    In the end, the answer was so simple it wasn't even funny, but I'll just cut to the chase here, skip the long story and tell you how to fix it.

    These are the exact steps that we took. the first one may not be necessary, but since this method fixed it, I won't leave it out.


    1. go into the main Options, (by clicking at the very top of the screen), and disable the Mobile Network. (Leave Wi-Fi on)
    2. Go to Options > Device > Advanced System Settings > Click on Service Books to open it.
    3. Under Service Book, there are two Wi-Fi TCP/IP service books. Delete both of them.
    4. Exit Service Books so that you are back in Advanced System Settings and open Host Routing Table
    5. Push the Blackberry button to bring up the menu and select "Register Now"
    6. Exit back to the main screen and go into the settings to turn your wireless network back on. (you will get a message about registering on the network)
    7. Pull the battery off of your phone, wait 30 seconds and re-instert it.
    8. Phone boots up, give it a minute or two.
    9. Go back into settings, turn off Wi-Fi, wait a minute and then turn it back on.
    10. Exit back to the main screen and enjoy a working Wi-Fi network again.
    So far so good it hasn't missed a time since i did the changes but it is sill slower that it should be because i do have a fast 10 meg DSL Connection. My home computers are fast.
    06-25-11 01:10 PM
  24. jerry12's Avatar
    it work for a while and stop again.
    06-26-11 06:15 PM
LINK TO POST COPIED TO CLIPBOARD