1. DawgMan's Avatar
    Okay, I've searched and searched with no answers. I have a 9780 that was on 6.0.0.359 on AT&T. I had the bluetooth connection set for my Range Rover and it connected everytime, no problems. I also have a 9800 that was on 6.0.0.337 that I would occasionally use and it paired just fine everytime too. I recently bought another 9780, factory unlocked, and unbrandded. As soon as I received it I immediately upgraded the OS to 6.0.0.448 on both 9780's and to 6.0.0.450 on the 9800. After upgrading the OS, none of the devices would connect via bluetooth. Well that is to say they would not connect everytime. Most of the time I received a msg on the BB stating "Connection to Range Rover Failed". I downgraded one 9780 back to 6.0.0.359 and the BB connected immediately connected and paired with my car.

    If this is related to the OS, is it possible to install 6.0.0.448 back on the 9780 but use the bluetooth configuration from 6.0.0.359? And if so, how would I do that? Thanks for any help.
    02-06-11 09:06 PM
  2. LandRoverwinkel's Avatar
    Some problem here... The Land Rover Discovery 3 and Range Rover SPORT also have problems with the latest OS6-version of BlackBerry's Bluetooth.....

    But.... I have just updated my 9700 Bold with OS6.0.0.499 and the Bluetooth is a bit better... it even connects so-one-in-a-while

    Hopefully v.6.0.0.512 (or better) will be improved on this issue.


    Regards from the Netherlands,
    Goswin
    03-25-11 10:09 AM
  3. talkingcow's Avatar
    same issue here, just posted:

    "9780 used to pair perfectly with the manufacturer system on a 2007 range rover sport. Upgrading from 6.00.294 to 6.00.498 results in the phone showing "connection to LANDROVER failed". Pairing appears to work, car is discovered etc, but the process does not complete. Once in about 20 times (of starting the car) the phone will pair and be able to receive calls, but the address book is screwed up.

    Downgrading back to 294 and everything returns to normal working 100% - which is what I have chosen to do as 498 had so little to offer.

    Because RIM are so unhelpful, it is impossible to ask this question:

    "exactly what did you change between 294 and 498 in the bluetooh implementation/code that would cause the problem described above"
    04-02-11 10:57 AM
  4. LandRoverwinkel's Avatar
    Isn't there a possibility to downgrade the Bluetooth 'module' only? I noticed that more and more users are getting this problem with the new OS6 and their BB 97xx phoones.

    Not only the Land Rover owners.

    Or a good bluetooth app?
    04-04-11 02:56 AM
  5. egharo's Avatar
    I'm also experiencing problems with my BMW.
    The car's Bluetooth module locks after trying to establish a connection.
    04-04-11 07:46 PM
  6. talkingcow's Avatar
    yes it is possible to downgrade the BT only - search my posts for the thread
    04-05-11 01:47 PM
  7. jamespotter's Avatar
    I cannot pair my Bold 9700 (v6.0.0.448) with my '07 Disco 3 since I upgraded from v5 to v6. Its very annoying!
    04-14-11 03:59 PM
  8. jamespotter's Avatar
    O2 made an upgrade available today (v6.0.0.534) and when I tried to pair it with my Disco 3, it worked 1st time!
    06-02-11 03:59 PM
  9. talkingcow's Avatar
    confirmed!!! run through the streets and rejoice! latest Blackberry version 6.0.0.534 restores full Bluetooth connectivity in my RR Sport!!
    06-04-11 04:23 PM
  10. LandRoverwinkel's Avatar
    confirmed!!! run through the streets and rejoice! latest Blackberry version 6.0.0.534 restores full Bluetooth connectivity in my RR Sport!!
    Unfortunately I tried the same version and they did work 1x time after a blackberry-reboot and than the same problem occurs....

    Anyone tried the latest version: version 6.0.0.576 ?
    06-05-11 05:25 AM
  11. talkingcow's Avatar
    well that is strange.. conscious of the previous problem (where it would sometimes pair but then wouldn't pair again) yesterday after upgrading i left the vehicle, walked away, and back again to check it was fully working - and it was. Did this 3 times then got bored :-). Then i just checked again this morning and... still working! Something occurred to me - are you doing a fresh link after version upgrade? I am NOT - i link it in 280 then upgrade to 534 (the bluetooth profiles persist). Could this be the key?
    06-05-11 05:57 AM
  12. BBerryBallin's Avatar
    Help! I have a blackberry bold 9700 with AT&T and upgraded my OS from 5 to 6...my phone now says it's running "6.0 Bundle 2342 (v6.0.0.526, Platform 6.6.0.195)". Prior to doing this, my bluetooth worked perfectly, but now it looks like I'm having some of the same problems as others on this forum. I'm new to this site and am not the most savvy tech guy, so if anyone can tell me if there's a version of OS 6 other the one I mentioned above that I should download and install that might help, I'd be very very thankful.
    08-16-11 05:32 PM
LINK TO POST COPIED TO CLIPBOARD