1. chibichin's Avatar
    My phone is set to Automatic but it's locked to my carrier. However, it doesn't show up the NETWORK MODE where I could chage my settings to 2G or 3G. Why is that? BTW, my phone's signal is set to SOS whatever I do. And the wi-fi stopped working after upgrading to v5. This is a brand new 8520 phone. Thanks!
    01-28-11 08:22 PM
  2. Culex316's Avatar
    Your phone is 2G only...no 3G
    01-28-11 08:37 PM
  3. albee 1's Avatar
    Pull and reinsert your sim card. If that doesn't do it try setting your network to home only.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-28-11 09:22 PM
  4. polopopp's Avatar
    Pull and reinsert your sim card. If that doesn't do it try setting your network to home only.

    Posted from my CrackBerry at wapforums.crackberry.com
    sorry,how do i set 'network to home only' ?
    01-04-12 09:29 AM
LINK TO POST COPIED TO CLIPBOARD