1. jknutter's Avatar
    I'm on my second BB 8330M from USC. When I got my first phone (also a 8330M) the GPS did not work. I followed the directions on CB and downloaded garmin's free trial which fixed the GPS. It actually worked pretty well locking quickly even sometimes indoors. My troubles started when the phone's internal speaker died. I brought the phone back to the USC store and they replaced it free of charge. Now I'm on my second 8330M and once again the GPS doesn't work. I followed all of the same steps as I did on the first one but this time nothing worked. I cannot make the GPS lock on any sats no matter what I do and an accuracy of 3200 meters in google just won't cut it. I kept both of the phones up to date so I'm sure they had the same version software - anyone have any idea on what I should do?

    Thanks in advance...
    12-27-09 09:46 PM
  2. Jimbo5000's Avatar
    You might be stuck trying plan B:
    http://forums.crackberry.com/f41/rea...v1-0-a-192999/

    If you've tried a few of the free or trial GPS options, check with your USCC customer service rep and ask for the SPC. Skip to step III-B and go from there. Also, note post #529 with the different IP and port settings to try. Good luck!
    12-28-09 11:02 PM
  3. WI_Archer's Avatar
    I have had problems with google maps on my 8530. It only finds postion from cell towers which only provides position within about a 3000 meter area. Other online posts I have read leads me to think it is a problem with google maps and not the GPS functionality of my phone. I installed Nav4All and that finds position very accurately.
    01-03-10 03:55 PM
  4. jknutter's Avatar
    Thanks Jimbo I applied the settings in both my wife's and my 8330M and the GPS is working great in both of them!
    01-14-10 01:07 AM
  5. Jimbo5000's Avatar
    Glad to hear it's working for you.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-15-10 06:58 PM
  6. jknutter's Avatar
    Oddly enough both mine and the wife's GPS quit working on our 8330M phones. I checked the GPS settings with QPST and they are OK or at least the same as they were when the GPS was working. Does anyone know if USCC has changed something?
    07-24-10 09:29 PM
  7. jeffh's Avatar
    They may have. There have been a couple of posts by USC users this week saying the GPS used to work and now doesn't. One user installed USCellular's mapping app and the GPS worked with it, but not with Google Maps.

    Here is one such link: http://forums.crackberry.com/f41/usc...ur-gps-499021/
    Last edited by JeffH; 07-24-10 at 10:04 PM. Reason: Added a link to corroborate my post
    07-24-10 09:51 PM
  8. jknutter's Avatar
    Thanks for the reply - I was doing some surfing in the USCC forum and reading up about this new nav app. Doesn't look like it is compatable with my 8330M... Or atleast I have not figured out how to load it yet.
    07-24-10 10:50 PM
LINK TO POST COPIED TO CLIPBOARD