1. Coleen's Avatar
    This is such a frustrating problem for my boss...I have been tasked with helping by tomorrow but totally out of my depth regarding caller ID. On her phone she gets all her caller names when they ring her but just the number when she receives SMS.

    I have followed the advice found on this and other forums. Content protection is off. I have even suggested that she may not have her numbers saved to her phone sim. Nothing works...please help!
    04-08-08 11:47 AM
  2. uncheels23's Avatar
    ya on mine i have to load the sim phone book before i can view who sends me the text unless they are in my address book
    04-08-08 11:48 AM
  3. Hazysky's Avatar
    Try going to the call log, hit menu key and select options. Next, select smart dialing and enter the country code.

    Also maybe enter the national number length which for example is 11 in the UK.

    This worked for me.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-08-08 12:03 PM
  4. vatsal bajpai's Avatar
    Hi everybody i found the solution to my problem : I took the the sim out and opened my phone without sim i found #smart dialing option right there in my phone app > settings . I had my country code wrong and area code missing . I also mentioned the length of phone no. In my country china ( i.e 11 by the way ) and voila it worked. After i inserted sim things became normal as in my other phones
    07-13-14 02:21 AM
LINK TO POST COPIED TO CLIPBOARD