1. levyo1's Avatar
    Hi I have a torch with the new upgrade software on it but even before the upgrade it would not connect to the wifi in my house but my old curve does I have looked at all the settings and still no luck, but the phone can see the wifi router, in fact it can see all three in my area but comes up saying "FAILED TO OBTAIN IP ADDRESS" Has anybody got any ideas? PS I put the new software in thinking it may fix the problem! Thanks
    11-14-10 04:09 PM
  2. zoom--zoom's Avatar
    Try manually connected to you WIFI
    and enter all the SSID, IP and WAP
    if you dont know your SSID call you internet provide he will be happy to help you
    11-14-10 04:18 PM
  3. Thanontos's Avatar
    Did you do a restore of the settings after the upgrade? If so, try going to your wifi connections and and delete any setting in the phone. Then try setting up the connection again.

    Also does your wifi have the same name as any in the surrounding area? I found out that the torch can only save the settings based on the broadcasted name so no duplicate "home" networks can be connected. Try changing your signal name and password if it did not work removing the settings in the phone

    Posted from my CrackBerry at wapforums.crackberry.com
    11-14-10 04:23 PM
  4. levyo1's Avatar
    yes tried all that still not connecting
    11-14-10 04:23 PM
  5. DaNewCrack's Avatar
    Could be an issue with your router. Check for firmware updates. WTF-LEFT-FIELD i know, but dlink just issued a firmware for my router that addressed blackberry wifi issues.

    i got a dlink dir615, and the firmware was updated specifically for blackberry. (a month and a half ago) I didn't believe it until I read this. Click on firmware and you'll see it left me speechless.
    11-14-10 04:34 PM
  6. kjaslow's Avatar
    There's definitely some funky business with routers and device compatibility. I bought my Torch when I was visiting family who use a Linksys router. The Wifi would connect and disconnect constantly. When I got home, I connected to my Draytek router and never once dropped the connection.

    Conversely, my MacBook connects happily to the Linksys router, but sporadically drops the Draytek. Go figure.
    11-14-10 04:47 PM