1. Saud14's Avatar
    Hello every one


    I just bought my first BB phone. It's Rogers Black Berry Bold 9000 (unlocked) and I'm using T-Mobile without a data plan. When activating the WiFi I'm not able to browse the web or BB massenger. The WiFi logo is gray and there is no check mark it's appear as dash --. Can someone help me fixing this problem I really appreciate your help.


    My first thread
    Best Regards,
    Saud14
    09-24-09 08:56 PM
  2. jd914's Avatar
    I believe you need a data plan in order to get white wifi symbol, you definately need a data plan to use Blackberry messenger.

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by JD914; 09-24-09 at 09:19 PM.
    09-24-09 09:06 PM
  3. juliankueh's Avatar
    U need BIS or BES to get BBmessenger. Go into ur BB options>advanced options>browser and select hotspot browser then u should be able to surf the internet using wifi.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-24-09 09:14 PM
  4. Saud14's Avatar
    U need BIS or BES to get BBmessenger. Go into ur BB options>advanced options>browser and select hotspot browser then u should be able to surf the internet using wifi.

    Posted from my CrackBerry at wapforums.crackberry.com

    Hello Juliank,

    I followed your instructions but it still the same issue. I cannot get connect and the WiFi logo is gray.


    Many thanks
    09-24-09 10:02 PM
  5. spitothec's Avatar
    Go into Options>Mobile Network and make sure your data is turned to On or Off when Roaming. If it is set to Off, even WiFi won't work on my Bold.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-24-09 10:57 PM
  6. Saud14's Avatar
    Go into Options>Mobile Network and make sure your data is turned to On or Off when Roaming. If it is set to Off, even WiFi won't work on my Bold.

    Posted from my CrackBerry at wapforums.crackberry.com
    Hello spitothec,

    I did what you said and now I can use the web. But I cannot use the BB messenger and the WiFi logo is still gray.

    Thank you
    09-24-09 11:53 PM
  7. jd914's Avatar
    Hello spitothec,

    I did what you said and now I can use the web. But I cannot use the BB messenger and the WiFi logo is still gray.

    Thank you
    Refer to post #2

    Better yet I'll make it easy for you

    I believe you need a data plan in order to get white wifi symbol, you definately need a data plan to use Blackberry messenger.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-24-09 11:56 PM
  8. felix baraquiel's Avatar
    please help to open my black berry bold 9000 as now can open almost 3 months please somabody help me
    02-15-15 10:58 AM
  9. ChainPunch's Avatar
    You need to explain to us what is your problem is first and have you tried contacting your carrier or the place you purchase the bold from yet?
    02-15-15 01:00 PM
LINK TO POST COPIED TO CLIPBOARD