1. BBAvatar104's Avatar
    OK I have CURVE8900, Im with Rogers, I dont have data plan because I have a prepaid card. I just got this curve, then browsing using wifi everywhere I go to. So when I'm browsing with wifi, then all of the sudden my battery was running low so I turned off my phone, then wanting to turn it back on, I forgot my pasword. Sadly my phone got blocked, so I called Rogers to get my PUK# to unblock it. After my phone was unblock, I tried to browse again using wifi and it failed, the phone required my wireless network like it showed the name of the network but it just not connected.

    Like under my "Manage Connections" everything got GREEN check marks except for my wifi.

    I tried everything that was suggested -- resending service books, calling support, resetting router/phone, checking if my router is not wep n such. Still no luck.

    Please do help.
    01-04-10 07:47 PM
  2. jlsparks's Avatar
    Don't take this wrong but: Have you tried deleting the problematic profile, rescan, reenter your WEP key, and see if it'll connect? I've noticed that, sometimes, with my S2 when connecting to a wireless network launching the browser for a minute, then closing it, seems to kickstart connectivity. Might be worth a try.
    01-04-10 07:54 PM
  3. BBAvatar104's Avatar
    I did that too but still no luck, like I deleted all the internet profile that I saved, N i also tried using different internet profile and still no luck. Do you have have anymore idea on how I can fix this problem?
    01-04-10 08:12 PM
  4. Reed McLay's Avatar
    The first step is the Wifi Diagnostics.

    Connections / Wifi Opions. Menu / Wifi Diagnostics.

    The first section is for your Wifi connection. You will see a Successful connection message or an error under Status. The error message can help diganose the connection problem.

    If you see a successful connection message:

    Options / Advanced Options / Browser. Select the Hotspot Browser as Default.

    There is a point I am not clear on:

    I forgot my pasword. Sadly my phone got blocked, ...
    If you don't know the password, there is no way the carrier can unblock the BlackBerry.
    01-05-10 10:46 AM
  5. BBAvatar104's Avatar
    I went to Wifi diagnostics, and ;
    Under Wifi everything is good and status Network aquired
    Under VPN everything is blank and status: VPN profile is not found
    I think the problem is the VPN?
    you know how to fix this?
    01-05-10 06:59 PM
  6. moofed's Avatar
    mine is like that too.. i have exactly the same situation as u
    12-18-10 10:13 PM
  7. catberryday's Avatar
    I went to Wifi diagnostics, and ;
    Under Wifi everything is good and status Network aquired
    Under VPN everything is blank and status: VPN profile is not found
    I think the problem is the VPN?
    you know how to fix this?
    Did anyone have a fix for that? I am having the same issue. My phone worked fine on my wifi then all the sudden it won't connect and I have VPN Profile not found.
    02-22-11 12:38 PM
LINK TO POST COPIED TO CLIPBOARD